VLAN Routing on Cisco 3750

Unanswered Question
Jun 15th, 2010

I have a very simple problem (I hope)

I have a Cisco 3750 with Vlan 1 ( and Vlan 200 (

I have a host ( in port 10

I have a host ( in port 45

Each host can ping its own default gateway and can ping the default gateway of the other host.

But the hosts cannot ping eachother.

Here is the config:

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname smcswa1
enable secret 5 $1$N6WZ$ggb0r1SfjXLbdPo.Rjsx41
no aaa new-model
switch 1 provision ws-c3750g-48ts
system mtu routing 1500
ip subnet-zero
ip routing
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
vlan internal allocation policy ascending

interface GigabitEthernet1/0/15
interface GigabitEthernet1/0/16

interface GigabitEthernet1/0/45
switchport mode access

switchport access vlan 200
interface GigabitEthernet1/0/46


interface Vlan1
ip address


interface Vlan200
ip address
router rip
version 2
ip classless
ip http server


line con 0
line vty 0 4
password xxxx
length 0
line vty 5 15
password xxxx

So why cant I ping the the hosts from eachother

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jfraasch Thu, 06/17/2010 - 05:19

So it sounds like everyone is in agreement that I am not an idiot and my switch is configured correctly.

I will plug another laptop in on the other side tomorrow night to see if I can ping laptop to laptop....not sure what is going on.

Since the router can ping the interface of both the laptop and server, there appears to be no firewall issue on either end host.  The hosts can ping the "other" interface of the router, but they cannot get through it to the far host...

Any more ideas?

jfraasch Thu, 06/24/2010 - 07:06

I thought I would update on what the issue was.

I had set up probably a hundred 3750's like this so I didn't think it was the routing.  It wasn't the default gateway.

So what the customer DIDN'T tell me was that the servers had a THIRD NIC that they had unplugged.  This third NIC had an IP address that sat on the network that I was adding (and on the same network from where I was pinging).

When I would ping the server from my NIC, the server would get the packet and see that its NIC that was directly connected to the network that I was pinging from (my source IP) was down since the cable was unplugged.  Doing an ICMP Debug on the 3750 gave some interesting information on traceroutes where it said that the packet TTL exceeded.

I had to remove the IP configuration from the server NIC to make it respond correctly.

Thanks for everyone's insight.  You all had the idea correct, that it was the server and not the network.



This Discussion