Unable to register CUPC with CUPS

Unanswered Question
Jun 16th, 2010
User Badges:

Hello

I have a problem in getting the CUPC client application to register with the CUPS server. I have successfully integrated CUPS with the CUCM7 which is again on AD. However when I try to login to the CUPC client, it works only as a softphone and all other features are greyed out. I checked the compatibility matrix and all three should work.


The Publisher status shows all green

Incoming Access list specified as all all in Presence




Attached are the screenshots. Please help me with this. I have a demo to present to a client on friday. Have been trying to figure this oout for many days.


Thanks in Advance.

Abraham

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2.3 (4 ratings)
Loading.
CHRIS CHARLEBOIS Wed, 06/16/2010 - 08:19
User Badges:
  • Silver, 250 points or more

The biggest concern is the red X next to Presence in the client 'Server Health' screen.  From the log you included, it looks like the client is unable to resolve the address of the CUP server.  It could also be blocked by a firewall or acl, if I'm misreading it.  But I would definitely start by trying to ping the CUPS address from the client by name and/or using the FQDN in the server field when logging into the CUP client.

abraham23482 Wed, 06/16/2010 - 12:04
User Badges:

Thanks ccharlebois ,


Your solution partially worked.. Now I am able to see the status of the user logged in... However still the chat button is greyed out..


Attached is the screehshot.

Attachment: 
CHRIS CHARLEBOIS Wed, 06/16/2010 - 12:19
User Badges:
  • Silver, 250 points or more

Don't worry about secure messaging... Unless you are using Secure Messaging within Unity or Unity Connect.  It's not something I've played with, so I have no experience troubleshooting it.


As for the TFTP error, have you defined the phone for the personal communicator with a device name of UPC within CUCM?  It's something I overlook when I was testing CUPC out myself.  These instructions are for CUPS 8, but the CUCM configuration is the same.


http://www.cisco.com/en/US/partner/docs/voice_ip_comm/cups/8_0/english/install_upgrade/deployment/guide/dgclient.html#wp1091492

salphons Thu, 06/17/2010 - 07:49
User Badges:

Hi Abraham,


From your screen shots, the issue looks like CUPC configuration file is not getting downloaded from CUCM.


Can you check the following?


1. did you create the end user in LDAP with all in upper case (Eg.CUPUSER2). Your screen shot shows that the user id is in all lower case.


2. Did you create CUPC phone device in CUCM with Device name starts with UPC followed by endusername (Eg. UPCCUPUSER2)?


3. Can you check the TFTP server configuration in CUP admin Page?


Regards,

Sumin

CHRIS CHARLEBOIS Thu, 06/17/2010 - 08:08
User Badges:
  • Silver, 250 points or more

If it were issue #1, the user wouldn't be able to login at all, so that isn't the problem.  And issue #3 is only a potential problem with CUPS 1.X and 6.X.  CUPS 7+ uses AXL to populate the TFTP field, it seems.


It's either that the softphone configuration wasn't setup, or, more likely, based on the logs, that traffic to or from the TFTP server is being blocked.


ERROR LCMiddleware - (MWMSG_CFGMGR_PARSEFAILED) TFTPConnectionImpl::connect() - Failed to download UPCCUPUSER1.cnf.xml
DEBUG LCConnection - CALLMANAGER_TFTP reportResult(DISCONNECTED): reason=UNREACHABLE, functionality=NONE


Hope this helps.  BTW, please rate posts if they are helpful.

abraham23482 Thu, 06/17/2010 - 09:19
User Badges:

Hi


I will do a packet capture while trying to login to the CUPC and figure out this. Will update you with the results.

abraham23482 Sun, 06/20/2010 - 12:07
User Badges:

I have some improvement on prsence .Sucessfully integated voice mail and Meeting place .
now i can able to do a Messenger broadcast and ather users are able recive broadcast.

But individual IM chat still not active .attached secreen shots


Thanks ,

Abraham

Attachment: 
amitkumarp Mon, 11/01/2010 - 05:10
User Badges:

Hi Abraham,


Were you able to solve the TFTP issue? I have the same issue but only with some of the Users' PC/Laptops. When I try to access those users from my laptop it works fine. It seems their personal Firewall or some other network policy is blocking that Laptop to connect with TFTP server.


Would you please let me know what did you do as a workaround for the same? Thanking you in anticipation.


Regards,

Amit.

Actions

This Discussion

Related Content