Cisco 836 ADSL over ISDN

Answered Question
Jun 16th, 2010
User Badges:

Hello.
I've been looking a lot, both at google and on this forum, but I can not find the solution. I can not configure a router 836 on a ADSL over ISDN line .
The company is Jaztel ISP, PVC 8 / 35 PPPOE.
The CD Led is on, but the PPP not.


Thank you.


Regards.


I posted the configuration:





Building configuration...


Current configuration : 3937 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname routerA
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 debugging
logging console critical
!
no aaa new-model
no ip source-route
!
!
ip cef
ip domain list test.lan
no ip domain lookup
ip domain name test.lan
ip name-server 8.8.8.8
no ip bootp server
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
isdn switch-type basic-net3
!
!
username root privilege 15 secret 5 xxxxx
archive
log config
  hidekeys
!
!
ip tcp synwait-time 10
!
!
!
!
interface Ethernet0
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$                 
ip address 192.168.2.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1412
!
interface Ethernet2
no ip address
shutdown
!
interface BRI0
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description $ES_WAN$
no ip redirects
pvc 8/35
  pppoe-client dial-pool-number 1
!
!        
interface FastEthernet1
duplex auto
speed auto
!
interface FastEthernet2
duplex auto
speed auto
!
interface FastEthernet3
duplex auto
speed auto
!
interface FastEthernet4
duplex auto
speed auto
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname xxxxx
ppp chap password 7 xxxxx
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 100 interface Dialer0 overload
ip nat inside source static 192.168.2.5 interface Dialer0
ip nat inside source static udp 192.168.2.1 161 interface Dialer0 161
ip nat inside source static tcp 192.168.2.1 22 interface Dialer0 22
!
logging trap debugging
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 23 permit xxxxxx
access-list 23 permit 192.168.2.0 0.0.0.255
access-list 100 remark SDM_ACL Category=2
access-list 100 permit ip 192.168.2.0 0.0.0.255 any
dialer-list 1 protocol ip permit
snmp-server ifindex persist
no cdp run
!
control-plane
!        
!
line con 0
logging synchronous
login local
no modem enable
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler max-task-time 5000
scheduler interval 500
!        
!
end



#show isdn status
Global ISDN Switchtype = basic-net3
ISDN BRI0 interface
        dsl 0, interface ISDN Switchtype = basic-net3
    Layer 1 Status:
        DEACTIVATED
    Layer 2 Status:
        Layer 2 NOT Activated
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x80000003
    Total Allocated ISDN CCBs = 0

My default ADSL config is always:-


!
interface atm0
no shut
no ip address
no ip directed-broadcast
no ip mroute-cache
pvc
  encapsulation aal5mux ppp dialer
  dialer pool-member 1


interface dialer1
ip address negotiated
no ip directed-broadcast
ip nat outside
encapsulation ppp
dialer pool 1
ppp chap hostname
ppp chap password
ppp pap sent-username password
!


ip nat inside source list 1 interface dialer1 overload


HTH>

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer

My default ADSL config is always:-


!
interface atm0
no shut
no ip address
no ip directed-broadcast
no ip mroute-cache
pvc
  encapsulation aal5mux ppp dialer
  dialer pool-member 1


interface dialer1
ip address negotiated
no ip directed-broadcast
ip nat outside
encapsulation ppp
dialer pool 1
ppp chap hostname
ppp chap password
ppp pap sent-username password
!


ip nat inside source list 1 interface dialer1 overload


HTH>

Actions

This Discussion