Flow Control

Unanswered Question
Jun 16th, 2010

Dear Friends,

We are not able to find command for disable FLOW-CONTROL on cisco 7206 router Gig Port (output flow-control is XON, input flow-control is XON).

Cisco_7206#sh int gi0/2
GigabitEthernet0/3 is up, line protocol is up
  Hardware is MV64460 Internal MAC, address is 001c.b0bb.d419 (bia 001d.c0cc.d728)
  Internet address is 172.168.1.77/30
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 199/255, rxload 68/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is autonegotiation, media type is SX
  output flow-control is XON, input flow-control is XON
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 2d07h
  Input queue: 0/75/7867/30 (size/max/drops/flushes); Total output drops: 1704

Cisco_7206#sh run int gi0/2
Building configuration...

Current configuration : 234 bytes
!
interface GigabitEthernet0/2
ip address 172.168.1.77 255.255.255.252
no ip redirects
no ip proxy-arp
duplex full
speed 1000
media-type sfp
negotiation auto
no clns route-cache
end

Router Model Is :-  7206VXR (NPE-G2)

We want to disable it as input errors are observed on this interface, but dopes'nt find a command for disable this.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Chetan Kumar Ress Wed, 06/16/2010 - 11:03

Hi

Please refer the below detail to disable flow control.

The negotiation command is applicable only to the Gigabit Ethernet interface of the Cisco 7200-I/O-GE+E. The negotiation auto command is used instead of the duplex and speed commands (which are used on Ethernet and Fast Ethernet interfaces) to automatically configure the duplex and speed settings of the interfaces. The negotiation forced command is used to configure the Gigabit Ethernet interface to be 1000/full-duplex only and to disable flow-control. The Gigabit Ethernet interface of the Cisco 7200-I/O-GE+E is restricted to 1000 Mbps/full duplex only. Autonegotiation only negotiates to these values.

Insted of using negotiation auto  you can use negotiation forced.

Regards

Chetan kumar

Actions

This Discussion