ACS 4.2 Remote Agent on Server 2008 R2

Answered Question
Jun 16th, 2010
User Badges:

Hi,


We are migrating our domain controllers from 2003 to 2008 R2 and would like to know if the remote agents are compatible to run on 2008 R2.  I've seen release notes that the RA's have been tested on 2008 SP1 but not R2.


Can anyone advise and/or confirm that the RA's are supported on 2008 R2?


We are currently running Solution Engine 4.2.1.15 as well as the 4.2.1.15-1 fix.  RA's are the same version.


Thanks in advance for your help.

Correct Answer by Jatin Katyal about 7 years 1 month ago

Well, this is a known enhancement bug:


CSCta35271    Support for Windows server 2008 R2


Acs 4.2.x doesn't support all newer versions of Windows 2008. It only supports the below listed version. You can also check the release notes.


Supported Operating Systems section


--Windows Server 2008, Standard Edition


--Windows Server 2008, Enterprise Edition


--Japanese Windows Server 2008, Standard Edition, Service Pack 2


--Japanese Windows Server 2008, Enterprise Edition, Service Pack 2


This bug might get fixed in upcoming Release\patches. This is in the pipeline/roadmap and the development team is working on it


Regds,

JK



Do rate helpful posts-

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Correct Answer
Jatin Katyal Wed, 06/16/2010 - 19:07
User Badges:
  • Cisco Employee,

Well, this is a known enhancement bug:


CSCta35271    Support for Windows server 2008 R2


Acs 4.2.x doesn't support all newer versions of Windows 2008. It only supports the below listed version. You can also check the release notes.


Supported Operating Systems section


--Windows Server 2008, Standard Edition


--Windows Server 2008, Enterprise Edition


--Japanese Windows Server 2008, Standard Edition, Service Pack 2


--Japanese Windows Server 2008, Enterprise Edition, Service Pack 2


This bug might get fixed in upcoming Release\patches. This is in the pipeline/roadmap and the development team is working on it


Regds,

JK



Do rate helpful posts-

jlhainy Sat, 10/09/2010 - 12:55
User Badges:

I actaully installed a remote agent for my ACS 4.2 SE on a 2003 server.... but that server is a member of a domain where the DC's are 2008 R2.  Does that mean I will still have problems?


I called TAC a while ago and they said a patch would be out by august, but I have heard nothing.  Does anyone know when or if this patch will be released?

jedubois Sat, 10/09/2010 - 16:06
User Badges:
  • Cisco Employee,

Hello,

     The domain being 2008 R2 shouldn't be a problem, we have no plan currently for 2008 R2 suppor that I know of, suppor for 2008 R2 is in ACS 5.2 though.

--Jesse

Jatin Katyal Sat, 10/09/2010 - 21:22
User Badges:
  • Cisco Employee,

Hi,


I think there are two different bugs


CSCta35271    Support for Windows server 2008 R2                                                  >> This says ACS doesn't support 2008 R2


CSCtg37183    ACS 4.x doesn't support 2008 R2 Server for AD                                   >> This says DC doesn't support 2008 R2


Hope this helps.


Regards,

Jatin

Manh Tien Bui Fri, 01/07/2011 - 20:16
User Badges:

I install ACS in window server 2008 Enterprise .But I don't show function "Add a remote agent" ?.Thanks in advance for your help.

Attachment: 
witkopstaub Tue, 01/18/2011 - 17:17
User Badges:

I am also planning a W2008 R2 schema update and need to verify if my ACS is compatible.  I have two redundant ACS solution engines at this version.

Release 4.2(0) Build 124 Patch 17

andamani Tue, 01/18/2011 - 19:09
User Badges:
  • Cisco Employee,

Hi Robin,


The following link states that the ACS 4.2 has only Windows 2k8, standard and enterprise edition as supported.

http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_server_for_windows/4.2/release/notes/ACS42_RN.html#wp100949


The release notes of ACS 5.2 has the bug resolved for Windows 2k8 R2.

http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_system/5.2/release/notes/acs_52_rn.html#wp190981


Regards,

Anisha


P.S.: Please mark this thread as answered if you feel your query is answered.

dlignier Tue, 03/01/2011 - 01:54
User Badges:

Hello,


We have appliance ACS v4.2. Our DC was under W2K3 and has been migrated to W2K8.


The remote agent doesn't work anymore, do you know if there is a version compatible with W2K8; we have unsuccessfully tested the ones we found on cisco site.


Thanks for your help,


Regards,

andamani Tue, 03/01/2011 - 03:17
User Badges:
  • Cisco Employee,

hi,


Could you please specify the exact the details of Win 2k8 server as well you ACS 4.2 version


The following states that windows 2008 R2 is not supported by ACS 4.2. Please have a look at system requirements.

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_server_for_windows/4.2.1/Installation_Guide/windows/install.html


Regards,

Anisha


-Do rate helpful posts.

dlignier Tue, 03/01/2011 - 05:06
User Badges:

Hi,


Thanks for your reply, but I think we don't speak about the same thing.


Our ACS is an appliance under W2K (ACSse), version 4.2 (build 124); it's the DC which is under W2K8 R2 standard.


And it's the remote agent which desn't run anymore under W2K8 on the DC; we are looking for a remote agent we can install on a W2K8 server; not the ACS (which still runs under W2K).


Thanks,


Regards

jlhainy Tue, 03/01/2011 - 06:35
User Badges:

The problem is the fact that your DCs are running Windows 2008 R2. 
The remote agent doesn't work with 2008 R2 DCs, only 2008 DCs.  The only fix for this is to upgrade to ACS 5.2.  I called TAC and they said they were not going to release any fixes for this on the 4.2 platform.  If you want it fixed, you'll have to either downgrade your DCs to 2008 or upgrade ACS to 5.2.


I upgraded ACS and have been quite happy with it.

Actions

This Discussion

Related Content