Configuring LAN side of 1310 Bridge

Unanswered Question
Jun 16th, 2010
User Badges:

Forgive my idiocy:


Is there a way to configure the ethernet port on the bridge to be a trunk port?  I tried using the same commands to set up a trunk port as on a switch, but the same commands were not there.  Is this simply a different string of commands to accomplish this, or is it no supported on this bridge?


Any help would be most appreciated.


Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
johnwcorl Wed, 06/16/2010 - 15:55
User Badges:

You cannot configure the port as a trunk, but you can create subinterfaces and add an encap dot1q to them for the vlan numbers. Here is an example of a non-root bridge. I only pasted the applicable commands. Root would have  station-role non-root bridge changed to  station-role root bridge


John



dot11 vlan-name VLAN01 vlan 1
dot11 vlan-name VLAN04 vlan 4
!
dot11 ssid V01
   vlan 1
   authentication open
   authentication key-management wpa
   wpa-psk ascii 7 XXXXXYYYY
!
dot11 ssid V04
   vlan 4
   authentication open
   authentication key-management wpa
   wpa-psk ascii 7 XXXXXYYYY
!
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 1 mode ciphers tkip
!
encryption vlan 4 mode ciphers tkip
!
ssid V01
!
ssid V04
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role non-root bridge
cca 75
concatenation
infrastructure-client
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.4
encapsulation dot1Q 4
no ip route-cache
bridge-group 4
bridge-group 4 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
full-duplex
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 spanning-disabled
!
interface FastEthernet0.4
encapsulation dot1Q 4
no ip route-cache
bridge-group 4
bridge-group 4 spanning-disabled
!
interface BVI1
ip address 10.0.0.2 255.255.255.240
no ip route-cache
!

Actions

This Discussion

 

 

Trending Topics - Security & Network