WLAN Client not getting DHCP

Answered Question

Here is my situation.  I am running a new WLC 5508 with 6.0x code and the controller is housed at the data center, the remote building has a high speed point to point link.  I have no issues with the LAPs connecting but clients are not getting IP addresses from the local DHCP server. I run the WLC as DHCP Proxy.


I am running DHCP server running on the local 3560 switch. Also I am not using option 43 on the DHCP server to provide the controllers address I am using DNS which resolves CISCO-CAPWAP-CONTROLER to the management address of the controller.



The LAP has a static address 10.100.6.20


The switchport that the LAP is plugged into is configured:


switchport mode access

switchport access vlan 106

switchport voice vlan 108

spanning-tree portfast


interface vlan 106

10.100.6.1 255.255.255.0


ip dhcp pool Users

network 10.100.6.0 255.255.255.0

dns-server <DNS at data center>

default-router 10.100.6.1


From what I understand the client connects and the WLAN which then the controllers virtual IP in my case 1.1.1.1 tells the local DHCP server that a client is looking for DHCP and then provides the client with IP.  I have this working in other building with the exact same configuration as above except that I am using local DNS server to lookup the name of the Controller Management IP but I cant understand why that would matter.


I have run debug messages on the switch and don't even see the DHCP Offer messages.  I have verified that wired clients are getting DHCP from the switch.

Correct Answer by abersven about 6 years 11 months ago
/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin-top:0cm; mso-para-margin-right:0cm; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0cm; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

You provided the configuration for the switch port where the LAP is connected. Assuming you are using local mode then all the client traffic is tunneled back to the controller (including DHCP). So what is configured for the switch port where the controller is connected and is there any DHCP server available for the VLAN where the SSID is terminated at the WLC?

/André

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
bellin Fri, 06/18/2010 - 08:39
User Badges:

My suggestion is that you run a debug from the controllers CLI.


(cisco controller)  >debug client xx:xx:xx:xx:xx:xx


When you /release /renew your clients workstation address, you should see an output in the CLI that relates to DHCP requests.  This gives you pretty much the same output as "debug DHCP packet enable" command.


The debug is pretty short, and it should identify the server ID it is using, or trying use for DHCP.


Try that and see if that helps.


As a side note, I use my management interface address as the DHCP server address within the dynamic interface configuration.  This works fine for me, but it doesn't seem to scale well when used with a lot controllers - that's a different issue entirely.


Another thing to look at is to make sure you don't override it in the WLAN settings.  If you do, just make sure the address is correct.

Ok here is an upate after getting TAC to give me some help.  You are correct because I had to enable HREAP mode on the access points and define the local VLANS to the branch office. This idea was escaping me and makes much more sense.  It also lets me know that when I move into our new building which will have 50 access points that I would rather have the traffic stay local so I will be installing controllers local.


It is still good to have HREAP for branches with 2 or less access points because I have noticed some issues roaming between access points.


Thanks for all the help.

Correct Answer
abersven Sat, 06/19/2010 - 02:24
User Badges:
/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin-top:0cm; mso-para-margin-right:0cm; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0cm; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

You provided the configuration for the switch port where the LAP is connected. Assuming you are using local mode then all the client traffic is tunneled back to the controller (including DHCP). So what is configured for the switch port where the controller is connected and is there any DHCP server available for the VLAN where the SSID is terminated at the WLC?

/André

Actions

This Discussion

Related Content

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode