How to enable SOAP in CCM 4.1.3?

Unanswered Question
Jun 17th, 2010

Hey, guys, any one who know how to enable SOAP in CCM 4.1.3, which is windows based?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Aaron Harrison Thu, 06/17/2010 - 13:59


The question would be which SOAP-based API are you interested in...?

If you are talking AXL, then yes, that was introduced in 4.1 I think. It's definately there at any rate - and it's enabled by default. It's on a different URL to the linux versions (https://server/CCMApi/AXL/V1/soapisapi.dll).

Risport is also there, again on a a different URL; this is all the in the documentation for the APIs at



Please rate helpful posts..

calvinzhao Tue, 06/22/2010 - 05:06

Hi Arron,

Thanks for your help!

I just want to change a certain ccs of a cetain line via SOAP, we've worked out some sample request xml files with ccm 7.x, but it seems not work well with CCM 4.x.

Could you please shed some light on this?

Aaron Harrison Tue, 06/22/2010 - 06:15


You'd have to post the errors you are receiving.

The idea behind this (and any other) API is that it should be reasonably version independent; obviously new things may not be supported in the 4.1 API, but CSS/phones is something pretty fundamental so should be OK.

If you aren't getting auth/URL problems, but are getting the actual contents of the request rejected, bear in mind that the 4.x AXL parser was extremely badly written. It's very sensitive to the order of the elements in some calls. I find the best thing to do is if you are trying an 'updatePhone', first do a 'getPhone', and then copy the order of the elements in from that in your updatePhone calls.

Other than that, post up your request and the error that is returned and I'll see if I can provide any further guidance.


calvinzhao Tue, 06/22/2010 - 19:37

Hi Thanks!

Now I'm making updatePhone work, yet still get the correct one with getLine.

The following is the request file I'm currently using:" xmlns:xsi="" xmlns:xsd="">" xsi:schemaLocation=" http://ccmserver/schema/axlsoap.xsd"  sequence="1">

the response told me to include , but I don't know where to find after a few retrying.

You also mentioned about the, but could you get me a direct URL or some key words? I just search by "4.1 soap getline", but only get a "4.1(3) Cisco Unified Communications Manager Serviceability XML Developer Guides.pdf", which seems not so helpful to me.

Aaron Harrison Wed, 06/23/2010 - 02:15


Re: your SOAP query - if you want to get a line, you have to identify it by a combination of line and partition.

So in your example, add a routePartitionName element with the name of the partition the line is in instead of XXX in this example:" xmlns:xsi="" xmlns:xsd="">" xsi:schemaLocation=" http://ccmserver/schema/axlsoap.xsd"  sequence="1">


Note, I've also added routeFilterName, which is empty but has to be there anyway...

Re: documentation, take a look at this page:

Download an uzip the 'Admin AXL Interface Specification' for your version of CUCM. This has a HTML document detailing the entire interface and the various procedures you can call. I find it opens badly in IE (very slow, lots of memory) but better in Firefox...




This Discussion

Related Content