NTP synchronization issue

Unanswered Question
Jun 17th, 2010

Hi Everybody,

I have a problem with ntp synchronization, I have 2 6500 Catalyst with latest IOS.They have hsrp configured on them BB3 is hsrp master.

both of them have same ntp configuration, as below

ntp source Vlan101
ntp master
ntp update-calendar
ntp server 128.249.1.1
ntp server 64.90.182.55
ntp server 193.140.151.239

my other access switches takes time from 6500 Backbone switches, from vlan 101.

One of the Backbone is synced with time server as below

BB-2#sh ntp status
Clock is synchronized, stratum 2, reference is 64.90.182.55
nominal freq is 250.0000 Hz, actual freq is 250.0003 Hz, precision is 2**18
reference time is CFC492C9.C6DC37CF (15:25:45.776 TURKEY Thu Jun 17 2010)
clock offset is -1.3027 msec, root delay is 140.01 msec
root dispersion is 9.99 msec, peer dispersion is 1.21 msec

BB-2#sh ntp associations

      address         ref clock     st  when  poll reach  delay  offset    disp
~128.249.1.1      0.0.0.0          16     -  1024    0     0.0    0.00  16000.
*~64.90.182.55     .ACTS.            1    50   512  377   139.6   -0.13     0.2
~127.127.7.1      127.127.7.1       7     8    64  377     0.0    0.00     0.0
~193.140.151.239  0.0.0.0          16     -  1024    0     0.0    0.00  16000.
* master (synced), # master (unsynced), + selected, - candidate, ~ configured

but the other one is cannot sync with any time server.yet it is still displays the correct time.

BB3#sh ntp status
Clock is unsynchronized, stratum 16, no reference clock
nominal freq is 250.0000 Hz, actual freq is 247.5813 Hz, precision is 2**18
reference time is CFC49F9E.DD27578E (16:20:30.863 TURKEY Thu Jun 17 2010)
clock offset is -625.2760 msec, root delay is 140.55 msec
root dispersion is 16500.31 msec, peer dispersion is 16000.00 msec

BB3#sh ntp associations

      address         ref clock     st  when  poll reach  delay  offset    disp
~128.249.1.1      0.0.0.0          16     -    64    0     0.0    0.00  16000.
~64.90.182.55     .ACTS.            1    39    64    0   140.5  -625.2  16000.
~127.127.7.1      127.127.7.1       7    26    64    1     0.0    0.00  15875.
~193.140.151.239  0.0.0.0          16     -    64    0     0.0    0.00  16000.
* master (synced), # master (unsynced), + selected, - candidate, ~ configured

both of them have same configuration same IOS same access permissions.Yet I cannot figure out what could be the problem.

I am looking for your helps.

thanks.

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ganesh Hariharan Thu, 06/17/2010 - 22:57

Hi Everybody,

I have a problem with ntp synchronization, I have 2 6500 Catalyst with latest IOS.They have hsrp configured on them BB3 is hsrp master.

both of them have same ntp configuration, as below

ntp source Vlan101
ntp master
ntp update-calendar
ntp server 128.249.1.1
ntp server 64.90.182.55
ntp server 193.140.151.239

my other access switches takes time from 6500 Backbone switches, from vlan 101.

One of the Backbone is synced with time server as below

BB-2#sh ntp status
Clock is synchronized, stratum 2, reference is 64.90.182.55
nominal freq is 250.0000 Hz, actual freq is 250.0003 Hz, precision is 2**18
reference time is CFC492C9.C6DC37CF (15:25:45.776 TURKEY Thu Jun 17 2010)
clock offset is -1.3027 msec, root delay is 140.01 msec
root dispersion is 9.99 msec, peer dispersion is 1.21 msec

BB-2#sh ntp associations

      address         ref clock     st  when  poll reach  delay  offset    disp
~128.249.1.1      0.0.0.0          16     -  1024    0     0.0    0.00  16000.
*~64.90.182.55     .ACTS.            1    50   512  377   139.6   -0.13     0.2
~127.127.7.1      127.127.7.1       7     8    64  377     0.0    0.00     0.0
~193.140.151.239  0.0.0.0          16     -  1024    0     0.0    0.00  16000.
* master (synced), # master (unsynced), + selected, - candidate, ~ configured

but the other one is cannot sync with any time server.yet it is still displays the correct time.

BB3#sh ntp status
Clock is unsynchronized, stratum 16, no reference clock
nominal freq is 250.0000 Hz, actual freq is 247.5813 Hz, precision is 2**18
reference time is CFC49F9E.DD27578E (16:20:30.863 TURKEY Thu Jun 17 2010)
clock offset is -625.2760 msec, root delay is 140.55 msec
root dispersion is 16500.31 msec, peer dispersion is 16000.00 msec

BB3#sh ntp associations

      address         ref clock     st  when  poll reach  delay  offset    disp
~128.249.1.1      0.0.0.0          16     -    64    0     0.0    0.00  16000.
~64.90.182.55     .ACTS.            1    39    64    0   140.5  -625.2  16000.
~127.127.7.1      127.127.7.1       7    26    64    1     0.0    0.00  15875.
~193.140.151.239  0.0.0.0          16     -    64    0     0.0    0.00  16000.
* master (synced), # master (unsynced), + selected, - candidate, ~ configured

both of them have same configuration same IOS same access permissions.Yet I cannot figure out what could be the problem.

I am looking for your helps.

thanks.

Hi,

As per the logs following things needs to be checked:-

The 'reach' counter shows a value of 0 for the following configured NTP server IP address(es):
  128.249.1.1
  64.90.182.55
  193.140.151.239
This means that the router did not receive at least the last eight NTP packets it expects to receive. Usually this counter shows a value of "377" which means that device has received at least the last eight NTP packets.

Check out the following things in the network from connectivity point of view from switch to ntp server:-

* Make sure that NTP server IP address(es) mentioned above is reachable by pinging   the server IP address(es).
* Enable the debug ntp packet command to make sure that NTP packets are received from the server(s).
* Make sure that NTP packets are not blocked by the access-list statement.

The output shows a NTP clock status of 'unsynced' with the following NTPserver(s):
  128.249.1.1
  64.90.182.55
  127.127.7.1
  193.140.151.239
* Verify that the 'stratum' value configured on the server is valid for your setup.  Configure a high stratum number to ensure that this router does not override  the clock on another system with a lower stratum number. The lower stratum number   indicates a more reliable clock.
* If authentication is configured between the server and the client, make sure   that authentication-key number and md5 key value matches. Also, verify that   the command ntp server {server_address} key {key} is included in the client   configuration.
* Make sure that NTP packets are not blocked by the access-list statement.

If at all problem persisits just re configure the ntp configuration on switch and then see the out put.

Hope to Help !!

Ganesh.H

Remember to rate the helpful post

burak-isiksoy Fri, 06/18/2010 - 00:58

Hi,

Problem solved.I erase ntp clock-period, ntp server and then configured router itself as a master.

Then re configured the time server now it is running smoothly.

Thanks for help.

Actions

This Discussion