IOM connections in a cluster setup

Answered Question
Jun 18th, 2010
User Badges:

I just wanted to verify that I have my physical connections setup:


If I have 2 Fabric interconnects and 2 chassis, I should connect:


Chassis1-IOM1 connected to Fabric1

Chassis1-IOM2 connected to Fabric2


Chassis2-IOM1 connected to Fabric2

Chassis2-IOM2 connected to Fabric1


Is this correct?  I just want to make sure I'm not supposed to connect it this way:


Chassis1-IOM1 connected to Fabric1

Chassis1-IOM2 connected to Fabric2


Chassis2-IOM1 connected to Fabric1

Chassis2-IOM2 connected to Fabric2


The Cisco high availability http://www.ciscosystemscapital.biz/en/US/products/ps10278/products_configuration_example09186a0080aef90f.shtml document doesn't specify how to connect 2 chassis.  Thanks.


Thanks.

Correct Answer by Nuno Filipe Alv... about 7 years 1 week ago

Hi Terence.


     The first thing you need is to define is how many connection you want from the Chassis to each of the Fabric Interconnects.


     IO Modules connect to either FIC A or B (not to both) - If you connect port 1 of the left IO Module to FIC A then the other ports also need to connect to it .


     Then you should have all your chassis connected all the same way (ideally though you may have more bandwidth requirements in one chassis then on the other and therefore have more connections - server ports on one chassis than on the other).


     The above means that if you are using only 1 server port per FIC to the chasssis you should connect each chassis like this (for example):


     Chassis 1 IO Module 1 (left) port 1 - FIC A (Port 1 ... for example)

     Chassis 2 IO Module 1 (left) port 1 - FIC A (Port 2 ... for example)


     Chassis 1 IO Module 2 (right) port 1 - FIC B (Port 1 ... for example)

     Chassis 2 IO Module 2 (right) port 1 - FIC B (Port 1 ... for example)


Cheers


Nuno Ferreira

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Nuno Filipe Alv... Fri, 06/18/2010 - 10:04
User Badges:

Hi Terence.


     The first thing you need is to define is how many connection you want from the Chassis to each of the Fabric Interconnects.


     IO Modules connect to either FIC A or B (not to both) - If you connect port 1 of the left IO Module to FIC A then the other ports also need to connect to it .


     Then you should have all your chassis connected all the same way (ideally though you may have more bandwidth requirements in one chassis then on the other and therefore have more connections - server ports on one chassis than on the other).


     The above means that if you are using only 1 server port per FIC to the chasssis you should connect each chassis like this (for example):


     Chassis 1 IO Module 1 (left) port 1 - FIC A (Port 1 ... for example)

     Chassis 2 IO Module 1 (left) port 1 - FIC A (Port 2 ... for example)


     Chassis 1 IO Module 2 (right) port 1 - FIC B (Port 1 ... for example)

     Chassis 2 IO Module 2 (right) port 1 - FIC B (Port 1 ... for example)


Cheers


Nuno Ferreira

terran0925 Fri, 06/18/2010 - 10:40
User Badges:

Thanks Nuno.  It looks like I had them crossed incorrectly then.  I'm running 2

cables from the IOM and configuring them as a 2-link (not 1 or 4).  I've switched the connections to:


Chassis1-IOM1(1,2) connected to Fabric1(1,2)

Chassis1-IOM2(1,2) connected to Fabric2(1,2)


Chassis2-IOM1(1,2) connected to Fabric1(5,6)

Chassis2-IOM2(1,2) connected to Fabric2(5,6)


Thanks.

terran0925 Fri, 06/18/2010 - 10:48
User Badges:

I just swapped out the connections and made sure all the links are back up but the connections I swapped are now indicating there is a FEX mismatch with a status of link up.

terran0925 Fri, 06/18/2010 - 11:33
User Badges:

I ended up fixing it by reacknowledging the chassis.

Actions

This Discussion