SPA3102 does not detect disconnect tone when call was originated from PSTN!!!

Unanswered Question
Jun 18th, 2010

Hello all,

I updated my SPA3102 to firmware 5.1.7( GW), I read that 5.1.10 has a bug related to disconnect tone detection.

I have the PSTN port connected to the analogue line (FXS) of a Siemens Gigaset SX353 phone.

The LINE port is connected to telephone set.

Detect Disconnect tone is Enabled

The Disconnect tone script is : 425@-30,425@-30;2(0.5/0.5/1+2)

{I have recorded the disconnect tone and figured out the frequency and duration using wavesurfer program}

The SPA3102 has successfully registered each port to a different SIP ID into my Trixbox IP-PBX.

When I make a call from the telephone set that is connected to the LINE port of the SPA3102  to the PSTN port, I get the dial tone generated from the Siemens Gigaset, I can then call an extension in the Gigaset and start a conversation.

When the called extension hangup, the Gigaset generate a "Disconnect tone" 425Hz with 50% duty one second cycle repeated ten times.

The SPA3102 detects this disconnect signal and terminates the call.

However, when I make a call from any Gigaset handset to the analogue Gigaset extension that is connected to the PSTN line of the SPA3102, I get the dial tone from the SPA-3102 and can dial any extension within my Trixbox IP-PBX, the call is made but when the caller hangs up first, the Gigaset send the same disconnect tone mentioned above but the PSTN line does not detect this and stays OFF HOOK for ever or until the called LINE hangs up!!!

As a work around, I used the Detect PSTN Long Silence feature. But I'd rather have the disconnect tone detection feature works as it is faster.

Has any one heard of such problem or know what is happening here?

Thanks

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Alberto Montilla Wed, 06/30/2010 - 10:06

Dear Sir;

Would need to see the html configuration (voice admin advanced), and please tell us the country you are located.

Regards
Alberto

sabah1000 Thu, 07/01/2010 - 06:11

Dear Alberto,

Thanks for your reply,

I am in Germany, however the PSTN port is not connected to German telecom, instead it is connected to an extension (ext. 21) of the Siemens Gigaset SX353 ISDN base unit.

I wasn't sure how you want me to show you the HTML configuration, so I just cut and pasted the PSTN Line page as follows:

Please let me know if you need more information.

Thanks

Sabah

Alberto Montilla Fri, 07/02/2010 - 03:12

Hi Sabah;

I need the full config, please do the following:

(1) Open the web UI, click voice tab, admin link, then advanced link

(2) The the full html file (.mht)

Regards;
Alberto

sabah1000 Thu, 07/15/2010 - 02:44

Dear Alberto,

Have you found the reason for the problem yet?

Thanks

sabah1000 Fri, 08/13/2010 - 11:30

Dear Alberto,

I have not received any response from you yet!!!

What's the problem?!!!

I too have observed this problem on a new SPA3102 with Firmware Version 3.3.6 on Hardware Version 1.4.5(a).

I purchased a Cisco SPA8800 earlier this year and upgraded it to firmware version 6.1.7(GW) on Hardware Version 1.3.0 and it too has the same problem.

I observed this problem when making a call to  the Telstra message service on my line, I observed that it was the CPC method whic eventually dropped the connection, I have been pulling my hair out trying to find the right settings for the SPA8800 and now I see the same problem on an SPA3102 I am beginning to see this as a device/firmware problem.

I am located in Australia and have the devices attached to a Telstra service.

I currently use the following for my Disconnect Tone;

425@-19,425@-29;2(.375/.375/1+2)

When a call is received on the PSTN and the remote party hangs up the SPA8800 & SPA3102 correctly detect the disconnect tone and promptly terminate the call.

I have an old SPA3000 which correctly detects the disconnect tone when either originating or receiving a call.

In m y frustration with this issue I have purchased an ATA from another vendor and set it to use a disconnect tone as above and it correctly detects the disconnect tone when a call is originated out of the PSTN.

I am happy to particiapte in getting a resolution to this on both the SPA8800 & SPA3012.

Cheers,

Larry.

francohefe1 Sat, 01/31/2015 - 14:04

Hi, I have the same problem with the disconect tone...When a Call comes in, if the caller hang up, the call follow its natural course, does not detect the tone.

 

Can you help me with that please.

That is the configuration file you asked..and the country is Colombia

 

Thanks a lot

Actions

This Discussion

Related Content