Create Serial Subinterface Cisco 2811

Unanswered Question
Jun 18th, 2010

How do you create a Serial Subinterface on a Cisco 2811 router.  This is for a WAN lab. I have a another Cisco 2811 router that was preconfigured with the serial subinterface withe following IOS flash:c2800nm-ipbase-mz.124-3g.bin. The Cisco 2811 router that I'm unable to create a subinterface on has  the follwoing IOS flash:c2800nm-advsecurityk9-mz.124-15.T9.bin. i'm not sure if the IOS is the problem or I'm usign the wrong commands.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
CSCO11702067 Fri, 06/18/2010 - 13:18

Hi,

Could you explain how you're going about creating the subinterface giving you the error?

Router#conf t
Router(config)#interface serial 2/0.10
Router(config-subif)#ip address 10.0.0.1 255.0.0.0

Above works just fine for me.

Regards,

Brian Beijl

reginaldjohnson Fri, 06/18/2010 - 13:49

From the global config:

RTR2(config)#interface serial 2/0.10
                       ^
% Invalid input detected at '^' marker.

RTR2(config)#inter
RTR2(config)#interface serial 0/0/0
                       ^
% Invalid input detected at '^' marker.

RTR2(config)#

Sh run:

controller T1 0/0/0
framing esf
linecode b8zs
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.250 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server

reginaldjohnson Fri, 06/18/2010 - 14:25

Answer:http://hardware.allfaq.org/forums/p/67840/135336.aspx

The  T1 Controller has to be configured before any serial interface are made  available. Below is the ouput from the command.

RTR3(config)#controller  T1 0/0/0
RTR3(config-controller)# framing esf
RTR3(config-controller)#  linecode b8zs
RTR3(config-controller)# channel-group  0 timeslots 1-24 speed 64
RTR3(config-controller)#
*Jun  18 21:15:06.441: %LINK-3-UPDOWN: Interface Serial0/0/0:0, changed state  to down
*Jun 18 21:15:07.441: %LINEPROTO-5-UPDOWN: Line protocol on  Interface Serial0/0/0:0, changed state to down
RTR3(config-controller)#

Command

controller T1 0/0/0
framing esf
linecode b8zs
channel-group  0  timeslots 1-24 speed 64

Richard Burts Fri, 06/18/2010 - 13:30

Reginald

I believe that it is very unlikely that your problem is related to the version of IOS. I suspect that the issue is in  the approach to configuring the serial subinterface.

Note that some serial interface encapsulations (such as Frame Relay) do support subinterfaces while others (HDLC and PPP) do not support subinterfaces.

It would be helpful is you could post the configuration of the serial interface and the serial subinterface from the router that was supplied to you. And it would be helpful if you also post the exact commands that you are entering and any response generated from the router when you attempt the configuration of the serial subinterface.

HTH

Rick

reginaldjohnson Fri, 06/18/2010 - 13:54

When the sh run command is executed a serial interface is not displayed. This particular post said, the  T1 Controller interface need to be configured and then a serial interface will be created.

RTR2#sh run
Building configuration..

Current configuration : 740 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RTR2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
no network-clock-participate wic 0
dot11 syslog
!
ip cef
!
multilink bundle-name authenticated
!
archive
log config
  hidekeys
!
!
!
controller T1 0/0/0
framing esf
linecode b8zs
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.250 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
ip forward-protocol nd
!
!ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end

Richard Burts Fri, 06/18/2010 - 14:12

Reginald

This additional information is helpful. Yes there is something else that you need to configure under the T1 controller to create the serial interface.

Under controller T1 0/0/0
add channel-group 2 timeslots 1-24

and this should create the serial interface.

HTH

Rick

reginaldjohnson Fri, 06/18/2010 - 14:13

Answer:http://hardware.allfaq.org/forums/p/67840/135336.aspx

The T1 Controller has to be configured before any serial interface are made available. Below is the ouput from the command.

RTR3(config)#controller T1 0/0/0
RTR3(config-controller)# framing esf
RTR3(config-controller)# linecode b8zs
RTR3(config-controller)# channel-group 0 timeslots 1-24 speed 64
RTR3(config-controller)#
*Jun 18 21:15:06.441: %LINK-3-UPDOWN: Interface Serial0/0/0:0, changed state to down
*Jun 18 21:15:07.441: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0:0, changed state to down
RTR3(config-controller)#

Command

controller T1 0/0/0
framing esf
linecode b8zs
channel-group 0  timeslots 1-24 speed 64

Actions

This Discussion