Trunk and active vlans. plus VTP configuration.

Unanswered Question
Jun 21st, 2010

Hello All,

sorry for my english.

I have to swithces 4506(also as a router between switches) and 3750 connected by trunk. I wanted to replace 3750 with 3750G model. so i coppyed config from old one to new and cheked the port's names and configuration to be currect. So after sturtup it doesnt work curectly. i don't know why but command show interfaces port-channel 1 trunk  returns me this result for the new switch.

show interfaces port-channel 1 trunk

Port        Mode             Encapsulation  Status        Native vlan

Po1         on               802.1q         trunking      254


Port        Vlans allowed on trunk

Po1                 3,112,144-145,160-161,176-177,192-193,208-209,216-217,224-225,243,247,253-254


Port                Vlans allowed and active in management domain

Po1                 161


Port                Vlans in spanning tree forwarding state and not pruned

Po1                 161

i don't undestand why only one VLAN allowed and active. the old 3750 works fine. all allowed vlans are active on old one. Plroblem is that 161 is a access VLAN configured on almost all ports on 3750 switch, also there is voice vlan on all ports - 177. But i can't see it as active. What I have after power on new switch - phones are started, and even recived IP by DHCP (ip helper configured for all vlans on 4506 switch - it is also router between VLANs), but i can't see or ping any other vlans from it. i can see whole netwotk only from 161 VLAN. so phones are not registered.
the same command for 4506 returns this: (and the same result for old 3750 with only one differance in a last line)
What i'm doing wrong? please advise!
thsnks
Alexey.
sorry again for my English, i'm new here.
show interfaces port-channel 1 trunk

Port        Mode             Encapsulation  Status        Native vlan
Po1         on               802.1q         trunking      254

Port        Vlans allowed on trunk
Po1                 3,112,144-145,160-161,176-177,192-193,208-209,216-217,224-225,243,247,253-254

Port                Vlans allowed and active in management domain
Po1                 3,112,144-145,160-161,176-177,192-193,208-209,216-217,224-225,243,247,253-254

Port                Vlans in spanning tree forwarding state and not pruned
Po1                 161,177,254
for old 3750
Port        Mode             Encapsulation  Status        Native vlan
Po1         on               802.1q         trunking      254

Port        Vlans allowed on trunk
Po1                 3,112,144-145,160-161,176-177,192-193,208-209,216-217,224-225,243,247,253-254

Port                Vlans allowed and active in management domain
Po1                 3,112,144-145,160-161,176-177,192-193,208-209,216-217,224-225,243,247,253-254

Port                Vlans in spanning tree forwarding state and not pruned
Po1                 3,112,144-145,160-161,176-177,192-193,208-209,216-217,224-225,243,247,253-254
this is VTP stutus new 3750G
VTP Version capable             : 1 to 3
VTP version running             : 2
VTP Domain Name                 : Core_Moscow_Office
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Enabled
Device ID                       : 0024.f97e.0300
Configuration last modified by 10.102.255.129 at 3-1-93 00:32:15
Local updater ID is 10.102.255.129 on interface Lo100 (first layer3 interface fo
und)

Feature VLAN:
--------------
VTP Operating Mode                : Server
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 6
Configuration Revision            : 0
MD5 digest                        : 0x3F 0xEC 0xE2 0xEF 0x30 0xA9 0x74 0x41
                                    0xCA 0x8A 0xC9 0x88 0x9F 0x3B 0x63 0xF5
this is for 4506
VTP Version                     : running VTP2
Configuration Revision          : 33
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 28
VTP Operating Mode              : Server
VTP Domain Name                 : Core_Moscow_Office
VTP Pruning Mode                : Enabled
VTP V2 Mode                     : Enabled
VTP Traps Generation            : Enabled
MD5 digest                      : 0x67 0x37 0x8C 0xFD 0x0D 0x5B 0x16 0x2A
Configuration last modified by 10.102.128.254 at 9-25-08 23:30:10
Local updater ID is 10.102.128.254 on interface Vl3 (lowest numbered VLAN interface found)
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Mon, 06/21/2010 - 05:26

   The port channel trunk is not working correctly , thus vtp is not propagating the vlan information the way it should.  To help you will probably have to post the port channel configuration from both sides along with the port setup in the port channel . A show vtp status would help.  That is one of th issues when forcing on a portchannel or trunk , as long as you  have a physical link it will show the links as trunking when they might not be .   Verify each side matches exactly on each side for the port channel SVI ,  port settings in the channel, and the trunk parameters .  Also check to see if there is any vtp password being used , if so that also has to match .  Does the new 3750 have to be a server or can it be a client .  You should have 2 servers in any vtp setup but the rest should be clients...

Alexey Shvarev Mon, 06/21/2010 - 06:05

Hi, thanks for quick replay.

The problem is that it is working on old 3750. As I told I've coppyed config one to one to the new 3750G, only changed interfaces from FE to GE. And it is not working on new...

So, it looks from main switch-router 4506 everything fine. At least should be.

configs for PChannel and interfaces below.

I have a question, is VTP configuration keeped in config file or not? i couldn't find any configuration for VTP (client or server, or any, only domain name. also no password for VTP domain used)

Unfourtunataly I had to rollback all changes, so all commands for 4506 have run on working infrustructure - 4506+old3750.

also vtp status commands looks different on old and new 3750. Probably HW or IOS differance.

let me know if I need to grab anything else.

port channal and interfacees config for 4506:

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 254

switchport trunk allowed vlan 3,112,144,145,160,161,176,177,192,193,208,209

switchport trunk allowed vlan add 216,217,224,225,243,247,253,254

switchport mode trunk

logging event link-status

logging event trunk-status

qos trust cos

!

interface GigabitEthernet1/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 254

switchport trunk allowed vlan 3,112,144,145,160,161,176,177,192,193,208,209

switchport trunk allowed vlan add 216,217,224,225,243,247,253,254

switchport mode trunk

logging event link-status

logging event trunk-status

qos trust cos

channel-group 1 mode desirable

!

interface GigabitEthernet1/2

switchport trunk encapsulation dot1q

switchport trunk native vlan 254

switchport trunk allowed vlan 3,112,144,145,160,161,176,177,192,193,208,209

switchport trunk allowed vlan add 216,217,224,225,243,247,253,254

switchport mode trunk

logging event link-status

logging event trunk-status

qos trust cos

channel-group 1 mode desirable

4506#show interfaces port-channel 1

Port-channel1 is up, line protocol is up (connected)

  Hardware is EtherChannel, address is 0011.21f9.fc81 (bia 0011.21f9.fc81)

  MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is N/A

  input flow-control is off, output flow-control is unsupported

  Members in this channel: Gi1/1 Gi1/2

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:05, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 828000 bits/sec, 127 packets/sec

  5 minute output rate 1401000 bits/sec, 153 packets/sec

     9053409266 packets input, 4616939860262 bytes, 0 no buffer

     Received 10228476 broadcasts (6717593 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 input packets with dribble condition detected

     12573430094 packets output, 15121841480153 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

for new 3750G (and old as well)

interface Port-channel1

switchport trunk encapsulation dot1q

switchport trunk native vlan 254

switchport trunk allowed vlan 3,112,144,145,160,161,176,177,192,193,208,209

switchport trunk allowed vlan add 216,217,224,225,243,247,253,254

switchport mode trunk

logging event trunk-status

logging event bundle-status

logging event spanning-tree

logging event status




interface GigabitEthernet1/0/49

switchport trunk encapsulation dot1q

switchport trunk native vlan 254

switchport trunk allowed vlan 3,112,144,145,160,161,176,177,192,193,208,209

switchport trunk allowed vlan add 216,217,224,225,243,247,253,254

switchport mode trunk

logging event trunk-status

logging event bundle-status

logging event spanning-tree

logging event status

mls qos trust cos

channel-group 1 mode desirable

!

interface GigabitEthernet1/0/50

switchport trunk encapsulation dot1q

switchport trunk native vlan 254

switchport trunk allowed vlan 3,112,144,145,160,161,176,177,192,193,208,209

switchport trunk allowed vlan add 216,217,224,225,243,247,253,254

switchport mode trunk

logging event trunk-status

logging event bundle-status

logging event spanning-tree

logging event status

mls qos trust cos

channel-group 1 mode desirable

#show vtp status

VTP Version capable             : 1 to 3

VTP version running             : 2

VTP Domain Name                 : Core_Moscow_Office

VTP Pruning Mode                : Disabled

VTP Traps Generation            : Enabled

Device ID                       : 0024.f97e.0300

Configuration last modified by 10.10.5.9 at 3-1-93 00:32:15

Local updater ID is 10.10.5.9 on interface Lo100 (first layer3 interface fo

und)


Feature VLAN:

--------------

VTP Operating Mode                : Server

Maximum VLANs supported locally   : 1005

Number of existing VLANs          : 6

Configuration Revision            : 0

MD5 digest                        : 0x3F 0xEC 0xE2 0xEF 0x30 0xA9 0x74 0x41

                                    0xCA 0x8A 0xC9 0x88 0x9F 0x3B 0x63 0xF5

glen.grant Mon, 06/21/2010 - 06:21

   Did the etherchannel come up correctly when you tried to bring it up ? As you are trying to negotiate the port channel  you could verify with "show etherchannel summory or show etherchannel detail to see if it aggregated the ports correctly. When bringing up the port channel make sure to bring up both ports at the same time , don't try to bring up one at a time , this sometimes leads to unpredictable results.  If it did not it will usually give you an indication in the logs themselves why it did not bundle them.  The vtp information will not show up when the switch is in server or client mode , it does show up if you run the connections in transparent mode .  VTP info is stored in the vlan.dat file. I see vtp pruning is off on the 3750 side and on for 4506 , not sure if this makes any difference or not . Other than that I do not see anything really that jumps out that is incorrect in your config . I normally run "channel-group X mode desirable non-silent" between cisco boxes but the way you have it should work fine also.

Actions

This Discussion