Dialing 0 for outside line.

Unanswered Question
Jun 22nd, 2010

Hi All,


My next issue on the UC540 is the dialing a number for an outside line. In our test setup we have 1x FXO PSTN line and a SIP trunk. The Sip trunk has 10x DIDs and 10 lines.


Now when we make calls we have to dial '0' in our case to get an outside line. The issue is when people call us we cannot call them back from our call history as it is missing the '0'.


What would be the best solution in this case. Remove the need for a 0 (as we would prefer) or manipulate the caller ID?


I have another issue which may or may not be related. With SNR sometimes the UC uses the SIP trunk and sometimes it used the SIP trunk. I would like to set all outgoing calls on the SIP trunk unless all lines are being used. Is there any way to do this?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
djh278778 Tue, 06/22/2010 - 09:48

From your call history there is an "edit dial" soft key. You would select the call on the log, press "edit dial",  then "0",  then  "dial". Does this not work for you?

SteveOrfanos Tue, 06/22/2010 - 12:38

In my experience this is a common gripe customers have.


I'm only new to the UC500 space, however I have a lot of experience with Unified Communications in particular with the Mitel product. Mitel can insert in this case an addition 0 to the inward dialing number which allows you to dial straight out of history without having to modify the number.


Is there a way of doing this on the UC500?


P.S. I'm not pitting one system against the other. I think both products are fantastic

David Trad Tue, 06/22/2010 - 13:19

Hi Matthew,


If you are comfortable with using the CLI I can help you to resolve this problem.


You need a Translation rule, that will add a "0" to the incoming, so that way when you review it in your history you only need to press redial.


Can you provide the following please:


  • Which country are you in?
  • Upload your running configuration with the removal of all sensitive information
  • Do you require it on both the POTS and the VoIP dial-peers?


This is a common problem, and I am still not sure why this has not been addressed, unless of course it is available in CCA and I am just not aware of it.



Cheers,



David.

matthew.cameron Tue, 06/22/2010 - 21:22

My CLI is great, I am a network engineer. I have tried translation rules already but with no luck. Any help would be

greatly appreciated.


I am in Australia (Melbourne)

Yes we use the SIP trunk for all outgoing calls and the POTS is only for backup if our inraweb breaks


I haven't seen anything in the CCA and it baffles me a little too.


Cheers


Running Config:

Building configuration...


Current configuration : 59883 bytes
!
! Last configuration change at 14:01:57 AEST Wed Jun 23 2010 by admin
! NVRAM config last updated at 00:19:10 AEST Wed Jun 23 2010
!
version 15.0
parser config cache interface
no service pad
no service timestamps debug uptime
service timestamps log datetime msec
service password-encryption
service internal
service compress-config
service sequence-numbers
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging buffered
no logging rate-limit
enable secret 5 $1$bnv3$f1/I/631VlAWNCIDnm7Tk/
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
!
!
!
!
aaa session-id common
!
!
!
clock timezone AEST 10
clock summer-time AEST recurring last Sun Oct 2:00 last Sun Mar 3:00
!
crypto pki trustpoint TP-self-signed-1789424616
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1789424616
revocation-check none
rsakeypair TP-self-signed-1789424616
!
!
crypto pki certificate chain TP-self-signed-1789424616
certificate self-signed 01
     quit
dot11 syslog
!
dot11 ssid Vibe Group
vlan 1
authentication open
authentication key-management wpa
guest-mode
!
dot11 ssid cisco-data
vlan 1
authentication open
!
dot11 ssid cisco-voice
vlan 100
authentication open
!
ip source-route
ip cef
!
!
ip dhcp relay information trust-all
ip dhcp excluded-address 10.0.1.100 10.0.1.255
ip dhcp excluded-address 10.0.1.1 10.0.1.49
ip dhcp excluded-address 10.0.0.100 10.0.0.255
ip dhcp excluded-address 10.0.0.1 10.0.0.49
!
ip dhcp pool phone
   network 10.0.1.0 255.255.255.0
   default-router 10.0.1.254
   option 150 ip 10.0.1.254
!
ip dhcp pool data
   import all
   network 10.0.0.0 255.255.255.0
   default-router 10.0.0.254
   dns-server 10.0.0.210
!
!
ip name-server 10.0.0.210
ip inspect name SDM_LOW cuseeme
ip inspect name SDM_LOW dns
ip inspect name SDM_LOW ftp
ip inspect name SDM_LOW h323
ip inspect name SDM_LOW https
ip inspect name SDM_LOW icmp
ip inspect name SDM_LOW imap
ip inspect name SDM_LOW pop3
ip inspect name SDM_LOW netshow
ip inspect name SDM_LOW rcmd
ip inspect name SDM_LOW realaudio
ip inspect name SDM_LOW rtsp
ip inspect name SDM_LOW esmtp
ip inspect name SDM_LOW sqlnet
ip inspect name SDM_LOW streamworks
ip inspect name SDM_LOW tftp
ip inspect name SDM_LOW tcp router-traffic
ip inspect name SDM_LOW udp
ip inspect name SDM_LOW vdolive
no ipv6 cef
!
!
stcapp ccm-group 1
stcapp
!
stcapp feature access-code
!
!
!
!
multilink bundle-name authenticated
!
!
trunk group ALL_FXO
max-retry 5
voice-class cause-code 1
hunt-scheme longest-idle
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
sip
  registrar server expires max 3600 min 3600
   outbound-proxy dns:sip-direct.vic.iibusiness.net.au
  no update-callerid
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
codec preference 3 g729r8
!
!
voice class cause-code 1
no-circuit
!
voice register global
!
voice hunt-group 1 parallel
final 00405277279
list 201,202,203
timeout 16
pilot 501
!
!
!
!
voice source-group CCA_SIP_SOURCE_GROUP_CUE_CME
access-list 2
translation-profile incoming SIP_Incoming
!
voice source-group CCA_SIP_SOURCE_GROUP_EXTERNAL
access-list 3
!
voice translation-rule 4
rule 1 /0390294381/ /501/
!
voice translation-rule 6
rule 1 /0380604506/ /202/
!
voice translation-rule 7
rule 1 /0380604505/ /201/
!
voice translation-rule 8
rule 1 /0380604500/ /501/
!
voice translation-rule 410
rule 1 /^0\(.*\)/ /\1/
rule 15 /^...$/ /0380604500/
!
voice translation-rule 411
rule 1 /^0\(.*\)/ /ABCD0\1/
!
voice translation-rule 412
rule 1 /^ABCD\(.*\)/ /\1/
!
voice translation-rule 1111
rule 1 /201/ /0380604500/
rule 15 /^...$/ /0380604500/
!
voice translation-rule 1112
rule 1 /^0/ //
!
voice translation-rule 2002
rule 1 /^6/ //
!
voice translation-rule 2222
!
!
voice translation-profile All-BG_Called_8
translate called 8
!
voice translation-profile CALLER_ID_TRANSLATION_PROFILE
translate calling 1111
!
voice translation-profile CallBlocking
translate called 2222
!
voice translation-profile User#2_Called_6
translate called 6
!
voice translation-profile User#1_Called_7
translate called 7
!
voice translation-profile OUTGOING_TRANSLATION_PROFILE
translate called 1112
!
voice translation-profile PSTN_CallForwarding
translate redirect-target 410
translate redirect-called 410
!
voice translation-profile PSTN_Outgoing
translate calling 1111
translate called 1112
translate redirect-target 410
translate redirect-called 410
!
voice translation-profile SIP-BG_Called_4
translate called 4
!
voice translation-profile SIP_Incoming
translate called 411
!
voice translation-profile SIP_Passthrough
translate called 412
!
voice translation-profile XFER_TO_VM_PROFILE
translate redirect-called 2002
!
!
voice-card 0
!
!
!
license udi pid UC540W-FXO-K9 sn FHK1421710B
archive
log config
  logging enable
  logging size 600
  hidekeys
username admin privilege 15 secret
!
process-max-time 50
!
ip tftp source-interface Loopback0
!
class-map match-all _class_Voice0
match ip dscp ef
class-map match-all _class_Voice1
match ip dscp cs3
!
!
policy-map Voice
class _class_Voice0
  set cos 6
class _class_Voice1
  set cos 3
!
!
!
!
bridge irb
!
!
!
!
interface Loopback0
description $FW_INSIDE$
ip address 10.1.10.2 255.255.255.252
ip access-group 101 in
ip nat inside
ip virtual-reassembly
!
!
interface FastEthernet0/0
description $ETH-WAN$
no ip address
ip virtual-reassembly
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
!
interface Integrated-Service-Engine0/0
description cue is initialized with default IMAP group
ip unnumbered Loopback0
ip nat inside
ip virtual-reassembly
service-module ip address 10.1.10.1 255.255.255.252
service-module ip default-gateway 10.1.10.2
!
!
interface FastEthernet0/1/0
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
!
interface FastEthernet0/1/1
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
!
interface FastEthernet0/1/2
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
!
interface FastEthernet0/1/3
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
!
interface FastEthernet0/1/4
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
!
interface FastEthernet0/1/5
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
!
interface FastEthernet0/1/6
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
!
interface FastEthernet0/1/7
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
!
interface FastEthernet0/1/8
switchport mode trunk
macro description cisco-switch
!
!
interface Dot11Radio0/5/0
no ip address
!
encryption vlan 1 mode ciphers aes-ccm
!
ssid Vibe Group
!
ssid cisco-voice
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
service-policy output Voice
!
interface Dot11Radio0/5/0.1
encapsulation dot1Q 1 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0/5/0.100
encapsulation dot1Q 100
bridge-group 100
bridge-group 100 subscriber-loop-control
bridge-group 100 spanning-disabled
bridge-group 100 block-unknown-source
no bridge-group 100 source-learning
no bridge-group 100 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
!
!
interface Vlan100
no ip address
bridge-group 100
!
!
interface Dialer0
description $FW_OUTSIDE$
ip address negotiated
ip access-group 104 in
ip mtu 1452
ip nat outside
ip inspect SDM_LOW out
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname
ppp chap password 7
ppp pap sent-username vibegroup password
ppp ipcp dns request
!
!
interface BVI1
description $FW_INSIDE$
ip address 10.0.0.254 255.255.255.0
ip access-group 102 in
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1412
!
!
interface BVI100
description $FW_INSIDE$
ip address 10.0.1.254 255.255.255.0
ip access-group 103 in
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1412
!
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
ip dns server
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 10.0.0.214 80 interface Dialer0 80
ip nat inside source static tcp 10.0.0.211 25 interface Dialer0 25
ip nat inside source static tcp 10.0.0.211 443 interface Dialer0 443
ip nat inside source static tcp 10.0.0.214 21 interface Dialer0 21
ip nat inside source static tcp 10.0.0.212 3389 interface Dialer0 3389
ip nat inside source static tcp 10.0.0.50 22999 interface Dialer0 22999
ip nat inside source static tcp 10.0.0.214 5721 interface Dialer0 5721
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.0.0.0 0.0.0.255
access-list 1 permit 10.0.1.0 0.0.0.255
access-list 1 permit 10.1.10.0 0.0.0.3
access-list 2 remark CCA_SIP_SOURCE_GROUP_ACL_INTERNAL
access-list 2 remark SDM_ACL Category=1
access-list 2 permit 10.0.0.254
access-list 2 permit 10.1.10.0 0.0.0.3
access-list 2 permit 10.0.0.0 0.0.0.255
access-list 2 permit 10.0.1.0 0.0.0.255
access-list 3 remark CCA_SIP_SOURCE_GROUP_ACL_EXTERNAL
access-list 3 remark SDM_ACL Category=1
access-list 3 permit 203.55.229.198
access-list 3 deny   any
access-list 100 remark auto generated by SDM firewall configuration
access-list 100 remark SDM_ACL Category=1
access-list 100 deny   ip 192.168.10.0 0.0.0.255 any
access-list 100 deny   ip host 255.255.255.255 any
access-list 100 deny   ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
access-list 101 remark auto generated by SDM firewall configuration##NO_ACES_7##
access-list 101 remark SDM_ACL Category=1
access-list 101 permit tcp 10.0.1.0 0.0.0.255 eq 2000 any
access-list 101 permit udp 10.0.1.0 0.0.0.255 eq 2000 any
access-list 101 deny   ip 10.0.1.0 0.0.0.255 any
access-list 101 deny   ip 10.0.0.0 0.0.0.255 any
access-list 101 deny   ip host 255.255.255.255 any
access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
access-list 101 permit ip any any
access-list 102 remark auto generated by SDM firewall configuration##NO_ACES_5##
access-list 102 remark SDM_ACL Category=1
access-list 102 deny   ip 10.1.10.0 0.0.0.3 any
access-list 102 deny   ip 10.0.1.0 0.0.0.255 any
access-list 102 deny   ip host 255.255.255.255 any
access-list 102 deny   ip 127.0.0.0 0.255.255.255 any
access-list 102 permit ip any any
access-list 103 remark auto generated by SDM firewall configuration##NO_ACES_7##
access-list 103 remark SDM_ACL Category=1
access-list 103 permit tcp 10.1.10.0 0.0.0.3 any eq 2000
access-list 103 permit udp 10.1.10.0 0.0.0.3 any eq 2000
access-list 103 deny   ip 10.1.10.0 0.0.0.3 any
access-list 103 deny   ip 10.0.0.0 0.0.0.255 any
access-list 103 deny   ip host 255.255.255.255 any
access-list 103 deny   ip 127.0.0.0 0.255.255.255 any
access-list 103 permit ip any any
access-list 104 remark auto generated by SDM firewall configuration##NO_ACES_12##
access-list 104 remark SDM_ACL Category=1
access-list 104 permit tcp any any eq 5721 log
access-list 104 permit tcp any any eq 22999 log
access-list 104 permit tcp any any eq 3389 log
access-list 104 permit tcp any any eq ftp log
access-list 104 permit tcp any any eq 443 log
access-list 104 permit tcp any any eq smtp log
access-list 104 permit tcp any any eq www log
access-list 104 permit udp host 10.0.0.254 eq 5060 any
access-list 104 permit udp host 10.0.0.254 any eq 5060
access-list 104 permit udp any any range 16384 32767
access-list 104 permit udp host 203.55.229.198 eq 5060 any
access-list 104 permit udp host 203.55.229.198 any eq 5060
dialer-list 1 protocol ip permit
!
!
!
!
snmp-server community public RO
tftp-server flash:/phones/521_524/cp524g-8-1-17.bin alias cp524g-8-1-17.bin
tftp-server flash:/phones/525/spa525g-7-1-9.bin alias spa525g-7-1-9.bin
tftp-server flash:/phones/5x5/spa5x5-7-1-3c.bin alias spa5x5-7-1-3c.bin
tftp-server flash:/ringtones/Analog1.raw alias Analog1.raw
tftp-server flash:/ringtones/Analog2.raw alias Analog2.raw
tftp-server flash:/ringtones/AreYouThere.raw alias AreYouThere.raw
tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
tftp-server flash:/ringtones/RingList.xml alias RingList.xml
tftp-server flash:/ringtones/AreYouThereF.raw alias AreYouThereF.raw
tftp-server flash:/ringtones/Bass.raw alias Bass.raw
tftp-server flash:/ringtones/CallBack.raw alias CallBack.raw
tftp-server flash:/ringtones/Chime.raw alias Chime.raw
tftp-server flash:/ringtones/Classic1.raw alias Classic1.raw
tftp-server flash:/ringtones/Classic2.raw alias Classic2.raw
tftp-server flash:/ringtones/ClockShop.raw alias ClockShop.raw
tftp-server flash:/ringtones/Drums1.raw alias Drums1.raw
tftp-server flash:/ringtones/Drums2.raw alias Drums2.raw
tftp-server flash:/ringtones/FilmScore.raw alias FilmScore.raw
tftp-server flash:/ringtones/HarpSynth.raw alias HarpSynth.raw
tftp-server flash:/ringtones/Jamaica.raw alias Jamaica.raw
tftp-server flash:/ringtones/KotoEffect.raw alias KotoEffect.raw
tftp-server flash:/ringtones/MusicBox.raw alias MusicBox.raw
tftp-server flash:/ringtones/Piano1.raw alias Piano1.raw
tftp-server flash:/ringtones/Piano2.raw alias Piano2.raw
tftp-server flash:/ringtones/Pop.raw alias Pop.raw
tftp-server flash:/ringtones/Pulse1.raw alias Pulse1.raw
tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw
tftp-server flash:/ringtones/Ring2.raw alias Ring2.raw
tftp-server flash:/ringtones/Ring3.raw alias Ring3.raw
tftp-server flash:/ringtones/Ring4.raw alias Ring4.raw
tftp-server flash:/ringtones/Ring5.raw alias Ring5.raw
tftp-server flash:/ringtones/Ring6.raw alias Ring6.raw
tftp-server flash:/ringtones/Ring7.raw alias Ring7.raw
tftp-server flash:/ringtones/Sax1.raw alias Sax1.raw
tftp-server flash:/ringtones/Sax2.raw alias Sax2.raw
tftp-server flash:/ringtones/Vibe.raw alias Vibe.raw
tftp-server flash:/Desktops/CampusNight.png
tftp-server flash:/Desktops/TN-CampusNight.png
tftp-server flash:/Desktops/CiscoFountain.png
tftp-server flash:/Desktops/TN-CiscoFountain.png
tftp-server flash:/Desktops/CiscoLogo.png
tftp-server flash:/Desktops/TN-CiscoLogo.png
tftp-server flash:/Desktops/Fountain.png
tftp-server flash:/Desktops/TN-Fountain.png
tftp-server flash:/Desktops/MorroRock.png
tftp-server flash:/Desktops/TN-MorroRock.png
tftp-server flash:/Desktops/NantucketFlowers.png
tftp-server flash:/Desktops/TN-NantucketFlowers.png
tftp-server flash:Desktops/320x212x16/List.xml
tftp-server flash:Desktops/320x212x12/List.xml
tftp-server flash:Desktops/320x216x16/List.xml
tftp-server flash:/bacdprompts/en_bacd_allagentsbusy.au alias en_bacd_allagentsbusy.au
tftp-server flash:/bacdprompts/en_bacd_disconnect.au alias en_bacd_disconnect.au
tftp-server flash:/bacdprompts/en_bacd_enter_dest.au alias en_bacd_enter_dest.au
tftp-server flash:/bacdprompts/en_bacd_invalidoption.au alias en_bacd_invalidoption.au
tftp-server flash:/bacdprompts/en_bacd_music_on_hold.au alias en_bacd_music_on_hold.au
tftp-server flash:/bacdprompts/en_bacd_options_menu.au alias en_bacd_options_menu.au
tftp-server flash:/bacdprompts/en_bacd_welcome.au alias en_bacd_welcome.au
tftp-server flash:/bacdprompts/en_bacd_xferto_operator.au alias en_bacd_xferto_operator.au
!
control-plane
!
!
bridge 1 route ip
bridge 100 route ip
call threshold interface FastEthernet0/0 int-calls low 4 high 4
!
voice-port 0/0/0
cptone AU
station-id name Cordless
station-id number 301
caller-id enable
!
voice-port 0/0/1
cptone AU
station-id number 302
caller-id enable
!
voice-port 0/0/2
cptone AU
station-id number 303
caller-id enable
!
voice-port 0/0/3
cptone AU
station-id number 304
caller-id enable
!
voice-port 0/1/0
trunk-group ALL_FXO 64
supervisory disconnect dualtone mid-call
cptone AU
timeouts call-disconnect 3
timeouts wait-release 3
connection plar opx 501
impedance complex1
description Configured by CCA 4 FXO-0/1/0-BG
caller-id enable
!
voice-port 0/1/1
trunk-group ALL_FXO 64
supervisory disconnect dualtone mid-call
cptone AU
timeouts call-disconnect 3
timeouts wait-release 3
connection plar 202
shutdown
impedance complex1
caller-id enable
!
voice-port 0/1/2
trunk-group ALL_FXO 64
supervisory disconnect dualtone mid-call
cptone AU
timeouts call-disconnect 3
timeouts wait-release 3
connection plar 203
shutdown
impedance complex1
caller-id enable
!
voice-port 0/1/3
trunk-group ALL_FXO 64
supervisory disconnect dualtone mid-call
cptone AU
timeouts call-disconnect 3
timeouts wait-release 3
connection plar 204
shutdown
impedance complex1
caller-id enable
!
voice-port 0/4/0
auto-cut-through
signal immediate
input gain auto-control -15
description Music On Hold Port
!
sccp local Loopback0
sccp ccm 10.0.1.254 identifier 1 version 3.1
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
!
dial-peer cor custom
name internal
name local
name local-plus
name international
name national
name national-plus
name emergency
name toll-free
!
!
dial-peer cor list call-internal
member internal
!
dial-peer cor list call-local
member local
!
dial-peer cor list call-local-plus
member local-plus
!
dial-peer cor list call-national
member national
!
dial-peer cor list call-national-plus
member national-plus
!
dial-peer cor list call-international
member international
!
dial-peer cor list call-emergency
member emergency
!
dial-peer cor list call-toll-free
member toll-free
!
dial-peer cor list user-internal
member internal
member emergency
!
dial-peer cor list user-local
member internal
member local
member emergency
member toll-free
!
dial-peer cor list user-local-plus
member internal
member local
member local-plus
member emergency
member toll-free
!
dial-peer cor list user-national
member internal
member local
member local-plus
member national
member emergency
member toll-free
!
dial-peer cor list user-national-plus
member internal
member local
member local-plus
member national
member national-plus
member emergency
member toll-free
!
dial-peer cor list user-international
member internal
member local
member local-plus
member international
member national
member national-plus
member emergency
member toll-free
!
!
dial-peer voice 5 pots
description ** MOH Port **
destination-pattern ABC
port 0/4/0
no sip-register
!
dial-peer voice 50 pots
description ** incoming dial peer **
incoming called-number .%
port 0/1/0
!
dial-peer voice 51 pots
description ** incoming dial peer **
incoming called-number .%
port 0/1/1
!
dial-peer voice 52 pots
description ** incoming dial peer **
incoming called-number .%
port 0/1/2
!
dial-peer voice 53 pots
description ** incoming dial peer **
incoming called-number .%
port 0/1/3
!
dial-peer voice 54 pots
description ** FXO pots dial-peer **
destination-pattern A0
port 0/1/0
no sip-register
!
dial-peer voice 55 pots
description ** FXO pots dial-peer **
destination-pattern A1
port 0/1/1
no sip-register
!
dial-peer voice 56 pots
description ** FXO pots dial-peer **
destination-pattern A2
port 0/1/2
no sip-register
!
dial-peer voice 57 pots
description ** FXO pots dial-peer **
destination-pattern A3
port 0/1/3
no sip-register
!
dial-peer voice 2000 voip
description ** cue voicemail pilot number **
translation-profile outgoing XFER_TO_VM_PROFILE
destination-pattern 399
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
voice-class sip outbound-proxy ipv4:10.1.10.1 
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 1 pots
description ** FXS PORT 0/0/0 **
destination-pattern 301
port 0/0/0
!
dial-peer voice 2 pots
description ** FXS PORT 0/0/1 **
destination-pattern 302
port 0/0/1
!
dial-peer voice 3 pots
description ** FXS PORT 0/0/2 **
destination-pattern 303
port 0/0/2
!
dial-peer voice 4 pots
description ** FXS PORT 0/0/3 **
destination-pattern 304
port 0/0/3
!
dial-peer voice 58 pots
trunkgroup ALL_FXO
corlist outgoing call-emergency
description **CCA*Australia*Emergency Services**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0000
forward-digits all
no sip-register
!
dial-peer voice 59 pots
trunkgroup ALL_FXO
corlist outgoing call-emergency
description **CCA*Australia*Emergency Services**
preference 5
destination-pattern 000
forward-digits all
no sip-register
!
dial-peer voice 60 pots
trunkgroup ALL_FXO
corlist outgoing call-emergency
description **CCA*Australia*Emergency TTY**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0106
forward-digits all
no sip-register
!
dial-peer voice 61 pots
trunkgroup ALL_FXO
corlist outgoing call-emergency
description **CCA*Australia*Emergency TTY**
preference 5
destination-pattern 106
forward-digits all
no sip-register
!
dial-peer voice 62 pots
trunkgroup ALL_FXO
corlist outgoing call-international
description **CCA*Australia*International Access**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0001[1589]T
forward-digits all
no sip-register
!
dial-peer voice 63 pots
trunkgroup ALL_FXO
corlist outgoing call-international
description **CCA*Australia*Premium Services**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 00055T
forward-digits all
no sip-register
!
dial-peer voice 64 pots
trunkgroup ALL_FXO
corlist outgoing call-local-plus
description **CCA*Australia*Analogue AMPS service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0014[04689].....
forward-digits all
no sip-register
!
dial-peer voice 65 pots
trunkgroup ALL_FXO
corlist outgoing call-local-plus
description **CCA*Australia*Analogue AMPS & Satellite**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0014[12357]......
forward-digits all
no sip-register
!
dial-peer voice 66 pots
trunkgroup ALL_FXO
corlist outgoing call-local-plus
description **CCA*Australia*Analogue AMPS service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0015......
forward-digits all
no sip-register
!
dial-peer voice 67 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Paging Service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 00160..
forward-digits all
no sip-register
!
dial-peer voice 68 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Paging Service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0016[1236789].....
forward-digits all
no sip-register
!
dial-peer voice 69 pots
trunkgroup ALL_FXO
corlist outgoing call-local-plus
description **CCA*Australia*Analogue AMPS service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0017[1289].....
forward-digits all
no sip-register
!
dial-peer voice 70 pots
trunkgroup ALL_FXO
corlist outgoing call-local-plus
description **CCA*Australia*Analogue AMPS service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0018......
forward-digits all
no sip-register
!
dial-peer voice 71 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Data Network Access Service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 00192.
forward-digits all
no sip-register
!
dial-peer voice 72 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Data Network Access Service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 00198[01239].....
forward-digits all
no sip-register
!
dial-peer voice 73 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Data Network Access Service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 00198[45678]
forward-digits all
no sip-register
!
dial-peer voice 74 pots
trunkgroup ALL_FXO
corlist outgoing call-national
description **CCA*Australia*NSW Numbers**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 002........
forward-digits all
no sip-register
!
dial-peer voice 75 pots
trunkgroup ALL_FXO
corlist outgoing call-national
description **CCA*Australia*VIC, TAS Numbers**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 003........
forward-digits all
no sip-register
!
dial-peer voice 76 pots
trunkgroup ALL_FXO
corlist outgoing call-local-plus
description **CCA*Australia*Digital Mobile Service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 004........
forward-digits all
no sip-register
!
dial-peer voice 77 pots
trunkgroup ALL_FXO
corlist outgoing call-national
description **CCA*Australia*Universal Personal Comms Service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 005........
forward-digits all
no sip-register
!
dial-peer voice 78 pots
trunkgroup ALL_FXO
corlist outgoing call-national
description **CCA*Australia*QLD Numbers**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 007........
forward-digits all
no sip-register
!
dial-peer voice 79 pots
trunkgroup ALL_FXO
corlist outgoing call-national
description **CCA*Australia*SA, WA, NT Numbers**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 008........
forward-digits all
no sip-register
!
dial-peer voice 80 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Community Service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 01100
forward-digits all
no sip-register
!
dial-peer voice 81 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Community Service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0110[1-9]..
forward-digits all
no sip-register
!
dial-peer voice 82 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Public Interest Service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0113...
forward-digits all
no sip-register
!
dial-peer voice 83 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Mass Calling Service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0114.....
forward-digits all
no sip-register
!
dial-peer voice 84 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Community Service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0119.
forward-digits all
no sip-register
!
dial-peer voice 85 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Directory and Service Numbers**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0122[1235]
forward-digits all
no sip-register
!
dial-peer voice 86 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Directory and Operator Numbers**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0123[46]
forward-digits all
no sip-register
!
dial-peer voice 87 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Operator Service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 012[45]T
forward-digits all
no sip-register
!
dial-peer voice 88 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Local Rate Numbers**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0130.......
forward-digits all
no sip-register
!
dial-peer voice 89 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Local Rate Numbers**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 013[1-9]...
forward-digits all
no sip-register
!
dial-peer voice 90 pots
trunkgroup ALL_FXO
corlist outgoing call-international
description **CCA*Australia*Carrier Preselection Codes**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 014[1-9]T
forward-digits all
no sip-register
!
dial-peer voice 91 pots
trunkgroup ALL_FXO
corlist outgoing call-toll-free
description **CCA*Australia*Freephone Numbers**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0180[01]......
forward-digits all
no sip-register
!
dial-peer voice 92 pots
trunkgroup ALL_FXO
corlist outgoing call-toll-free
description **CCA*Australia*Freephone Numbers**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0180[2-9]...
forward-digits all
no sip-register
!
dial-peer voice 93 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Universal PCS Profile Management**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0185..
forward-digits all
no sip-register
!
dial-peer voice 94 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*Australia*Calling Card Service**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0189..
forward-digits all
no sip-register
!
dial-peer voice 95 pots
trunkgroup ALL_FXO
corlist outgoing call-international
description **CCA*Australia*Premium Services**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0190[0126]......
forward-digits all
no sip-register
!
dial-peer voice 96 pots
trunkgroup ALL_FXO
corlist outgoing call-international
description **CCA*Australia*Premium Services**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 019[1345]...
forward-digits all
no sip-register
!
dial-peer voice 97 pots
trunkgroup ALL_FXO
corlist outgoing call-international
description **CCA*Australia*Premium Services**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 019[679].....
forward-digits all
no sip-register
!
dial-peer voice 98 pots
trunkgroup ALL_FXO
corlist outgoing call-national
description **CCA*Australia*8-digit dialing**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 0[2-9].......
forward-digits all
no sip-register
!
dial-peer voice 1000 voip
permission term
description ** Incoming call from SIP trunk (Generic SIP Trunk Provider) **
session protocol sipv2
session target sip-server
incoming called-number .%
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1001 voip
corlist outgoing call-local
description ** star code to SIP trunk (Generic SIP Trunk Provider) **
destination-pattern *..
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1003 voip
description ** Passthrough Inbound Calls from CUE **
translation-profile incoming SIP_Passthrough
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
incoming called-number ABCDT
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 1005 voip
description ** Passthrough Inbound MWI from CUE **
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
incoming called-number A80T
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 1020 voip
corlist outgoing call-national
description **CCA*Australia*8-digit dialing**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0[2-9].......
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1021 voip
corlist outgoing call-local-plus
description **CCA*Australia*Digital Mobile Service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 004........
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1022 voip
corlist outgoing call-national
description **CCA*Australia*VIC, TAS Numbers**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 003........
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1023 voip
corlist outgoing call-local
description **CCA*Australia*Community Service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0110[1-9]..
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1024 voip
corlist outgoing call-local
description **CCA*Australia*Community Service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 01100
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1025 voip
corlist outgoing call-local
description **CCA*Australia*Community Service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0119.
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1026 voip
corlist outgoing call-local
description **CCA*Australia*Paging Service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0016[1236789].....
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1027 voip
corlist outgoing call-local
description **CCA*Australia*Paging Service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 00160..
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1028 voip
corlist outgoing call-local
description **CCA*Australia*Public Interest Service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0113...
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1029 voip
corlist outgoing call-local
description **CCA*Australia*Calling Card Service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0189..
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1030 voip
corlist outgoing call-local
description **CCA*Australia*Mass Calling Service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0114.....
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1031 voip
corlist outgoing call-emergency
description **CCA*Australia*Emergency TTY**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0106
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1032 voip
corlist outgoing call-emergency
description **CCA*Australia*Emergency TTY**
translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
preference 1
destination-pattern 106
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1033 voip
corlist outgoing call-international
description **CCA*Australia*International Access**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0001[1589]T
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1034 voip
corlist outgoing call-emergency
description **CCA*Australia*Emergency Services**
translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
preference 1
destination-pattern 000
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1035 voip
corlist outgoing call-emergency
description **CCA*Australia*Emergency Services**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0000
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1036 voip
corlist outgoing call-local
description **CCA*Australia*Directory and Operator Numbers**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0123[46]
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1037 voip
corlist outgoing call-local
description **CCA*Australia*Directory and Service Numbers**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0122[1235]
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1038 voip
corlist outgoing call-national
description **CCA*Australia*QLD Numbers**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 007........
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1039 voip
corlist outgoing call-local-plus
description **CCA*Australia*Analogue AMPS & Satellite**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0014[12357]......
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1040 voip
corlist outgoing call-local
description **CCA*Australia*Universal PCS Profile Management**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0185..
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1041 voip
corlist outgoing call-local
description **CCA*Australia*Data Network Access Service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 00198[01239].....
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1042 voip
corlist outgoing call-local
description **CCA*Australia*Data Network Access Service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 00192.
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1043 voip
corlist outgoing call-local
description **CCA*Australia*Data Network Access Service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 00198[45678]
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1044 voip
corlist outgoing call-toll-free
description **CCA*Australia*Freephone Numbers**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0180[2-9]...
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1045 voip
corlist outgoing call-toll-free
description **CCA*Australia*Freephone Numbers**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0180[01]......
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1046 voip
corlist outgoing call-local
description **CCA*Australia*Operator Service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 012[45]T
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1047 voip
corlist outgoing call-national
description **CCA*Australia*Universal Personal Comms Service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 005........
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1048 voip
corlist outgoing call-local-plus
description **CCA*Australia*Analogue AMPS service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0015......
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1049 voip
corlist outgoing call-local-plus
description **CCA*Australia*Analogue AMPS service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0018......
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1050 voip
corlist outgoing call-local-plus
description **CCA*Australia*Analogue AMPS service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0014[04689].....
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1051 voip
corlist outgoing call-local-plus
description **CCA*Australia*Analogue AMPS service**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0017[1289].....
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1052 voip
corlist outgoing call-local
description **CCA*Australia*Local Rate Numbers**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 013[1-9]...
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1053 voip
corlist outgoing call-local
description **CCA*Australia*Local Rate Numbers**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0130.......
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1054 voip
corlist outgoing call-international
description **CCA*Australia*Premium Services**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 019[679].....
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1055 voip
corlist outgoing call-international
description **CCA*Australia*Premium Services**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 019[1345]...
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1056 voip
corlist outgoing call-international
description **CCA*Australia*Premium Services**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 00055T
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1057 voip
corlist outgoing call-international
description **CCA*Australia*Premium Services**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0190[0126]......
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1058 voip
corlist outgoing call-national
description **CCA*Australia*NSW Numbers**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 002........
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1059 voip
corlist outgoing call-international
description **CCA*Australia*Carrier Preselection Codes**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 014[1-9]T
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1060 voip
corlist outgoing call-national
description **CCA*Australia*SA, WA, NT Numbers**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 008........
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 3000 voip
description SIP-BG
translation-profile incoming SIP-BG_Called_4
session protocol sipv2
session target sip-server
incoming called-number 0390294381
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 48 voip
translation-profile incoming sip_trunk
translation-profile outgoing wash_cli
destination-pattern .....T
session protocol sipv2
session target dns:vibegroup01.iibusiness.net.au
incoming called-number 0380604500-0380604519
voice-class codec 1
voice-class sip asserted-id pai
dtmf-relay rtp-nte
dtmf-interworking rtp-nte
!
dial-peer voice 3002 voip
description LeeDemetrious
translation-profile incoming LeeDemetrious_Called_6
session protocol sipv2
session target sip-server
incoming called-number
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 3003 voip
description MatthewCameron
translation-profile incoming MatthewCameron_Called_7
session protocol sipv2
session target sip-server
incoming called-number
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 3004 voip
description All-BG
translation-profile incoming All-BG_Called_8
session protocol sipv2
session target sip-server
incoming called-number
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
!
no dial-peer outbound status-check pots
sip-ua
authentication username password
calling-info pstn-to-sip asserted-id number set
no remote-party-id
retry invite 2
retry register 10
timers connect 100
host-registrar
!
!
!
telephony-service
video
fxo hook-flash
max-ephones 40
max-dn 300
ip source-address 10.0.1.254 port 2000
auto assign 10 to 43
auto assign 5 to 8 type anl
calling-number initiator
service phone videoCapability 1
service dnis overlay
service dnis dir-lookup
timeouts interdigit 5
system message Vibe Group
url services http://10.1.10.1/voiceview/common/login.do
url authentication http://10.1.10.1/voiceview/authentication/authenticate.do 
load 521G-524G cp524g-8-1-17
load 525G spa525g-7-1-9
load 501G spa5x5-7-1-3c
load 502G spa5x5-7-1-3c
load 504G spa5x5-7-1-3c
load 508G spa5x5-7-1-3c
load 509G spa5x5-7-1-3c
time-zone 48
time-format 24
date-format dd-mm-yy
voicemail 399
max-conferences 8 gain -6
call-forward pattern .T
call-forward system redirecting-expanded
moh flash:/media/music-on-hold.au
multicast moh 239.10.16.16 port 2000
web admin system name cisco secret 5 $1$uwDC$j8UG5FNQIJ86ciRy7tpnj1
dn-webedit
time-webedit
transfer-system full-consult dss
transfer-pattern 9.T
transfer-pattern .T
transfer-pattern 0.T
transfer-pattern 6... blind
secondary-dialtone 0
directory entry 1 00405277279 name Matthew Mobile
directory entry 2 201 name Matthew
directory entry 3 202 name Lee
directory entry 4 203 name Jim
fac standard
create cnf-files version-stamp 7960 Jun 08 2010 21:20:56
!
!
ephone-template  15
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys idle  Redial Newcall Mobility Cfwdall Pickup Gpickup Dnd Login
softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
softkeys connected  Hold Endcall Mobility Trnsfer TrnsfVM Confrn Acct Park
button-layout 7931 2
!
!
ephone-template  16
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys idle  Redial Newcall Mobility Cfwdall Pickup Gpickup Dnd Login
softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
softkeys connected  Hold Endcall Mobility Trnsfer TrnsfVM Confrn Acct Park
!
!
ephone-dn  9
number BCD no-reg primary
description MoH
moh out-call ABC
!
!
ephone-dn  10  dual-line
number 201 secondary 0380604505 no-reg both
label 201
description Matthew Cameron
name Matthew Cameron
mobility
snr 00405277279 delay 5 timeout 30 cfwd-noan 399
call-forward busy 399
call-forward noan 399 timeout 20
!
!
ephone-dn  11  dual-line
number 202 secondary 0380604506 no-reg both
label 202
description Lee Demetrious
name Lee Demetrious
call-forward busy 399
call-forward noan 399 timeout 20
!
!
ephone-dn  12  dual-line
number 203 no-reg primary
label 203
description Jim Simos
name Jim Simos
call-forward busy 399
call-forward noan 399 timeout 20
!
!
ephone-dn  13  dual-line
number 204 no-reg primary
label 204
description 204
name 204
!
!
ephone-dn  14  dual-line
number 205 no-reg primary
label 205
description 205
name 205
!
!
ephone-dn  15  dual-line
number 206 no-reg primary
label 206
description 206
name 206
!
!
ephone-dn  16  dual-line
number 207 no-reg primary
label 207
description 207
name 207
!
!
ephone-dn  17  dual-line
number 208 no-reg primary
label 208
description 208
name 208
!
!
ephone-dn  18  dual-line
number 209 no-reg primary
label 209
description 209
name 209
!
!
ephone-dn  19  dual-line
number 210 no-reg primary
label 210
description 210
name 210
!
!
ephone-dn  20  dual-line
number 211 no-reg primary
label 211
description 211
name 211
!
!
ephone-dn  21  dual-line
number 212 no-reg primary
label 212
description 212
name 212
!
!
ephone-dn  22  dual-line
number 213 no-reg primary
label 213
description 213
name 213
!
!
ephone-dn  23  dual-line
number 214 no-reg primary
label 214
description 214
name 214
!
!
ephone-dn  24  dual-line
number 215 no-reg primary
label 215
description 215
name 215
!
!
ephone-dn  25  dual-line
number 216 no-reg primary
label 216
description 216
name 216
!
!
ephone-dn  26  dual-line
number 217 no-reg primary
label 217
description 217
name 217
!
!
ephone-dn  27  dual-line
number 218 no-reg primary
label 218
description 218
name 218
!
!
ephone-dn  28  dual-line
number 219 no-reg primary
label 219
description 219
name 219
!
!
ephone-dn  29  dual-line
number 220 no-reg primary
label 220
description 220
name 220
!
!
ephone-dn  30  dual-line
number 221 no-reg primary
label 221
description 221
name 221
!
!
ephone-dn  31  dual-line
number 222 no-reg primary
label 222
description 222
name 222
!
!
ephone-dn  32  dual-line
number 223 no-reg primary
label 223
description 223
name 223
!
!
ephone-dn  33  dual-line
number 224 no-reg primary
label 224
description 224
name 224
!
!
ephone-dn  34  dual-line
number 225 no-reg primary
label 225
description 225
name 225
!
!
ephone-dn  35  dual-line
number 226 no-reg primary
label 226
description 226
name 226
!
!
ephone-dn  36  dual-line
number 227 no-reg primary
label 227
description 227
name 227
!
!
ephone-dn  37  dual-line
number 228 no-reg primary
label 228
description 228
name 228
!
!
ephone-dn  38  dual-line
number 229 no-reg primary
label 229
description 229
name 229
!
!
ephone-dn  39  dual-line
number 230 no-reg primary
label 230
description 230
name 230
!
!
ephone-dn  40  dual-line
number 231 no-reg primary
label 231
description 231
name 231
!
!
ephone-dn  41  dual-line
number 232 no-reg primary
label 232
description 232
name 232
!
!
ephone-dn  42  dual-line
number 233 no-reg primary
label 233
description 233
name 233
!
!
ephone-dn  43  dual-line
number 234 no-reg primary
label 234
description 234
name 234
!
!
ephone-dn  44  dual-line
number 235 no-reg primary
label 235
description 235
name 235
!
!
ephone-dn  45  dual-line
number 236 no-reg primary
label 236
description 236
name 236
!
!
ephone-dn  297
number 0380604500
description SIP Main Number registration
preference 10
!
!
ephone-dn  298
number 6... no-reg primary
description ***CCA XFER TO VM EXTENSION***
call-forward all 399
!
!
ephone-dn  299
number A801... no-reg primary
mwi off
!
!
ephone-dn  300
number A800... no-reg primary
mwi on
!
!
ephone  5
device-security-mode none
video
mac-address 0026.998D.2D78
ephone-template 16
max-calls-per-button 2
username "MatthewCameron" password nqr87092
type 525G
button  1:10 2m11 3m12
!
!
!
ephone  6
device-security-mode none
video
mac-address 8843.E155.10E8
ephone-template 16
max-calls-per-button 2
username "LeeDemetrious" password 123456
type 504G
button  1:11 2m10 3m12
!
!
!
ephone  7
device-security-mode none
video
mac-address C47D.4F06.5729
ephone-template 16
max-calls-per-button 2
username "JimSimos" password 123456
type 504G
button  1:12 2m10 3m11
!
!
alias exec cca_voice_mode PBX
banner login ^CCisco Configuration Assistant. Version: 2.2 (4). Tue Jun 08 20:58:33 EST 2010^C
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
line vty 5 100
!
ntp master
end

David Trad Tue, 06/22/2010 - 23:48

Hi Matthew,


Just as a test could you apply this to one of your translation profiles?




voice translation-rule 1111
rule 1 /201/ /0380604500/
rule 2 /^...$/ /0380604500/
rule 3 /^4/ /004/
rule 4 /^7/ /007/
rule 5 /^3/ /0073/
rule 6 /^02/ /002/
rule 7 /^08/ /008/
rule 8 /^03/ /003/
rule 9 /^2/ /002/
rule 10 /^8/ /008/


Look I honestly am not sure if it will work, this only normally gets applied to ISDN/DID services where you get more control over this type of stuff, but rules 3-10 normally take care of the issue you are experiencing, they are the very one I use on pretty much all deployments.


Your current setup baffles me a little, I am not sure why you are running translation rules when you are already plaring the FXO ports to either a PHG or an extension, sadly I don't have enough time on my hands at the moment to go over your whole config and try and work out exactly what is going on, but please give the above a try and let me know how it goes (I am about 30% confident it will yield a result, but doubtful would be more accurate).


I'll keep working with you on this one untill we get a good outcome.


Cheers,



David.

Actions

This Discussion