Can't Add Jtapi Password in CCM 4.2 for Unity Express 3.2

Unanswered Question

I'm connecting Unity Express 3.2  to CCM 4.2 where I need the jtapi user and password. The issue is that I've done everything succesfully except that there is no option in the CCM to add/edit password. I can create user and pin but it won't help in connecting the two. Can anyone suggest a solution if I missed something on the CCM and/or if its a bug?

Prompt reply will be appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Md. Mijanur Rahman Thu, 06/17/2010 - 00:31

Hi, there's no 'User Password*' and 'Confirm Password*' field while creating new user?

Once the user is already created on the user edit page there should be a 'Change...' button besides 'User Password' field.

These all fields should be visible for all user permission groups.

Md. Mijanur Rahman Thu, 06/17/2010 - 01:22

That's interesting! I think the installatoin is currupted i'm not sure though! Have you checked it browsing the ccmadmin page from inside OS?

If you have any existing user and the password is known, then use the user with CTI permissions added on user page.



I haven't tried connecting from inside the OS but I'll try that.

Other than that, I've username and password which was previously created for another site with devices associated to it. As you mentioned to add these new devices/cti ports, my concern is, what would be the impact of adding these new cti ports.

Md. Mijanur Rahman Thu, 06/17/2010 - 02:18

Hi, you can use the same user to integrate with multiple systems, no bad impact!

Just create different CTI ports and VM profile.



I've added the cti ports to the jtapi user but there is still an issue with the voice mail. By trying to call the trigger number or by pressing the mail button, I got the busy signal.

I've created the voice mail profile, pilot number, cti route point, cti ports and configured everything according to cisco documentation, including jtapi policy map on router. Did I miss something? I mean what might the possible reason for getting busy signal?

Aaron Harrison Mon, 06/21/2010 - 00:32


If you view the CTI RPs and ports in CCMAdmin, do you see them shown as 'registered'?


Aaron Harrison Mon, 06/21/2010 - 01:37


Can you screen grab your system/CTI ports menu in CUE Web admin?


This email communication does not create or vary any contractual relationship between Logicalis and you. Internet communications are not secure and accordingly Logicalis does not accept any legal liability for the contents of this message. The contents of this email are confidential to the intended recipient at the email address to which it has been addressed. It may not be disclosed to or used by anyone other than this addressee, nor may it be copied in any way. If received in error, please contact Logicalis on the above switchboard number quoting the name of the sender and the addressee and then delete it from your system. Please note that neither Logicalis nor the sender accepts any responsibility for viruses and it is your responsibility to scan the email and attachments (if any).

Logicalis UK Ltd, Registered in England and Wales No: 3732397, Registered Office: 110 Buckingham Avenue, Slough. Berkshire, SL1 4PF

Ok, somehow I did it. To get rid of the fast busy on voicemail, I had to remove everything and start from scratch.

1st thing I did was remove Voice Mail Profile, Voicemail Pilot and then remove all CTI Ports and the CTI RP. After that I removed all UnAssgined DN in the Route Plan section, it is important to do this else you might fail again and will get Fast Busy on VM.

Then, step by step I created CTI RP, 8 CTI Ports, VM Pilot with DN as CTI RP. Created VM Profile and added the the VM Pilot. I associated CTI ports and CTI RP with the Jtapi user and reloaded the Unity Express.

In the mean time I removed the Extension (DN) I was using for the VM testing and created a new DN assigning the VM Profile and checking the tik boxes for VM. After that I went to Serviceability, stopped the CTI services and restarted. Bingo!! It worked like a charm.

If any one interested I can provide the configuration on the router side too.


This Discussion

Related Content