communication between L3(3560G) to L3 switches with help of RIP

Answered Question
Jun 23rd, 2010
User Badges:

The problem is I want to made communication between L3(3560G) to L3 switches with help of RIP.

I configured the same think but not got success, but my L3 to L2 (2960)are working fine in a same building.

Please find attached configuration files of L3, L2  and network diagram, and suggest me proper configuration in respect of same.

So my aim is made communication between both building users to each other.

Correct Answer by Hitesh Vinzoda about 6 years 11 months ago

Hi Akshay,


In that case,


Instead of assigning IP address on physical fiber ports, make them as dot1q trunk on both sides,


1. Create a new vlan x on both switches

2. create Interface vlanx on both switches and assign the ip addresses that you wanted to assign it on physical ports

3. advertize this interfaces in eigrp using network command

4. eigrp neighbor will come up

5. verify using sh ip eigrp neigh and sh ip route eigrp

6. the link that you configured will be multilayer link, means the layer 2 traffic will pass through using trunk and if some traffic requires to go to other vlan in other switch will be routed via eigrp on the same link


Hope this helps


Hitesh Vinzoda


Pls rate useful posts

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Hitesh Vinzoda Wed, 06/23/2010 - 06:22
User Badges:
  • Silver, 250 points or more

Hi,


First of all, why you want to use rip ? You better be using eigrp ...


Create a routed link (fiber ports) between two switches, i believe you dont want to pass layer 2 traffic across both switches.


On Switch A

int gix/y

no switchport

ip address 10.100.x.y 255.255.255.252


On switch B

int gix/y

no switchport

ip address 10.100.x.z 255.255.255.252


On Switch A



router eigrp 100

network 10.100.0.0 0.0.255.255

network 10.100.x.y 0.0.0.0  

no auto-summary


insert this command only if you have assigned IP to routed port other that 10.100 network            

Write down the ip address not the network address e.g. if ip add is 10.2.3.1/30 use network "10.2.3.1 0.0.0.0"



On switch B


router eigrp 100

network 10.100.0.0 0.0.255.255

network a.b.c.e 0.0.0.0                Write down the ip address not the network address e.g. if ip add is 10.2.3.2/30 use network "10.2.3.1 0.0.0.0"

no auto-summary


Eigrp neighborship will come up


verify

using "sh ip eigrp neigh"

sh ip route




HTH


Hitesh Vinzoda


Pls rate useful posts

moreakshayraj Wed, 06/23/2010 - 21:43
User Badges:

Hi Hitesh,


Ok, i'm ready to you eigrp insist of rip.


but i want  to pass layer 2 traffic across both switches, so in that case the suggest configuration is perfect or need to do any changes.


Please suggest...


Regards,

Akshayraj

Correct Answer
Hitesh Vinzoda Wed, 06/23/2010 - 22:27
User Badges:
  • Silver, 250 points or more

Hi Akshay,


In that case,


Instead of assigning IP address on physical fiber ports, make them as dot1q trunk on both sides,


1. Create a new vlan x on both switches

2. create Interface vlanx on both switches and assign the ip addresses that you wanted to assign it on physical ports

3. advertize this interfaces in eigrp using network command

4. eigrp neighbor will come up

5. verify using sh ip eigrp neigh and sh ip route eigrp

6. the link that you configured will be multilayer link, means the layer 2 traffic will pass through using trunk and if some traffic requires to go to other vlan in other switch will be routed via eigrp on the same link


Hope this helps


Hitesh Vinzoda


Pls rate useful posts

moreakshayraj Wed, 06/23/2010 - 22:55
User Badges:

Hi Hitesh,


I'll try the same and let you know if there is any issue.


thanks & regards,


Akshayraj

moreakshayraj Thu, 06/24/2010 - 00:45
User Badges:

hi Hitesh,


its working now, thanks for the same...


Regards,

Akshayraj

Jerry Ye Wed, 06/23/2010 - 06:22
User Badges:
  • Cisco Employee,

Not sure what is the problem but I do see some missing command


router rip

network 10.0.0.0

version 2

no auto-summary


BTW, which VLAN is on the common subnet (the fiber between the 3560 switches)?


Regards,

jerry

Actions

This Discussion