All Phones 'Registering' on CUCM 7 upgrade

Unanswered Question

Hi everyone,


We've upgraded from CM 4.1.3 to CUCM 7.0(2a) and all the data has been imported successfully but the problem I have is that every IP phone I try and register it just sits there 'registering'. All the data looks good, and there were no errors on import  and the publisher issues a DHCP address and TFTP firmware upgrade to the phones without any issue - but they just wont register!!  Ive tried 7940,12, and 70's but they all have the same problem.  Ive also tried diasbling CTL etc but makes no difference.  The only change I can think of between the two call manager versions are the names - ver 4 was called CCM_PUB1 whereas the version 7 is CCMPUB1 (same for the subs) - I dont know if this would make any difference?


Cheers


Mark

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (7 ratings)
Loading.
Aaron Harrison Wed, 06/23/2010 - 06:16
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi Mark


First thing that comes to mind is that the phones get a list of servers from TFTP - this includes the names or IPs as specified under the 'System/Servers' menu in CCMAdmin.


If that menu has names (e.g. CCMPUB1) then the phones need to resolve that to IP via DNS - if this is how thing are running, it's possible the DNS entries haven't been updated since the upgrade and name change?


If that is the case (check the System/Servers menu, and if it's listed by name, then try pinging each name as it is listed), then you have two choices:


1) Update DNS (do this anyway, sooner or later)

2) Change the server names to IPs (carefully! get it wrong and you will have a fun afternoon) and then reset all the phones


Regards


Aaron


Please rate helpful posts...

Aaron Harrison Wed, 06/23/2010 - 06:25
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


No problem... you mention CTL, are you using encryption on this cluster?


Are the IPs in the settings page on the phone correct, and can those CCMs ping the phones?


Have you tried doing a pcap of the phone registration?


Aaron

jp.barraja Wed, 06/23/2010 - 06:36
User Badges:

Hello,


As Aaron said, 3 possibilities:

  1. The TFTP server is unreacheable from the IP Phones
  2. The TFTP server is badly configured on the DHCP ip ranges
  3. The CTL is still on and Phones don't have it.


Check the configuration and error messages on a IP Phones via a browser.

Check the TFTP configuration on the network.

Try to do a herd reset of an IP Phone unplugging the phone than plug it again once led are on, do teh following sequence 123456789*0#.


Hoping that will help


JP

Hi Aaron,


Not using CTL, just tried disabling the service (read this somewhere that it could make a difference).  All the phone settings are correct in terms of IP addresses, gateway, TFTP servers etc and pinging is fine.  Haven't grabbed a capture yet but it's probably the sensible next step!!


Thanks.

Rob Huffman Wed, 06/23/2010 - 06:47
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Mark,


I don't want to pile too much on here in addition to the great help from Aaron & JP (+5 each folks!)


I thought that you might take a moment to read this excellent blog from Bill Bell because

you are running CUCM 7.0


http://www.netcraftsmen.net/resources/blogs/cucm-upgrade-may-cause-host-name-issue.html


Cheers! And good luck here!
Rob

Hi Guys,


Huge thanks to you guys for trying to help me out here - it's really appreciated.  Well, the good news is that it's now working and the reason that things weren't working was due to the Software License Version not being completed - I'd forgot to register the product!  DOH!!!!!!!

Oh well, live and learn - at least I wont forget to do that again!


Thanks again for everyones help,


Mark

Rob Huffman Wed, 06/23/2010 - 10:03
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hey mark,


DOH!! I guess we all missed that one


+5 points for posting back with your results! Great work

getting things up and running.


Cheers!

Rob

Actions

This Discussion