Corrupted LFIB entry

Unanswered Question
Jun 24th, 2010

Hi,

For some reason there is a corrupted LFIB entry on one of my PE routers (6509, Sup720-3B, 12.2(33)SXI2) which disrupts normal traffic flow. The output of the sh ip bgp vpnv4 vrf A labels command shows that MP-BGP assigned label 31 to FEC A(vrf A), but when I do a sh mpls forwarding-table labels 31 I can see that label 31 points to some wrong FEC (FEC B) which resides in vrf B. Is there any way I can force the router to reassign labels to all the FECs it has all over again? Some command? I've found this one "clear mpls ldp checkpoint *" but I'm not sure that it's the right command in my case.
Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Reza Sharifi Thu, 06/24/2010 - 18:52

Hi,

Not sure about the specific issue you have but I know that SXI2 is a deferred release and should not be used.  An upgrade to SXI2a, 3 or 4 now may help resolve your issue.

HTH

Reza 

saiiven07 Fri, 06/25/2010 - 02:43

Hi,

Yeah, I've already decided that I'm going to upgrade to SXI3 soon because it's a very strange behavior and it shouldn't happen. But I'm still wondering if there's a command that clears the LFIB (forwarding plane) and refills it again. So basically the question is what to do when control plane data doesn't match forwarding plane data(except rebooting the router)?

saiiven07 Sun, 06/27/2010 - 07:26

Hi, Shivlu

Thanks for the reply. I've surfed your website for a while and there's a lot of useful information on troubleshooting different network problems. Keep up the good work. As for my problem, I have a slightly different situation. The PE router in question propagates the same lable for the FEC A in vrf A that I can see after issuing the sh ip bgp vpnv4 vrf A lables command. No problem here. But at the same time it, for some reason/bug, installs an absolutely different label in its LFIB table, so I don't think that clearing the MP-iBGP session with the RR will help in my case. And looks like there's no clear command to fix it.

shivlu jain Sun, 06/27/2010 - 11:01

Hi

I have seen this problem but not able to document it, In this case you need to refresh the MP-iBGP session. Because bottom label is not generated by ldp

regards

Shivlu Jain

http://www.mplsvpn.info

saiiven07 Sun, 06/27/2010 - 13:51

Shivlu,

I agree that the VPN label has been generated by MP-BGP. As I understand it after I clear the BGP session with the RR, the router's just going to resend the same information without assigning a new label and updating the LFIB entry. Although I may be wrong. I'll give it a shot.

shivlu jain Sun, 07/04/2010 - 23:58

Hi

After refreshing the BGP entry label could be generated again. Or  I have one work around for you; on PE simple add the mpls ip command in global; that will refresh the all labels without hanging out the session. I tried it in live network.

regards

shivlu jain

http://www.mplsvpn.info

Actions

This Discussion