cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6648
Views
0
Helpful
6
Replies

HSRP 3560

afionda
Level 1
Level 1

All,

I have a newbie question.

I have two 3560 L3 switches, I would like to setup HSRP so they failover.

My question is:

How do i setup HSRP with etherchannels.

Do i just add standby 1 IP-ADDDRESS command to the etherchannel or vlan interface ?

Here is my setup

ip routing is enabled on both devices.

3560_A

interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable

interface Vlan200
description Production
ip address 200.200.1.254 255.255.255.0

3560_B

interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable

interface Vlan200
ip address 200.200.1.253 255.255.255.0

Any help would be great.

Thanks in advance

6 Replies 6

konigl
Level 7
Level 7

Standby commands for HSRP go on the Layer 3 interfaces.  That is, the ones with the IP addresses.  Which in your example would be your interface Vlan200.

Ganesh Hariharan
VIP Alumni
VIP Alumni

All,

I have a newbie question.

I have two 3560 L3 switches, I would like to setup HSRP so they failover.

My question is:

How do i setup HSRP with etherchannels.

Do i just add standby 1 IP-ADDDRESS command to the etherchannel or vlan interface ?

Here is my setup

ip routing is enabled on both devices.

3560_A

interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable

interface Vlan200
description Production
ip address 200.200.1.254 255.255.255.0

3560_B

interface Port-channel1

switchport trunk encapsul

If you want to make redundacy for traffic coming from vlan 200 then configure standby 1 ip address under vlan 200 svi interface to enable HSRP.

Hope to Help !!

Ganesh.H

Remember to rate the helpful post

afionda
Level 1
Level 1

Guys,

Thank you VERY much for the quick responce.

So if i am not mistaken this config should look like this, I saw in the 3560 guide you dont have to specify the ip on the secondary interface cause it will be learned.

I guess the only reason i would put it on both interface is to standardize everything.

3560_A

interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable

interface Vlan200
description Production
ip address 200.200.1.254 255.255.255.0

standby 200 ip 200.200.1.252 255.255.255.0

3560_B

interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable

interface Vlan200
ip address 200.200.1.253 255.255.255.0

standby 200 ip 200.200.1.252 255.255.255.0

Please correct me if i am worong.

Once again THANK YOU GUYS.

I will be using this forum MUCH more.

Hi Adam,

As i said earlier configuration is simple and will work for vlan 200

traffic coming in from host to vip of standby group 200.

Hope to Help !!

Ganesh.H

Remember to rate the helpful post

afionda
Level 1
Level 1

First off,

Thank you very much for the help again guys.

I got it to work, but i dont think thats what i need,

I am looking for an active/active connection i think.

I have 2 3560 L3 switch and would like them to be active / active, so if one router has a power failure, the secondary router will take the master role.

When i cluster the routers will the routing configuration copy over or must i do that by hand ?

I think maybe a cluster would accomplish this, i am going for my CCNA and just trying to learn as much as i can.

So my config should look like this:

interface Vlan200
description Production
ip address 200.200.1.254 255.255.255.0

standby 1 ip 200.200.1.250

Once in gloabl mode submit command

cluster standby-group HSRP_3560_A-3560_B routing-redundancy

One more question.
Do you guys know which is the best cisco eumlation software ?

First off,

Thank you very much for the help again guys.

I got it to work, but i dont think thats what i need,

I am looking for an active/active connection i think.

I have 2 3560 L3 switch and would like them to be active / active, so if one router has a power failure, the secondary router will take the master role.

When i cluster the routers will the routing configuration copy over or must i do that by hand ?

I think maybe a cluster would accomplish this, i am going for my CCNA and just trying to learn as much as i can.

So my config should look like this:

interface Vlan200
description Production
ip address 200.200.1.254 255.255.255.0

standby 1 ip 200.200.1.250

Once in gloabl mode submit command

cluster standby-group HSRP_3560_A-3560_B routing-redundancy

One more question.
Do you guys know which is the best cisco eumlation software ?

Hi Adam,

The switches in the cluster standby group are ranked according to HSRP priorities. The switch with the highest priority in the group is the active command switch (AC). The switch with the next highest priority is the standby command switch (SC). The other switches in the cluster standby group are the passive command switches (PC). If the active command switch and the standby command switch become disabled at the same time, the passive command switch with the highest priority becomes the active command switch.

Check out the below link for cluster configuration in cisco 3560 switches

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.1_19_ea1/configuration/guide/swhsrp.html

and simulator for practice purpose is GNS3 or packet tracer will be helpful for realtime practice.

Hope to Help !!

Ganesh.H

Remember to rate the helpful post

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card