Using AP 1310 as repetears - dropping randomly

Unanswered Question
Jun 24th, 2010

I am doing remote support for RV park and we have following setup: Gateway-->WAP(root)--> three wireless backhauled repeater AP's back to the root. Pretty simple setup. All Cisco 13010. We're having issues with repeaters dropping randomly and some users not being able to connect to those AP's.All of repeaters have one antenna on them. Repeaters are about 250ft from each other and from the root AP. We have one SSID for clients and one for AP's to communicate with eachother.

What would be proper way to configure this kind of deployment? I am providing current config for the root AP and for two repeaters. Just looking at the config, are we doing something wrong here?

As you can see from AP2 config we even tried to statically assign parent to it.

Thanks in advance

AP1 ROOT
Building configuration...

Current configuration : 2432 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname AP1
!
no logging console
enable secret 5 #############
!
ip subnet-zero
no ip domain lookup
!
!
aaa new-model
!
!
aaa group server radius rad_eap
!
aaa group server radius rad_mac
!
aaa group server radius rad_acct
!
aaa group server radius rad_admin
!
aaa group server tacacs+ tac_admin
!
aaa group server radius rad_pmip
!
aaa group server radius dummy
!
aaa authentication login default local
aaa authentication login eap_methods group rad_eap
aaa authentication login mac_methods local
aaa authorization exec default local
aaa accounting network acct_methods start-stop group rad_acct
aaa session-id common
!
dot11 ssid TEST
   authentication open
   guest-mode
!
dot11 ssid wireless_backhaul
   authentication open
   infrastructure-ssid
!
!
!
username Cisco password 7 #####
username admin privilege 15 password 7 ######
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid TEST
!
ssid wireless_backhaul
!
speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root access-point
concatenation
mobile station period 20 threshold 70
antenna receive right
antenna transmit right
antenna gain 12
infrastructure-client
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
keepalive 100
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
hold-queue 80 in
!
interface BVI1
ip address 10.61.32.51 255.255.255.0
no ip route-cache
!
ip default-gateway 10.61.32.1
ip http server
ip http authentication aaa
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
!
logging trap warnings
logging facility local1
snmp-server community ####### RO
snmp-server community ####### RW
snmp-server enable traps tty
radius-server attribute 32 include-in-access-req format %h
radius-server vsa send accounting
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
password 7 #########
line vty 5 15
password 7 #########
!
end


AP3 (repeater)
Building configuration...

Current configuration : 2325 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname AP3
!
no logging console
enable secret 5 $1##################
!
ip subnet-zero
!
!
aaa new-model
!
!
aaa group server radius rad_eap
!
aaa group server radius rad_mac
!
aaa group server radius rad_acct
!
aaa group server radius rad_admin
!
aaa group server tacacs+ tac_admin
!
aaa group server radius rad_pmip
!
aaa group server radius dummy
!
aaa authentication login default local
aaa authentication login eap_methods group rad_eap
aaa authentication login mac_methods local
aaa authorization exec default local
aaa accounting network acct_methods start-stop group rad_acct
aaa session-id ##########
!
dot11 ssid TEST
   authentication open
   guest-mode
!
dot11 ssid wireless_backhaul
   authentication open
   infrastructure-ssid
!
!
!
username Cisco password 7 #############
username admin privilege 15 password 7 ##################
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid TEST
!
ssid wireless_backhaul
!
speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0
station-role repeater
antenna receive right
antenna transmit right
infrastructure-client
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
keepalive 100
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
hold-queue 80 in
!
interface BVI1
ip address 10.61.32.53 255.255.255.0
no ip route-cache
!
ip default-gateway 10.61.32.1
no ip http server
ip http authentication aaa
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
!
logging trap warnings
logging facility local1
snmp-server community ########### RO
snmp-server community ############## RW
snmp-server enable traps tty
radius-server attribute 32 include-in-access-req format %h
radius-server vsa send accounting
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
password 7 ##############
line vty 5 15
password 7 #############
!
end

WAP2 (repeater)
Building configuration...

Current configuration : 2408 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname AP2
!
no logging console
enable secret 5 $1####################
!
ip subnet-zero
!
!
aaa new-model
!
!
aaa group server radius rad_eap
!
aaa group server radius rad_mac
!
aaa group server radius rad_acct
!
aaa group server radius rad_admin
!
aaa group server tacacs+ tac_admin
!
aaa group server radius rad_pmip
!
aaa group server radius dummy
!
aaa authentication login default local
aaa authentication login eap_methods group rad_eap
aaa authentication login mac_methods local
aaa authorization exec default local
aaa accounting network acct_methods start-stop group rad_acct
aaa session-id ########
!
dot11 ssid TEST
   authentication open
   guest-mode
!
dot11 ssid wireless_backhaul
   authentication open
   infrastructure-ssid
!
!
!
username admin privilege 15 password 7 060C450C61050E0054
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid TEST
!
ssid wireless_backhaul
!
parent 1 0024.9717.0de0
parent timeout 60
speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role repeater
concatenation
mobile station period 20 threshold 70
antenna receive right
antenna transmit right
antenna gain 12
infrastructure-client
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
keepalive 100
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
hold-queue 80 in
!
interface BVI1
ip address 10.61.32.52 255.255.255.0
no ip route-cache
!
ip default-gateway 10.61.32.1
ip http server
ip http authentication aaa
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
!
logging trap warnings
logging facility local1
snmp-server community ############# RO
snmp-server community ############# RW
snmp-server enable traps tty
radius-server attribute 32 include-in-access-req format %h
radius-server vsa send accounting
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
password 7 ################
line vty 5 15
password 7 ################
!
end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
praetoleiad Mon, 06/28/2010 - 03:10

Maybe you could set the AP Mode of the (GW)  to RootBridge to (RootBridge w/ Wireless Clients) and the other AP/Bridge to (Non-RootBridge w/ Wireless Clients)

vanjaburic Wed, 06/30/2010 - 12:53

Thanks for your reply.

Will they still be able to talk back to the root AP in this configuration? Remember, everythign is wirless except AP1 (root) which is wired back to the gateway. I thought you can only set wireless AP's in repeater mode. But maybe I'm off here.

praetoleiad Mon, 07/05/2010 - 17:53

You can set the role-mode to Root Bridge w/ Wireless Clients and Non-root Bridge w/ wireless clients. The one connected to the LAN must be the Root while the other two will be Non-Root.

Actions

This Discussion