WCS 7.0 install on Virtual Machine shows VM memory error

Unanswered Question
Jun 25th, 2010


We are running WCS on a virtual machines and during the installation we get an error stating:

Failed to parse system memory

VM size will be set to the lowest setting

Verify that this server has the recommended minimul amount of memroy, 2.0 GB

Performance will be impaired and support may be limited by not meeting all of the minimun requirements.

WCS installs successfully after this but I feel it is slow.

It looks like the install can't handle the virtual machine.

The Virtual machine has 4 GB of memory though

I think the JVM startup file is modified and set to the lowest value.

Does anyone know how to check and fix this?

What should actually be the settings and where do I set this?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
patoberli Mon, 08/23/2010 - 03:57


Have you ever received an answer to this?
I also get the exact same error, but already with every 4.2 and 6.0 version.



ARJAN TOXOPEUS Mon, 08/23/2010 - 04:07


You are correct. I have had the same with the previous versions also.

Untill now no response whatsoever.

Maybe I will try to open up a TAC case.

Will inform here if and when I get info.


patoberli Fri, 04/15/2011 - 04:43

Hi Arjan

Did you ever get an answer to this?

I still have the issue, even with the very latest version.


TvdN3tadmin77 Mon, 05/30/2011 - 03:08

i have the same issue @ version

No ideas about allocate memory to JavaVM processes?

patoberli Wed, 02/08/2012 - 02:13

Got still the same error with on a physical Windows Server 2003 Server with 1 CPU and 4GB of RAM.

janne.kuosmanen Mon, 03/19/2012 - 02:31

We had same error when upgrading from 7.0.164 to 7.0.230. wcs is on vmware / win 2003 server standard sp2 with 4 GB RAM. Does anyone have idea where this "VM size will be set to the lowest setting" is adjusted back to normal.

danielfalemo Tue, 10/16/2012 - 05:16


Also had this problem but after contacting tac i finally got an answer to this. The bottom line is that you can not use PAE on a windows server that you will install wcs on. To use more RAM than 4GB you need to use PAE on the windows server. Because you cannot use PAE the RAM cannot be more than 4GB. So if you set the server to 4GB of RAM and not to use PAE it will install correct.

Answer from TAC:

We have created a documentation bug regarding the PAE support in the WCS document . Kindly see the bug details :

CSCuc70883 : WCS does not work with PAE, but PAE is advised in our documentation


Error message during the WCS installation: not enough memory. There is more than 4GB of RAM on the box.


Windows platform is used. PAE is enabled.


Disable PAE and use less amount of memory (no more than 4Gb). See the instruction from Microsoft: http://msdn.microsoft.com/en-us/library/windows/desktop/aa366778


Use Linux platform.

This bug is a new bug , so you may be not be able to view the bug details . it will take time to be accessible by your CCO ID .


This Discussion

Related Content



Trending Topics - Security & Network