Network Out of order

Answered Question
Jun 25th, 2010

Hi all,

I have two VG routers- router 1 and router 2-  both have the same configuration and were working fine, suddenly one of them can place calls to PSTN but no in-bound calls from PSTN. to be more accurate the routers have Auto-Attendant script, if I called the router1 I can here the AA message and once I entered the extension, the router reply the destination un-reachable. router2 is OK.

I tried to use csim start XXXX from router 2 is Ok and the phone is ringing. but from router 1 no.

I used debug voice ccapi inout I found disconnect cause 38 which is network out of order. any body can tell me what is the meaning of that and if any body can tell how to solve this it will be very appreciated

I attached the debug. I placed calls to extension using csim start and I called from my mobile and press 0 to reach the operator but no luck.

Attachment: 
I have this problem too.
0 votes
Correct Answer by Abu Hadee about 6 years 5 months ago

Hi

The Gateway is doing what it should do.

Make sure Callmanager has 172.20.170.2 as H323 GW.

I saw a incoming call to the gw from 172.20.104.6. I hope 172.20.170.2 is configured properly. If that is the case, I can only think that CSS on the GW config on CUCM causing it to match some other device.

Call manager trace would have been very good. But if you have problem collecting it, can you give the snapshot of the GW config on the callmanager?

Thank you

- abu

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (6 ratings)
Loading.
JustForVoice_2 Sat, 06/26/2010 - 05:23

Anybody can tell me what is the meaning of the word Network?

Shall I check network connectivity or Networking issues.

Or the network here maybe IPT network?

kebrenna Sat, 06/26/2010 - 07:08

Hi,

Can you attach a show run?

What are the phones registered to, call manager?  What is the call flow look like, do you have PRI's coming in from the pstn and are using H323 to the CUCM?

thanks,

K

JustForVoice_2 Sat, 06/26/2010 - 07:17

Thank you for your reply

I am using CallManager 7

I have FXO cards>> its-CISCO.2.0.1.0.tcl application >> CUCM

No Pri connected

regards,

Abu Hadee Sat, 06/26/2010 - 21:19

Hi

Network Out of Order means that the gateway not able to establish tcp connection to the peer, or peer is unreachable.

Now, Call manager wouldn't response if the h225 request coming from known address.

I see you have h323-gateway voip bind command under GigabitEthernet0/0. So I am assuming that you've added 172.20.170.2 to cucm.

now what about "ip access-group ASD-Sulay out" ? I didn't see any access-list configured. Did you try removing it?

You can try debuging "debug ip tcp transaction" and "debug ip tcp port 1720"

Thank you

- abu

JustForVoice_2 Sat, 06/26/2010 - 22:29

Thank you Abu Hadee for this nice information,

the followoing is the output from debug ip tcp transaction

*Jun 26 15:55:40: TCB11A544D8 created
*Jun 26 15:55:40: TCB11A544D8 setting property TCP_NO_DELAY (0) 1D6488C
*Jun 26 15:55:40: TCB11A544D8 setting property TCP_TOS (11) 1D648A0
*Jun 26 15:55:40: TCB11A544D8 setting property TCP_NONBLOCKING_WRITE (10) 1D648F8
*Jun 26 15:55:40: TCB11A544D8 setting property TCP_NONBLOCKING_READ (14) 1D648F8
*Jun 26 15:55:40: TCB11A544D8 setting property TCP keepalive timeout (17) 1D648F8
*Jun 26 15:55:40: TCB11A544D8 setting property TCP_VRFTABLEID (20) 205447C
*Jun 26 15:55:40: TCB11A544D8 setting property TCP_NO_DELAY (0) 1D648A8
*Jun 26 15:55:40: TCB11A544D8 setting property TCP_ALWAYSPUSH (15) 1D648A8
*Jun 26 15:55:40: TCP: Random local port generated 50036, network 1
*Jun 26 15:55:40: TCB11A544D8 bound to
*Jun 26 15:55:40: Reserved port 50036 in Transport Port Agent for TCP IP type 1
*Jun 26 15:55:40: TCP: sending SYN, seq 4045888116, ack 0
*Jun *Jun 26 15:55:40: TCP0: RST with invalid seq. num received, ACK sent to validate RST
*Jun 26 15:55:40: TCP0: RST received, Closing connection
*Jun 26 15:55:40: TCP0: state was LASTACK -> CLOSED [50036 *Jun 26 15:55:40: Released port 50036 in Transport Port Agent for TCP IP type 1 delay 240000
*Jun 26 15:55:40: TCB 0x11A544D8 destroyed
*Jun 26 15:55:48: TCP0: ACK timeout timer expired
*Jun 26 15:55:49: TCP0: ACK timeout timer expired

*Jun 26 15:55:57: Reserved port 0 in Transport Port Agent for TCP IP type 0
*Jun 26 15:55:57: TCP: connection attempt to port 445
*Jun 26 15:55:57: TCP: sending RST, seq 0, ack 1939518559
*Jun 26 15:55:57: TCP: sent RST to*Jun 26 15:55:57: Released port 0 in Transport Port Agent for TCP IP type 0 delay 240000
*Jun 26 15:55:57: TCP0: state was LISTEN -> CLOSED [0 -> UNKNOWN(0)]
*Jun 26 15:55:57: TCB 0x12AEE808 destroyed
*Jun 26 15:55:58: Reserved port 0 in Transport Port Agent for TCP IP type 0
*Jun 26 15:55:58: TCP: connection attempt to port 445
*Jun 26 15:55:58: Released port 0 in Transport Port Agent for TCP IP type 0 delay 240000
*Jun 26 15:55:58: TCP0: state was LISTEN -> CLOSED [0 -> UNKNOWN(0)]
*Jun 26 15:55:58: TCB 0x12AEE808 destroyed
*Jun 26 15:55:59: Reserved port 0 in Transport Port Agent for TCP IP type 0

*Jun 26 15:55:59: TCP: connection attempt to port 445
*Jun 26 15:55:59: TCP: sending RST, seq 0, ack 4269790923
*Jun 26 15:55:59: TCP: sent RST to *Jun 26 15:55:59: Released port 0 in Transport Port Agent for TCP IP type 0 delay 240000
*Jun 26 15:55:59: TCP0: state was LISTEN -> CLOSED [0 -> UNKNOWN(0)]
*Jun 26 15:55:59: TCB 0x2307390 destroyed
*Jun 26 15:55:59: Reserved port 0 in Transport Port Agent for TCP IP type 0
*Jun 26 15:55:59: TCP: connection attempt to port 445
*Jun 26 15:55:59: TCP: sending RST, seq 0, ack 4269790923
*Jun 26 15:55:59: TCP: sent RST to

*Jun 26 15:55:59: Released port 0 in Transport Port Agent for TCP IP type 0 delay 240000
*Jun 26 15:55:59: TCP0: state was LISTEN -> CLOSED [0 -> UNKNOWN(0)]
*Jun 26 15:55:59: TCB 0x11A544D8 destroyed

*Jun 26 15:56:01: TCP0: FIN processed
*Jun 26 15:56:01: TCP0: state was *Jun 26 15:56:01: TCP0:

Abu Hadee Sat, 06/26/2010 - 22:41

Looks like TCP session establishes properly for 1720.
Can you collect "debug h225 asn1" from the gateway and cucm trace from the  72.20.104.6( make sure it is set to detail)

Thank you

- abu

JustForVoice_2 Sun, 06/27/2010 - 00:15

Thank you too much Abu hadee,

I collect the output of debug h225 asn1

and I will try to collect the traces ASAP.

Hope we can solve the problem with out the traces.

Correct Answer
Abu Hadee Sun, 06/27/2010 - 03:46

Hi

The Gateway is doing what it should do.

Make sure Callmanager has 172.20.170.2 as H323 GW.

I saw a incoming call to the gw from 172.20.104.6. I hope 172.20.170.2 is configured properly. If that is the case, I can only think that CSS on the GW config on CUCM causing it to match some other device.

Call manager trace would have been very good. But if you have problem collecting it, can you give the snapshot of the GW config on the callmanager?

Thank you

- abu

JustForVoice_2 Sun, 06/27/2010 - 06:15

YOU ARE THE MAN.

Thank you too much for your support.

somebody changed the IP address of the gateway and this was the problem.

I cahnged the Device name and reset the gateway and it is OK now.

Thank you toooo much.

I just need to ask you one more thing, where I can find more details about the debug commands. like in my case I traced the output I found disconnect cause 38 which is Network out of order. but I did not find any thing to give me more details about the meaning and causes for this error.

when you asked me to collect the h225 asn1 I did not understand anything from the output.

So, any reference for this?

I realy appreciate your support and again thank you too much.

Abu Hadee Mon, 06/28/2010 - 01:45

Hi

Nice to hear that your problem got resolved.

There is no document explained all the disconnect cause code. Hopefully in few days I'll write one and publish:)

h225 debug is hard to understand as it is not in readable format.

You can read "troubleshooting IP Telephony" book from Cisco Press. You can also review

http://www.cisco.com/en/US/partner/docs/ios/12_3/debug/command/reference/dbg_h1g.html#wp1093900

hope this helps.

thank you

- abu

JustForVoice_2 Mon, 06/28/2010 - 02:55

Thank you too much for your help

I have this book but it is not enough (this what I saw)

Anyhow I am waiting you to write the troubleshooting document. but how I will know that you did it??

Regards,

kidnapped Mon, 11/08/2010 - 05:49

Good day!

I beg Sorry my bad English.

I have a problem when handling calls. Error is the same - Network of office warrant.


Gatevay - Cisco 5350, IOS 12.4

Below cite any debuggers found


thanks

debug ip tcp transactions

Nov  8 09:16:23.157: TCB65C640A0 created
Nov  8 09:16:23.157: TCB65C640A0 setting property TCP_PID (8) 657C301C
Nov  8 09:16:23.157: TCB65C640A0 setting property TCP_NO_DELAY (1) 657C3020
Nov  8 09:16:23.157: TCB65C640A0 setting property TCP_TOS (11) 657C3048
Nov  8 09:16:23.157: TCB65C640A0 setting property TCP_NONBLOCKING_WRITE (10) 657C30A8
Nov  8 09:16:23.157: TCB65C640A0 setting property TCP_NONBLOCKING_READ (14) 657C30A8
Nov  8 09:16:23.157: TCB65C640A0 setting property TCP keepalive timeout (17) 657C30A8
Nov  8 09:16:23.157: TCB65C640A0 setting property TCP_NO_DELAY (1) 657C3064
Nov  8 09:16:23.157: TCB65C640A0 setting property TCP_ALWAYSPUSH (15) 657C3064
Nov  8 09:16:23.157: TCP: Random local port generated 13151
Nov  8 09:16:23.157: TCB65C640A0 bound to xxxxxxxxx.13151
Nov  8 09:16:23.157: TCP: sending SYN, seq 3573862222, ack 0
Nov  8 09:16:23.157: TCP0: Connection to aaaaaaaaaaa:1720, advertising MSS 536
Nov  8 09:16:23.157: TCP0: state was CLOSED -> SYNSENT [13151 -> aaaaaaaaa(1720)]
Nov  8 09:16:25.157: xxxxxxxxxxxxxxx:13151 <---> aaaaaaaaaaaa:1720   congestion window changes
Nov  8 09:16:25.157: cwnd from 536 to 536, ssthresh from 65535 to 1072
Nov  8 09:16:25.157: TCP0: timeout #1 - timeout is 4000 ms, seq 3573862222
Nov  8 09:16:25.157: TCP: (13151) -> aaaaaaaaaaaaa(1720)
Nov  8 09:16:29.157: TCP0: timeout #2 - timeout is 8000 ms, seq 3573862222
Nov  8 09:16:29.157: TCP: (13151) -> aaaaaaaaaaaa(1720)
Nov  8 09:16:37.157: TCP0: timeout #3 - timeout is 16000 ms, seq 3573862222
Nov  8 09:16:37.157: TCP: (13151) -> aaaaaaaaaaaa(1720)
Nov  8 09:16:38.157: TCP0: state was SYNSENT -> CLOSED [13151 -> aaaaaaaaaaaaa(1720)]
Nov  8 09:16:38.157: TCB 0x65C640A0 destroyed
Nov  8 09:16:38.157: %VOIPAAA-5-VOIP_CALL_HISTORY: CallLegType 2, ConnectionId 95AD62CB EA4F11DF 8023001E 13D10702, SetupTime 13:16:23.157 SAR Mon Nov 8 2010, PeerAddress 9999#sdsdsdsdsds, PeerSubAddress , DisconnectCause 26  , DisconnectText network out of order (38), ConnectTime 13:16:38.157 SAR Mon Nov 8 2010, DisconnectTime 13:16:38.157 SAR Mon Nov 8 2010, CallOrigin 1, ChargedUnits 0, InfoType 2, TransmitPackets 0, TransmitBytes 0, ReceivePackets 0, ReceiveBytes 0
Nov  8 09:16:38.157: TCB65C0E12C created
Nov  8 09:16:38.157: TCB65C0E12C setting property TCP_PID (8) 657C301C
Nov  8 09:16:38.157: TCB65C0E12C setting property TCP_NO_DELAY (1) 657C3020
Nov  8 09:16:38.157: TCB65C0E12C setting property TCP_TOS (11) 657C3048
Nov  8 09:16:38.157: TCB65C0E12C setting property TCP_NONBLOCKING_WRITE (10) 657C30A8
Nov  8 09:16:38.157: TCB65C0E12C setting property TCP_NONBLOCKING_READ (14) 657C30A8
Nov  8 09:16:38.157: TCB65C0E12C setting property TCP keepalive timeout (17) 657C30A8
Nov  8 09:16:38.157: TCB65C0E12C setting property TCP_NO_DELAY (1) 657C3064
Nov  8 09:16:38.157: TCB65C0E12C setting property TCP_ALWAYSPUSH (15) 657C3064
Nov  8 09:16:38.157: TCP: Random local port generated 34095
Nov  8 09:16:38.157: TCB65C0E12C bound to xxxxxxxxxxxxxxx.34095
Nov  8 09:16:38.157: TCP: sending SYN, seq 3498343848, ack 0
Nov  8 09:16:38.157: TCP0: Connection to aaaaaaaaaaaaaa:1720, advertising MSS 536
Nov  8 09:16:38.157: TCP0: state was CLOSED -> SYNSENT [34095 -> aaaaaaaaaaa(1720)]
saratov#
Nov  8 09:16:40.157: 77.245.211.17:34095 <---> xxxxxxxxxxxxxx:1720   congestion window changes
Nov  8 09:16:40.157: cwnd from 536 to 536, ssthresh from 65535 to 1072
Nov  8 09:16:40.157: TCP0: timeout #1 - timeout is 4000 ms, seq 3498343848
Nov  8 09:16:40.157: TCP: (34095) -> xxxxxxxxxxxxx(1720)
saratov#
Nov  8 09:16:44.157: TCP0: timeout #2 - timeout is 8000 ms, seq 3498343848
Nov  8 09:16:44.157: TCP: (34095) -> xxxxxxxxxxxx(1720)
saratov#
Nov  8 09:16:52.157: TCP0: timeout #3 - timeout is 16000 ms, seq 3498343848
Nov  8 09:16:52.157: TCP: (34095) -> xxxxxxxxxxxx(1720)
Nov  8 09:16:53.157: TCP0: state was SYNSENT -> CLOSED [34095 -> 80.237.13.33(1720)]
Nov  8 09:16:53.157: TCB 0x65C0E12C destroyed

Claudio Quiroz ... Mon, 10/24/2016 - 12:21

Thank you Abu,

I´m working with FXO MGCP Gateway in Chile and the debug commands showed me disconnect cause = 38 ("Network out of order"). So I checked the dial-peers in Gateway (as you suggested) and they don´t have set the mgcp service.

I set it and the problem was resolved properly !

Actions

This Discussion