WLC 7.0 discontinues CDP support?

Unanswered Question
Jun 25th, 2010

I just upgraded to 7.0.98.0 on a WiSM blade and it is telling me that it no longer supports CDP?  Whoa is this right?  All of my current APs that were on 6.0 and upgraded to 7.0 still have CDP working... but if I get a new AP out of the box that has not been on a controller yet, and join it to the controller.... if I want to make any changes I have to disable CDP.  It says that CDP is not enabled on the controller.  Sure enough it isn't, but when I tried to enable, it said it wasn't supported.

Please tell me this is a bug and it will be fixed in the next 7.0 release!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jlhainy Fri, 06/25/2010 - 11:09

ok, it looks like this is a controller issue and if I go to the controller I can enable cdp for the AP.... but I cannot do that in WCS. 

jlhainy Fri, 06/25/2010 - 12:07

ok.... I am now priming some brand  new APs out of the box after upgrading to 7.0.  During my priming, I  give the AP a more user friendly hostname, assign primary and secondary  controllers and assign an AP group to the AP.

Now, I like to do this in WCS  in a multiple controller environment.  So as the new APs come up, they  have the default hostname of AP.  So in WCS you can  sort them by name and find your new APs.  Then click on the AP and  change your settings... well, when I do that, WCS throws a message at me  saying that the config change failed because cdp is deactivated  globally on the controller..... which it is.  The entire config failed  via wcs.  no name changes, no primary controllers set, no AP groups  set.  So, I tried it again and the same thing.  So, I went to the  controller itself and tried to enable cdp globally..... it said this  controller doesn't support CDP! 

Well the controller doesn't really need CDP, but I  sure would have liked these new APs to have it, so I went to WCS again  and did everything over again, only this time I turned cdp off.  WCS was  happy and pushed the config to the APs and then CDP was no longer  active on the APs.

I then went to the controller these APs were associated to  and turned cdp back on and everything was fine.  The controller does  say the cdp is turned off globally, but it allowed me to turn CDP back  on.

Then  I primed another batch but this time just used the controller directly  and skipped WCS.  All was well.

Kind of a weird interesting thing.  Not sure  where the issue lies.  It appears that the controller doesn't want to  support CDP on 7.0... at least a WiSM running 7.0.  WCS 7.0 is wanting  the controller to have cdp turned on globally before it pushes a config  to an ap that has cdp turned on, but the controller itself doesn't seem  to care.

What I would like to know is does the Wism really not support CDP and why does WCS throw up at that when the controller is ok with it?

jlhainy Sun, 06/27/2010 - 10:22

Hi zhenningx,

You are absolutely right about the WiSM not supporting CDP.  The issue actually lies in WCS.  When priming APs using WCS 7.0, if you change settings on an AP and one of those settings is leaving CDP enabled or enabling CDP if it was not already, then WCS throws up an error message and says that it can't send the config to the AP because cdp is not enabled globally.  So for example, lets say I am priming an AP using WCS and I change the hostname of the AP, the primary and secondary controller and the AP group. Because CDP is enabled be default on an AP, I just leave that as is.

Well, what happens is that WCS doesn't like the fact that cdp is globally disabled on the controller but it is sending a command to an AP to enable CDP on an AP.  WCS seems to want CDP to be enabled globally if it is going to enable CDP on an AP.  It gives bean error and says that CDP is not enabled globally on the controller.  But it also fails to send any of the other settings as well.  So, my hostname, primary controllers and AP group were never sent to the AP.  So, if I disabled CDP, everything was great, but that is not the outcome I wanted.

Now a work around is to just use the controller directly and the controller is able to make the changes just fine.  6.0 WCS with 6.0 WLC code didn't have this issue, so to me, it appears to be an issue with the new WCS 7.0.

zhenningx Mon, 06/28/2010 - 17:33

I just tested with WCS 7.0 and WISM 7.0. I tried to change AP name using WCS template. Only AP name was changed, did not touch any other settings(CDP was left enabled). I can change the AP name without any errors.

jlhainy Tue, 06/29/2010 - 08:24

ok, go to WCS, then go to configure>access points> and try to change a name of an AP, primary and secondary controllers and the AP group and see what happens.

zhenningx Tue, 06/29/2010 - 08:29

I did change AP name under configure>access points> and that worked. Can you try just to change AP name (not so many settings at same time) to see if that works? So we can figure out which setting is causing problem exactly.

jlhainy Tue, 06/29/2010 - 08:37

Tried that.  The only one I am having issues with is enabling CDP on the AP itself.  I can do it on the controller, but

not wcs.  This is what I am seeing on WCS.

Attachment: 
zhenningx Tue, 06/29/2010 - 08:57

Still cannot reproduce this on my WCS. I went to configure>access points> (CDP is currently enabled), I unchecked CDP and clicked Save, no errors. I verified CDP is disabled for this AP on WLC now. Then I checked CDP on WCS and clicked Save, still no errors and CDP became enabled for this AP on WLC. Sorry cannot help for more than that.

jlhainy Mon, 08/23/2010 - 05:46

Glad to see that some one else is having the issue.  Other than using the controller, have you found any work arounds?  We know its an issue with the WLC 7.0.98.0 code and WCS 7.0.164 code.

What controller model are you running your code on?  I am running on WiSM Blades for the 6500.

jlhainy Tue, 10/26/2010 - 09:40

So, might this be an issue with the WiSM's specifically?

Actions

This Discussion

 

 

Trending Topics - Security & Network