Newbie Question : INTERNET->Router1->Router2 ?

Answered Question
Jun 25th, 2010

Hello,

I am learning and reading the CCNA / CCENT books , just to understand how it works. (It is only the second week I have the routers to play with)

At the moment I was able to connect Router1 via F0/0 to my ISP and F0/1 to my computer via DHCP , and it works I have INTERNET on the computer connected on F0/1.

The next step I would like to archive is to connect my second router to one of the S0/0 S0/1 busses and connect the computer to F0/0 of this router.

I can ping the S0/0 and F0/0 and even the computer that is connected on the first router , but nothing from the internet (even 8.8.8.8 GOOGLE DNS done not work)

NOTE:

ROUTER 1 = 2621XM + WIC2T (DTE)

ROUTER 2 = 2610XM + WIC1T (DCE)

Here bellow what I did on Router1 :

! Last configuration change at 23:14:38 pdt Fri Jun 25 2010

! NVRAM config last updated at 23:03:28 pdt Fri Jun 25 2010

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

clock timezone GMT 1

clock summer-time pdt recurring

no network-clock-participate slot 1

no network-clock-participate wic 0

no ip source-route

ip cef

!

!

no ip dhcp use vrf connected

no ip dhcp conflict logging

ip dhcp excluded-address 10.0.100.1 10.0.100.99

!

ip dhcp pool internal

   network 10.0.100.0 255.255.255.0

   default-router 10.0.100.1

   dns-server 192.168.1.250 8.8.8.8

   netbios-name-server 10.0.100.2 10.0.100.3

   lease 5

!

!

no ip bootp server

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

interface FastEthernet0/0

description DMZ

ip address dhcp

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

no ip mroute-cache

duplex auto

speed auto

no cdp enable

!

interface Serial0/0

no ip address

no ip mroute-cache

no cdp enable

!

interface FastEthernet0/1

description INTERNAL

ip address 10.0.100.1 255.255.255.0

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no ip mroute-cache

duplex auto

speed auto

no cdp enable

!

interface Serial0/1

ip address 172.16.0.1 255.255.255.0

encapsulation ppp

!

interface Serial0/2

no ip address

shutdown

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

ip nat inside source list 1 interface FastEthernet0/0 overload

ip nat inside source list 2 interface FastEthernet0/0 overload

!

access-list 1 permit 10.0.100.0 0.0.0.255

access-list 2 permit 172.16.0.0 0.0.0.255

!

control-plane

!

no call rsvp-sync

!

mgcp behavior g729-variants static-pt

!

gatekeeper

shutdown

!

line con 0

speed 115200

line aux 0

line vty 0 4

login

!

ntp clock-period 17179930

ntp server 66.27.60.10

!

end

On Router2 , I have this :

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

interface FastEthernet0/0

ip address dhcp

no ip unreachables

no ip proxy-arp

ip nat outside

duplex auto

speed auto

!

interface Serial0/0

ip address 172.16.0.2 255.255.255.0

encapsulation ppp

clock rate 64000

!

interface Serial0/1

no ip address

shutdown

!

interface Serial0/2

no ip address

shutdown

!

ip forward-protocol nd

ip route 10.0.100.0 255.255.255.0 172.16.0.1

!

no ip http server

no ip http secure-server

control-plane

!

line con 0

speed 115200

line aux 0

line vty 0 4

login

!

end

Correct Answer by Reza Sharifi about 6 years 8 months ago

Hi Didier,

You have a static route on router 2 (ip route 10.0.100.0 255.255.255.0 172.16.0.1)

this static route will give you readability to subnet 10.0.100,0/24 only

so in order to have readability to the world you need to change your static route to a default route as follows:

ip route 0.0.0.0 0.0.0.0 172.16.0.1

then test again

HTH

Reza

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Reza Sharifi Fri, 06/25/2010 - 15:20

Hi Didier,

You have a static route on router 2 (ip route 10.0.100.0 255.255.255.0 172.16.0.1)

this static route will give you readability to subnet 10.0.100,0/24 only

so in order to have readability to the world you need to change your static route to a default route as follows:

ip route 0.0.0.0 0.0.0.0 172.16.0.1

then test again

HTH

Reza

Actions

This Discussion