Publisher and Subscriber replication through WAN

Unanswered Question
Jun 26th, 2010

Hi,

I have 2 sites [HQ and branch] and was having publisher and subscriber and my branch and HQ users register via WAN,then I mover the publisher to the HQ as per customer request,I asked for a maximum delay through WAN 80-msec

After the move the replication is affected [the delay average is a bout 130 msec] , and I found its status on CLI on the publisher is 3 and subscriber is 0

trying [utils dbreplication stop on sub then pub then utils dbreplication reset all on pub] with no effect

Then resetting both servers have no effect

The final status is that publisher stuck in  3 and subscriber told 2 for the dbreplication

When I check it from RTMT, the publisher told 3 and the publisher raw is empty and the RTMT told that the subscriber node is unreachable and there is a dbreplication errors in the logs

So I need to ask about 2-things:

1. When the HQ users registered to publisher, a lot of problems occur for call routing that they can call mobile but not land line and like that

But when they register to subscriber,all is working fine, so why this happen

2. Also how to let HQ users work find with publisher and branch users work fine with the subscriber without the effect of replication on both of them,I expect the replication affect only when both sites need to talk to each other ?

I can't make 2-publisher at both sites that I need the redundancy to be exist

Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
JustForVoice_2 Sat, 06/26/2010 - 05:50

Hi,

I think the solution for you to increase the bandwidth or to make it two cluster.

I faced some problem in one project. it was DB replication issues and both CCMs in the same site. some phones can make calls and others no.

You can not control the DB for each server. you can not know the content of publisher DB or Sub DB. So, even if you forced the phones HQ to register with one your servers, you can not control the DB for this server.

David Hailey Sat, 06/26/2010 - 14:22

Your issue is latency.  You are WAY outside of the required/supported amount of latency (and likely bandwidth if I were to guess) for clustering CUCM over the WAN.  To be frank, database replication is an issue - period.  It's not something where it only comes into play if the two servers need to talk to each other.  The Publisher is the database.  If it cannot replicate the database to the Subscriber, then there is a cluster-wide issue that needs to be resolved.  It may seem that there are intermittent issues but that's part of what you see when you have replication problems.

You need to bring your network into specifications for clustering over the WAN.  If you can't do that, you should reconsider your deployment and how to best serve each location given the bandwidth, latency, and other limitations you may be facing.

Hailey

sjafri786 Fri, 11/12/2010 - 06:21

Does anyone know what is the maximum latency in terms of Cisco's best practice between Publisher and Subscriber, if we need to deploy on WAN?

Actions

This Discussion