Redistribution issues between OSPF and RIP

Unanswered Question
Jun 27th, 2010
User Badges:

Please look into scenario which stopping for selecting best path from OSPF over RIP.

There are 4 routers R1, R2, R3 and R4 connected in full mesh ethernet. Connectivity between R1, R2 and R3 is on OSPF Process 1 and area 0. However Connectivity between R4 and R1 is on RIP V2. The following are IP and configurations snapshots of routers.

IP Details

R1->R2: 10.1.1.0/30

R2->R3: 10.1.2.0/30

R3->R4: 10.1.3.0/30

R4->R1: 10.50.1.0/30

Configurations

R1

interface loopback0

ip address 1.1.1.1 255.255.255.255

!

interface gig 0/0

description connected to R2

ip address 10.1.1.1 255.255.255.252

!

interface gig 0/1

description connected to R4

ip address 10.50.1.2 255.255.255.252

!

router ospf 1

passive-interface default

no passive-interface gig 0/0

redistribute rip metric 400 subnets

network 10.1.1.0 0.0.0.3 area 0

network 1.1.1.1 0.0.0.0 area 0         

!

router rip

version 2

passive-interface default

no passive-interface gig 0/1

redistribute ospf 1 metric 15

network 10.0.0.0

no auto-summary

R2

Interface loopback0

ip address 2.2.2.2 255.255.255.255

!

Interface gig 0/0

description connected to R1

ip address 10.1.1.2 255.255.255.252

!

interface gig 0/1

description connected to R3

ip address 10.1.2.1 255.255.255.252

!

router ospf 1

passive-interface default

network 10.1.1.0 0.0.0.3 area 0

network 10.1.2.0 0.0.0.3 area 0

network 2.2.2.2 0.0.0.0 area 0           

!

R3

interface loopback0

ip address 3.3.3.3 255.255.255.255

!

interface gig 0/0

description connected to R2

ip address 10.1.2.2 255.255.255.252

!

interface gig 0/1

description connected to R4

ip address 10.1.3.1 255.255.255.252

!

router ospf 1

passive-interface default

network 10.1.2.0 0.0.0.3 area 0

network 10.1.3.0 0.0.0.3 area 0

network 3.3.3.3 0.0.0.0 area 0           

!

R4

interface loopback0

ip address 4.4.4.4 255.255.255.255

!

interface gig 0/0

description connected to R3

ip address 10.1.3.2 255.255.255.252

!

interface gig 0/1

description connected to R1

ip address 10.50.1.1 255.255.255.252

!

router ospf 1

passive-interface default

no passive-interface gig 0/0

redistribute rip metric 400 subnets

network 10.1.3.0 0.0.0.3 area 0

network 4.4.4.4 0.0.0.0 area 0         

!

router rip

version 2

passive-interface default

no passive-interface gig 0/1

redistribute ospf 1 metric 15

network 10.0.0.0

no auto-summary

!

All routes from R2, R3 and R4 appear as an OSPF route on R1. Routes get shifted to RIP once R1 gig 0/0 interface goes down. However routes are not reverted to OSPF once gig 0/0 interface comes up (OSPF instance resorted). I have to manually shutdown gig 0/1 interface and OSPF routes appear immediately in R1 routing table. Why routes switching are not automatically happening from RIP to OSPF? Does any configuration change require?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
shivlu jain Sun, 06/27/2010 - 05:37
User Badges:
  • Silver, 250 points or more

Hi


I need to test the scenario. But what I can visualize is that the problem is occuring because of mutual redistribution.What is happening int he topology is that all the routes coming from ospf are going to rip and then rip is redistributong those routes to OSPF with metric 15. Because of this problem is happening. The best way is to do these type of scenarios is to use tags. You can define tags on the basic of protocol and deny those routes.

I will test it today and post my results.


regards

Shivlu Jain

http://www.mpslvpn.info     

In this scenario, there are multiple points of unrestricted redistribution (R1 and R4) between the RIP and OSPF domain, which is a recipe for routing loops.


Here, R1 and R4 will learn routes from the RIP domain, redistribute them into OSPF and so the RIP routes are preferred in the OSPF domain because of its lower  administrative distance (OSPF=110 , RIP=120). In the opposite direction it works fine.


Besides the solution already mentioned, another way of resolving this is to raise the administrative distance of OSPF external routes to be above the default RIP distance.


On R1 and R4:


router ospf

distance ospf external 121

end


HTH

Marcel

shivlu jain Mon, 06/28/2010 - 01:23
User Badges:
  • Silver, 250 points or more

One problem also I could see with the configs of R2 and R3, where in you are using passive interface default which means no neighborship will be formed with OSPF. Please correct it.


regards

Shivlu Jain

http://www.mplsvpn.info

shivlu jain Mon, 06/28/2010 - 01:40
User Badges:
  • Silver, 250 points or more

I have tested it and it is working fine. Can you check whether you have changed the OSPF reference cost bandwidth.

Given output is attached when I made Fa0/0 --> Yours Gi0/0 shut down and when I made it no shut I am receiving the proper routes with cost of 2,3 and so on


regards

Shivlu Jain

http://www.mplsvpn.info

pankaj_cisco111 Mon, 06/28/2010 - 02:32
User Badges:

Dear Shivlu,


Traffic gets easily shifted to RIP. However once OSPF comes up, RIP routes are still available in routing table. There is no OSPF reference cost bandwidth configured. Should I play with tag during redistribution? It might do the trick.



Regards,

Pankaj

pankaj_cisco111 Mon, 06/28/2010 - 02:17
User Badges:

Passive-interface defualt is actually not configured on R2 and R3 OSPF instance. It typed mistakenly.



Regards,

Pankaj

jimmysands73_2 Mon, 06/28/2010 - 21:43
User Badges:
  • Silver, 250 points or more

You can also always go to the Cisco Learning Network for with homework questions like this 

Actions

This Discussion