INTERNET->ROUTER1->ROUTER2 Broken line simulation ?

Answered Question
Jun 27th, 2010

Hello,

I have 2 routers connected BACK 2 BACK.

One of them is connected to my ISP and via 2 serial line I connect it to the second router :

                                   WIC2T S0/1-----------WIC2T S0/1

ISP->ROUTER 1 <                                                           > ROUTER 2 -> PC

                                   WIC2T S0/2-----------WIC1T S0/0

When I connect the first serial cable to both routers , I have internet.

When I connect the second serial cable to both routers , I have still internet.

BUT , If I remove the first serial cable I do not have internet anylonger.

The only way to make it work again is to give the next command on ROUTER 2 :

NO ip nat inside source list 1 interface Serial0/0 overload

Can I give some time out before it switch from :

ip nat inside source list 1 interface Serial0/0 overload  to ip nat inside source list 1 interface Serial0/1 overload

Or even better can I use both at the same time to increase the bandwith ?

Form my ISP , I receive 21Mbps

When I am connected to the second router via the serial cable I have only 7Mbps

If I can combine both serial cables , it will be fine to have 14Mbps

To give you a better overview bellow you will see the scrit of both routers :

ROUTER 1:

Current configuration : 2333 bytes
!
! Last configuration change at 14:03:48 pdt Sun Jun 27 2010
! NVRAM config last updated at 13:09:15 pdt Sun Jun 27 2010
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
clock timezone GMT 1
clock summer-time pdt recurring
no network-clock-participate slot 1
no network-clock-participate wic 0
no ip source-route

ip cef
!
no ip dhcp use vrf connected
no ip dhcp conflict logging
ip dhcp excluded-address 10.0.100.1 10.0.100.99
!
ip dhcp pool internal
   network 10.0.100.0 255.255.255.0
   default-router 10.0.100.1
   dns-server 192.168.1.250 8.8.8.8
   netbios-name-server 10.0.100.2 10.0.100.3
   lease 5
!
no ip bootp server
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3

interface FastEthernet0/0
description DMZ
ip address dhcp
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!
interface Serial0/0
no ip address
no ip mroute-cache
no cdp enable
!
interface FastEthernet0/1
description INTERNAL
ip address 10.0.100.1 255.255.255.0
no ip proxy-arp
ip nat inside
ip virtual-reassembly
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!
interface Serial0/1
ip address 172.16.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
encapsulation ppp
clock rate 8000000
!
interface Serial0/2
ip address 172.16.0.3 255.255.255.0
ip nat inside

ip virtual-reassembly
encapsulation ppp
!
ip forward-protocol nd
ip route 192.168.66.0 255.255.255.0 172.16.0.2
ip route 192.168.66.0 255.255.255.0 172.16.0.4
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
ip nat inside source list 2 interface FastEthernet0/0 overload
!
access-list 1 permit 10.0.100.0 0.0.0.255
access-list 1 permit 172.16.0.0 0.0.0.255
access-list 2 permit 10.0.100.0 0.0.0.255
access-list 2 permit 172.16.0.0 0.0.0.255
!
control-plane
!
no call rsvp-sync
!
mgcp behavior g729-variants static-pt
!
gatekeeper
shutdown

line con 0
speed 115200
line aux 0
line vty 0 4
login
!
ntp clock-period 17180029
ntp server 66.27.60.10
!
end


ROUTER 2 :


Current configuration : 1462 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.66.1 192.168.66.99

!
ip dhcp pool Didier
   network 192.168.66.0 255.255.255.0
   default-router 192.168.66.1
   dns-server 192.168.1.250 8.8.8.8
   netbios-name-server 192.168.66.2
   lease 5
!
interface FastEthernet0/0
description INTERNAL
ip address 192.168.66.1 255.255.255.0
no ip unreachables
no ip proxy-arp
ip nat inside
duplex auto
speed auto
!
interface Serial0/0
description INTERNET via S0/0
ip address 172.16.0.4 255.255.255.0
ip nat outside
encapsulation ppp
clock rate 8000000
!
interface Serial0/1
description INTERNET via S0/1

ip address 172.16.0.2 255.255.255.0
ip nat outside
encapsulation ppp
!
interface Serial0/2
no ip address
shutdown
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.0.1
ip route 0.0.0.0 0.0.0.0 172.16.0.3
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface Serial0/0 overload
ip nat inside source list 2 interface Serial0/1 overload
!
access-list 1 permit 192.168.66.0 0.0.0.255
access-list 2 permit 192.168.66.0 0.0.0.255
!
control-plane
!
line con 0
speed 115200
line aux 0
line vty 0 4
login
!
end

Best Regards,

Didier.

I have this problem too.
0 votes
Correct Answer by Edison Ortiz about 6 years 5 months ago

Not only 2600 is slow but is End of Life.

As for the NAT query, in a nutshell, modify the timeout values - please refer to the documentation:

http://www.cisco.com/en/US/docs/ios/ipaddr/command/reference/iad_nat.html#wp1013201

Regards,

Edison

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Loading.
Edison Ortiz Sun, 06/27/2010 - 06:36

Didier,

I'm not sure how you are able to achieve 7Mbps via a serial connection where the hardware specs indicates that a serial will provide up to 1.5Mbps (T1 speed) or 2Mbps (E1 speed) on your router.

If you want to achieve greater speeds, you need to use another media such as Ethernet as there is a serialization delay when going from Ethernet-to-Serial hence the lost on speed. The router itself also has its limitation, what kind hardware do you have?

As for the NAT issue, this is working as expected. The current NAT table on the router is translating for S0/0. If S0/0's IP address isn't routable via S0/1, then packets will be dropped. You can clear the NAT table without removing the NAT command and it should work. You can also modify your configuration with aggresive NAT timers.

Regards,

Edison

Didier1966 Sun, 06/27/2010 - 06:54

Hello,

Thank you for replying on a Sunday

Sorry for this kind of newbie questions but is only 3 week's that I play with this CISCO ROUTERS and SWITCHES.

The HW I use is :

ROUTER 1 (the one connected to the ISP) = CISCO 2621XM IOS12.4 + WIC 1T(W0) + WIC 2T(W1)

ROUTER 2 CISCO 2610XM IOS12.4 + WIC1DSUT1(W0) + WIC2T(W1)

In the CISCO WIC-2T SPEC. the give a MAX SPEED of 8Mbps.

This is what I get when I do I speed test from the second router :

This is what I get on the first router :

Please be aware that the serial link is at CLOCK RATE = 8000000.

Best Regards,

Didier.

Didier1966 Tue, 06/29/2010 - 23:31

Hello ,

Thank you for this usefull information , I did not know my 2600 was so slow

When you have the time can you be more explicit on the AGGRESIVE NAT , or a solution how I can reconnect in a short time ?

"If S0/0's IP address isn't routable via S0/1, then packets will be dropped. You can clear the NAT table without removing the NAT command and it should work. You can also modify your configuration with aggresive NAT timers."

Best Regards,

Didier

Didier1966 Wed, 06/30/2010 - 11:54

Hi Edison,

Thank you for this very good information , it works

The reason why I have this museum routers , is due to that I would like to do a CCENT or higher.

I hope this will be usefull for my training.

Best Regards,

Didier.

Actions

This Discussion