h-reap bad windows filesharing performance

Unanswered Question
Jun 27th, 2010

Hi,

I'm experiencing a very odd issue here. I'm running the following setup:

1x WLC 2106 running version 7.0.98.0.

2x 1131AG in local mode

1x 1131AG in h-reap mode with local switching.

Everything is working as it should except Windows File Sharing transfers on the h-reap AP. If a laptop is connected to the h-reap AP and it is transfering a file using WFS/SMB it performs really bad 0-400 KBps, it fluctuates up and down constrantly, but if I use FTP it works flawlessly (2,5 MBps constantly). I've tried two different sources, Win2k3 server with SMB + FTP and a Synology NAS with SMB + FTP. Every time I use SMB the performance is bad. When I connect the laptop using UTP it works like a charm. Even HTTP test 100MB.bin from the Internet is going with 2,5MBps constantly. I've tried several different laptops and OS's.

SMB works fine on the local mode AP's.

Laptop / SourceSMB on Local APSMB on H-Reap APHTTP on H-Reap APFTP on H-Reap AP
MacBook Pro/with Vista 2,5 MBps0 - 400 KBps2,5 MBps2,5 MBps
Dell Inspirion/with Windows 72,5 MBps0 - 400 KBps2,5 MBps2,5 MBps

Tried both the A and G frequencies, no difference.

Anyone any clues on why this might happen???

Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
2044418Puts Sun, 06/27/2010 - 09:04

Just looking through the release notes and I found this open caveat:

CSCth02374

HREAP central switching TCP performance is better than local switching.

Is it possible that I face this bug with this issue?

When I look this bug up in the Bug Tool I see that this bug description is still only available to Cisco TAC. Is anyone able to look into this and post / verify this info?

Thanks!

2044418Puts Fri, 08/13/2010 - 10:22

Okay I just upgraded/downgraded from 7.0.98 to 6.0.199 and now it works fine. Seems to be a bug of version 7.0.98.0

Actions

This Discussion

Related Content