CIPC not recieving tftp settings?

Unanswered Question
Jun 27th, 2010

                    Hello All,

                                 I am using SSL VPN to connect to my office network but, when I start up the CIPC software it does not recieve the default tftp setting from the Call Manager Express. I keep getting a message that says unable to reach tftp server. I setup option 150 for the IP Address of the CME Router on the voice VLan. On the Data VLAN I setup DHCP option 150 have the exact same IP Address for in the Voice VLAN. My data Vlan is a and my voice VLAN it a 172.16.X.X. What do I need to do to get the tftp setings to be pushed to my CIPC so I do not have to manual input the setting on every machine manually for every user?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Md. Mijanur Rahman Sun, 06/27/2010 - 23:52

Hi, the method you are trying is applicable for hard-phones only. The Cisco IP Phones search the DHCP IP on the voice-vlan configured on it's switchport, CIPC doesn't, so behaviour of Cisco IP Phone and CIPC is not the same at network perspective. Cisco IP Phone marks and classifies the RTP and Call Control Signaling traffic to get high priority whereas the data traffic from attached PC to less priority, CIPC traffic is also left to less priority as it's considered as data traffic. The point I'm trying to explain is, you can't expect the same behaviour from CIPC as always you get from Cisco IP Phones.

If you wish to put the default TFTP Server you have to work with Windows Registry Settings. Navigate to 'HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\Communicator' and set the TFTPServer1 and TFTPServer2 in hexa format , example: 3284ea0a for


Please rate helpful posts!


This Discussion