Cisco AP 1252AG Cannot setup More than 54Mb/s speed in radio 0 (2.4G)

Answered Question
Jun 27th, 2010
User Badges:

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:SimSun; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

I have a problem when I configure CISCO AP 1252, it cannot support more than 54Mb/s speed but support 802.n which speed can up to 300Mb/s. See below :


here is dot11radio 0 speed option: (The MAX speed is 54Mb/s by manually, how can i setup more than 54Mb/s, because of this AP support 802.n. So the speed should be more than 54M/s, like 300M)



AP#sho inter dot11Radio 0
Dot11Radio0 is up, line protocol is up
   Hardware is 802.11N 2.4Ghz Radio, address is *************
   MTU 1500 bytes, BW 54000 Kbit, DLY 1000 usec,
--------------------------------------
AP(config)#inter dot11Radio 0
AP(config-if)#speed ?
   1.0         Allow 1.0 Mb/s rate
   11.0        Allow 11.0 Mb/s rate
   12.0        Allow 12.0 Mb/s rate
   18.0        Allow 18.0 Mb/s rate
   2.0         Allow 2.0 Mb/s rate
   24.0        Allow 24.0 Mb/s rate
   36.0        Allow 36.0 Mb/s rate
   48.0        Allow 48.0 Mb/s rate
   5.5         Allow 5.5 Mb/s rate
   54.0        Allow 54.0 Mb/s rate

***(why here without more than 54M/s rate, CISCO AP 1252 support IEEE802/n)
   6.0         Allow 6.0 Mb/s rate
   9.0         Allow 9.0 Mb/s rate
   basic-1.0   Require 1.0 Mb/s rate
   basic-11.0  Require 11.0 Mb/s rate
   basic-12.0  Require 12.0 Mb/s rate
   basic-18.0  Require 18.0 Mb/s rate
   basic-2.0   Require 2.0 Mb/s rate
   basic-24.0  Require 24.0 Mb/s rate
   basic-36.0  Require 36.0 Mb/s rate
   basic-48.0  Require 48.0 Mb/s rate
   basic-5.5   Require 5.5 Mb/s rate
   basic-54.0  Require 54.0 Mb/s rate

***(why here without over than 54Mb/s Rate?, it support IEEE802.n)
   basic-6.0   Require 6.0 Mb/s rate
   basic-9.0   Require 9.0 Mb/s rate
   default     Set default rates
   m0-7        Allow MCS rate indices 0-7
   m0.         Allow MCS rate index 0
   m1.         Allow MCS rate index 1
   m10.        Allow MCS rate index 10
   m11.        Allow MCS rate index 11
   m12.        Allow MCS rate index 12
   m13.        Allow MCS rate index 13
   m14.        Allow MCS rate index 14
   m15.        Allow MCS rate index 15
   m2.         Allow MCS rate index 2
   m3.         Allow MCS rate index 3
   m4.         Allow MCS rate index 4
   m5.         Allow MCS rate index 5
   m6.         Allow MCS rate index 6
   m7.         Allow MCS rate index 7
   m8-15       Allow MCS rate indices 8-15
   m8.         Allow MCS rate index 8
   m9.         Allow MCS rate index 9
   ofdm        How to place OFDM rates in rates elements
   only-ofdm   Set rates for best OFDM throughput (no ERP protection will be used)
   range       Set rates for best range
   throughput  Set rates for best throughput (includes non-OFDM rates and may cause ERP


Why this device cannot support  300Mb/s rate in radio 0 of speed ?


i want to setup more than 54 Mb/s when i use my laptop to connect this AP.


Correct Answer by Surendra BG about 6 years 11 months ago
To achieve N rates on the 1252, you need to ensure a few settings

1. For encryption only completely open or wpa2/aes will work.
2. On the WLAN, WMM needs to be allowed.
3. antennas are recommended.
4. MCS rates upto 15 should be enabled.
5. Channel bonding can be enabled ( not recommended on the 2.4 GHz channel)


Correct Answer by Surendra BG about 6 years 11 months ago

Hi,


i request you to remove any onr ciphers AES command, that is either with the vlan if we are not using any vlan or without vlan if we are using.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Surendra BG Sun, 06/27/2010 - 23:02
User Badges:
  • Cisco Employee,

Hi,


802.11N speeds are supported only if we are using CIPHERS AES as the encryption.


Go to the encryption manager and change the encryption to AES, enable all the MCS radio settings. This will resolve the issue.


Regards

Surendra

Surendra BG Sun, 06/27/2010 - 23:03
User Badges:
  • Cisco Employee,

in the mean time whats the exact product ID of the Access point?

Surendra BG Sun, 06/27/2010 - 23:28
User Badges:
  • Cisco Employee,

Thanks for the response..  does it support N-Radio? Pla send me the screen shot from the radio interfaces

donglei888999 Sun, 06/27/2010 - 23:51
User Badges:

AP1252#sho interfaces dot11Radio 0


Dot11Radio0 is up, line protocol is up


  Hardware is 802.11N 2.4Ghz Radio, address is 68ef.bde1.d450 (bia 68ef.bde1.d45


0)


  MTU 1500 bytes, BW 54000 Kbit, DLY 1000 usec,


     reliability 255/255, txload 1/255, rxload 1/255


  Encapsulation ARPA, loopback not set


  ARP type: ARPA, ARP Timeout 04:00:00


  Last input never, output 00:00:00, output hang never


  Last clearing of "show interface" counters never


  Input queue: 0/1677/0/0 (size/max/drops/flushes); Total output drops: 0


  Queueing strategy: fifo


  Output queue: 0/30 (size/max)


  5 minute input rate 1000 bits/sec, 3 packets/sec


  5 minute output rate 0 bits/sec, 0 packets/sec


     396 packets input, 31667 bytes, 0 no buffer


     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles


     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored


     0 input packets with dribble condition detected


     0 packets output, 0 bytes, 0 underruns


     0 output errors, 0 collisions, 2 interface resets


     0 babbles, 0 late collision, 0 deferred


     0 lost carrier, 0 no carrier


     0 output buffer failures, 0 output buffers swapped out

Surendra BG Mon, 06/28/2010 - 00:12
User Badges:
  • Cisco Employee,

thanks for the response.. we changed the encryption to Ciphers AES right??

donglei888999 Mon, 06/28/2010 - 00:29
User Badges:

Sorry, I don't know the :" encryption to Ciphers AES right " 


I have not change any settings, that's default .

Surendra BG Mon, 06/28/2010 - 00:33
User Badges:
  • Cisco Employee,

From the GUI..


home >> security or serveice >> Encryption manager >> check CIPHERS >> from the drop down >> select AES from the drop down >> Apply.

donglei888999 Mon, 06/28/2010 - 01:58
User Badges:

My company use AAA model. and use TACACS as authentication server when some user connect AP, so if  i Change security method, does it impact use??


how can i setup this in  CLI mode??   after changing this, it will support more than 54Mb/s rate (speed) ??

donglei888999 Mon, 06/28/2010 - 02:30
User Badges:

interface Dot11Radio0
no ip address
no ip route-cache
!
encryption mode ciphers aes-ccm
!
ssid *****
!
channel 2437
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!


***, encryption mode to AES,

donglei888999 Mon, 06/28/2010 - 02:32
User Badges:

AP1252#sho dot11 ass all


Address           : 001d.e032.08b1     Name             : HUANB263


IP Address        : 0.0.0.0            Interface        : Dot11Radio 0


Device            : ccx-client         Software Version : NONE


CCX Version       : 4                  Client MFP       : Off


State             : EAP-Assoc          Parent           : self

SSID              : JABOFF0001

VLAN              : 0

Hops to Infra     : 1                  Association Id   : 1

Clients Associated: 0                  Repeaters associated: 0

Tunnel Address    : 0.0.0.0

Key Mgmt type     : NONE               Encryption       : WEP

Current Rate      : 36.0               Capability       : WMM ShortHdr ShortSlot

Supported Rates   : 1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0   (***, why there have not more than 54 MB/s rate)

Voice Rates       : disabled

Signal Strength   : -41  dBm           Connected for    : 115 seconds

Signal to Noise   : 7   dB            Activity Timeout : 147 seconds

Power-save        : Off                Last Activity    : 115 seconds ago

Apsd DE AC(s)     : NONE


Packets Input     : 3                  Packets Output   : 12

Bytes Input       : 237                Bytes Output     : 1063

Duplicates Rcvd   : 0                  Data Retries     : 40

Decrypt Failed    : 0                  RTS Retries      : 0

MIC Failed        : 0                  MIC Missing      : 0

Packets Redirected: 0                  Redirect Filtered: 0

Session timeout   : 0 seconds

Reauthenticate in : never

Surendra BG Mon, 06/28/2010 - 03:50
User Badges:
  • Cisco Employee,

From the above output.. i can see encryption as WEP?? thats is ...


Encryption        : WEP

Surendra BG Mon, 06/28/2010 - 03:51
User Badges:
  • Cisco Employee,

int dot11 0

encryption vlan # mode ciphers aes

no shut

volvog379 Sat, 11/29/2014 - 03:26
User Badges:

Surendra,

I'm want to bring this Topic to the top again as I face the same issue.
- I set the encryption to AES

- I use WPA

- I enabled all MCS rates

- I do not use any VLANs

 

But still I get only 54Mbit... (I'm pretty sure that yesterday I saw already 144... but I'm not able to restore this behaviour?!?!?!?!)
Any ideas where to search for my mistake?

Many thanks and best regards,
Volker

Sandeep Choudhary Sat, 11/29/2014 - 04:13
User Badges:
  • Purple, 4500 points or more
  • Cisco Designated VIP,

    2017 Wireless

HI Volker,

Paste the config of AP.

 

Regards

volvog379 Sat, 11/29/2014 - 09:13
User Badges:

Hi Sandeep,

looking on the configuration to screenshot for you I saw that there is a warning concerning power supply (I moved the AP and connected it to PoE - knowing, that my Switch supports up to 30W per port persuant to 802.3at).
I assume that this might be the issue...?!
How can I convince the AP to rely on the PoE power supply? (Switch is a TP-Link TL-SG2434P...)

Many thanks for your Support.

Best regards,
Volker
 

abersven Mon, 06/28/2010 - 09:53
User Badges:

The 802.11n HT rates apply only to no encryption  or WPA2/AES encryption. They do not apply to WEP or WPA encryption. If  WEP or TKIP encryption is used, the 1250 series access points and any  802.11n Draft 2.0 clients will not transmit at the HT rates. Legacy  rates (802.11a/b/g) will be used for any clients using WEP or TKIP  encryption.


Ref.: Release Notes



40MHz Operation


If the  throughput you get from a 20-MHz channel isn't enough for your speedy  users, you can flip each 5-GHz 11n radio into a bonded-channel  configuration.

You can configure 40-MHz operation on the 2.4-GHz  radio of the 1250 Series AP, but this isn't recommended or supported.  The primary reason against it is that with a wide channel in a band that  has so little available spectrum (and so much interference), you make a  single AP capable of higher throughput at the expense of performance  for all neighboring access points-certainly not the way enterprise WLANs  ought to be designed. Also, the vast majority of client chipsets  (Intel's, for one) will not support 40-MHz operation in the 2.4-GHz  space.


Ref.: Cisco  802.11n Design and Deployment Guidelines



Making the Most of Things


Once you're  connected at 802.11n HT rates, you'll want to make sure you don't lose  the throughput gains you should be able to achieve. Not all may be  within your control, but if you understand the performance implications  of these variables, it will help you in baselining your WLAN  capabilities.

When your  laptops are unplugged, the 11n client will likely try aggressively to  save battery power. Depending on client radio and chipset, it's not  uncommon to see performance drop by as much as 50 percent. Unless you  know how to fully disable this, keep your laptops plugged in if you want  maximum performance,

Note: Even if you managed to disable this power save function, most laptop  motherboards/chipsets have automated power-saving features that kick in  when the laptop is unplugged. At best, these are difficult to disable.  Thus, it is strongly recommended that you not do performance testing  when clients are battery operated.


As detailed  previously, throughput performance may vary as legacy devices are  introduced into the 802.11n environment. This is to be expected, but  make sure that you find a channel void of all legacy transmissions if  you want to test the high-water mark of your new 11n WLAN. If that isn't  possible, adjust your expectations accordingly.



Regards,

André

donglei888999 Mon, 06/28/2010 - 18:12
User Badges:

I have already changed the encryption to AEC, see pic 1,


but the client assocication interface encryption is still WEP,  (reboot again) why?


Attachment: 
Correct Answer
Surendra BG Mon, 06/28/2010 - 18:20
User Badges:
  • Cisco Employee,

Hi,


i request you to remove any onr ciphers AES command, that is either with the vlan if we are not using any vlan or without vlan if we are using.

donglei888999 Mon, 06/28/2010 - 18:28
User Badges:

Encryption is  OFF, but Support Rates is still just 54.0. cannot more than it.?


------------------------------------------

VLAN              : 0
Hops to Infra     : 1                  Association Id   : 1
Clients Associated: 0                  Repeaters associated: 0
Tunnel Address    : 0.0.0.0
Key Mgmt type     : NONE               Encryption       : Off
Current Rate      : 54.0               Capability       : WMM ShortHdr ShortSlot
Supported Rates   : 1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
Voice Rates       : disabled

Signal Strength   : -44  dBm           Connected for    : 2 seconds
Signal to Noise   : 26  dB            Activity Timeout : 20 seconds
Power-save        : Off                Last Activity    : 0 seconds ago
Apsd DE AC(s)     : NONE


Packets Input     : 7                  Packets Output   : 2
Bytes Input       : 893                Bytes Output     : 228
Duplicates Rcvd   : 0                  Data Retries     : 1
Decrypt Failed    : 0                  RTS Retries      : 0

Correct Answer
Surendra BG Mon, 06/28/2010 - 18:38
User Badges:
  • Cisco Employee,
To achieve N rates on the 1252, you need to ensure a few settings

1. For encryption only completely open or wpa2/aes will work.
2. On the WLAN, WMM needs to be allowed.
3. antennas are recommended.
4. MCS rates upto 15 should be enabled.
5. Channel bonding can be enabled ( not recommended on the 2.4 GHz channel)


donglei888999 Mon, 06/28/2010 - 18:38
User Badges:

I guess the problem is My computer cannot support this encrption: (pic 3)


and my Local wireless network adapter property is (pic 4), we use Domain Account login computer, and use Windows Username and password as authentication to connect to AP.

Attachment: 
Surendra BG Mon, 06/28/2010 - 18:40
User Badges:
  • Cisco Employee,

oh whats the model number of the network adapter??

donglei888999 Mon, 06/28/2010 - 18:55
User Badges:

Still cannot setup more than 54mb/s rate in Radio 0 :


-------------------------------------------------------------------

interface Dot11Radio0
no ip address
no ip route-cache
!     (***, see here is no encryption).
ssid JABOFF0001
!
speed  basic-1.0 basic-2.0 basic-5.5 basic-11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m15
.

channel 2462
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio1
no ip address


-____________________________

Surendra BG Mon, 06/28/2010 - 18:59
User Badges:
  • Cisco Employee,

Hi,


If we are using dot11 0 (G-Radio) or the 802.11A (A-Radio), the maximum speed that we get is 54Mbps, we dont get more than that..

Surendra BG Mon, 06/28/2010 - 19:06
User Badges:
  • Cisco Employee,

Hi,

Do you have the cisco cco id and password? if so u could download it from the website...


donglei888999 Tue, 06/29/2010 - 22:27
User Badges:

  i have no Cisco ID and Password to download it, but i supposed i have got that's why.   when I choose encryption is open or AEC and Use supported 802.11n network adapter and it will support speed to M15. (**maybe this is 802.11n speed rate??).


thanks for Surendra BG great support. appreciate all of you give to me!

Surendra BG Tue, 06/29/2010 - 22:35
User Badges:
  • Cisco Employee,

yes you are right.. if you have the N-supported adapter and  set the encryption for AES and WPA2 authentication then you can get the N-speeds..


Thanks for the compliments.. its was my pleasure assisting you.


I request you to rate the posting if possible.


regards

Surendra

Actions

This Discussion

Related Content

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode