2612 Router and h323 protocol

Unanswered Question
Jun 28th, 2010
User Badges:

Hi I have a 2612 router and am trying to get my IP phones up and working, but i have ran into a issue. For some reason I cannot get the set protocol h.323 command to work. I have tried every IOS 12.3. The one i currently have on is the IP/h323 one.  Does anyone have an idea on how to get this protocol to work. or even make a custom protocol?


*******

Current Version:

Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-IS3X-M), Version 12.3(26), RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by cisco Systems, Inc.
Compiled Mon 17-Mar-08 15:23 by dchih

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

WNrouter uptime is 6 days, 55 minutes
System returned to ROM by power-on
System image file is "flash:2610.bin"

cisco 2612 (MPC860) processor (revision 0x102) with 61440K/4096K bytes of memory
.
Processor board ID JAB04130B5C (864598034)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
1 Token Ring/IEEE 802.5 interface(s)
1 Serial network interface(s)
6 Low-speed serial(sync/async) network interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2142

**** conf

Using 7576 out of 29688 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname WNrouter
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
no logging console
enable secret 5 $1$1/iD$seni/4XyulJzibvGqqSra.
!
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
ip domain name driveprestige.com
!
!
!
!
!
!
!
!
!
!
!
!
username Administrator privilege 15 secret 5 $1$LvF7$pJ1vJvXlIA4emgF0TNWQ61
username bcook privilege 15 password 7 101D5148171211535C
username admin privilege 15 password 7 02240B59091F5F77
!
!
!
class-map match-any SDMTrans-Serial1/3
  match protocol citrix
  match protocol finger
  match protocol notes
  match protocol novadigm
  match protocol pcanywhere
  match protocol secure-telnet
  match protocol sqlnet
  match protocol sqlserver
  match protocol ssh
  match protocol telnet
  match protocol xwindows
class-map match-any SDM-Transactional-2
  match  dscp af21
  match  dscp af22
  match  dscp af23
  match protocol citrix
  match protocol finger
  match protocol notes
  match protocol novadigm
  match protocol pcanywhere
  match protocol secure-telnet
  match protocol sqlnet
  match protocol sqlserver
  match protocol ssh
  match protocol telnet
  match protocol xwindows
class-map match-any SDM-Transactional-1
  match  dscp af21
  match  dscp af22
  match  dscp af23
  match protocol citrix
  match protocol finger
  match protocol notes
  match protocol novadigm
  match protocol pcanywhere
  match protocol secure-telnet
  match protocol sqlnet
  match protocol sqlserver
  match protocol ssh
  match protocol telnet
  match protocol xwindows
class-map match-any SDMScave-Ethernet0/0
  match protocol napster
  match protocol fasttrack
  match protocol gnutella
class-map match-any SDMVoice-Serial1/3
  match protocol rtp audio
class-map match-any SDMTrans-Ethernet0/0
  match protocol citrix
  match protocol finger
  match protocol notes
  match protocol novadigm
  match protocol pcanywhere
  match protocol secure-telnet
  match protocol sqlnet
  match protocol sqlserver
  match protocol ssh
  match protocol telnet
  match protocol xwindows
class-map match-any SDM-Routing-2
  match  dscp cs6
  match protocol bgp
  match protocol egp
  match protocol eigrp
  match protocol rip
  match protocol rsvp
class-map match-any SDM-Signaling-1
  match  dscp cs3
  match  dscp af31
class-map match-any SDM-Signaling-2
  match  dscp cs3
  match  dscp af31
class-map match-any SDM-Routing-1
  match  dscp cs6
  match protocol bgp
  match protocol egp
  match protocol eigrp
  match protocol rip
  match protocol rsvp
class-map match-any SDMScave-Serial1/3
  match protocol napster
  match protocol fasttrack
  match protocol gnutella
class-map match-any SDM-Voice-1
  match  dscp ef
  match protocol rtp audio
class-map match-any SDM-Voice-2
  match  dscp ef
  match protocol rtp audio
class-map match-any SDMVoice-Ethernet0/0
  match protocol rtp audio
class-map match-any SDMSignal-Serial1/3
class-map match-any SDMRout-Serial1/3
  match protocol bgp
  match protocol egp
  match protocol eigrp
  match protocol rip
  match protocol rsvp
class-map match-any SDMManage-Ethernet0/0
  match protocol dhcp
  match protocol dns
  match protocol imap
  match protocol kerberos
  match protocol ldap
  match protocol secure-imap
  match protocol secure-ldap
  match protocol snmp
  match protocol socks
  match protocol syslog
class-map match-any SDMBulk-Serial1/3
  match protocol exchange
  match protocol ftp
  match protocol irc
  match protocol nntp
  match protocol pop3
  match protocol printer
  match protocol secure-ftp
  match protocol secure-irc
  match protocol secure-nntp
  match protocol secure-pop3
  match protocol smtp
  match protocol tftp
class-map match-any SDMRout-Ethernet0/0
  match protocol bgp
  match protocol egp
  match protocol eigrp
  match protocol rip
  match protocol rsvp
class-map match-any SDMSignal-Ethernet0/0
class-map match-any SDM-Management-1
  match  dscp cs2
  match protocol dhcp
  match protocol dns
  match protocol imap
  match protocol kerberos
  match protocol ldap
  match protocol secure-imap
  match protocol secure-ldap
  match protocol snmp
  match protocol socks
  match protocol syslog
class-map match-any SDMBulk-Ethernet0/0
  match protocol exchange
  match protocol ftp
  match protocol irc
  match protocol nntp
  match protocol pop3
  match protocol printer
  match protocol secure-ftp
  match protocol secure-irc
  match protocol secure-nntp
  match protocol secure-pop3
  match protocol smtp
  match protocol tftp
class-map match-any SDM-Management-2
  match  dscp cs2
  match protocol dhcp
  match protocol dns
  match protocol imap
  match protocol kerberos
  match protocol ldap
  match protocol secure-imap
  match protocol secure-ldap
  match protocol snmp
  match protocol socks
  match protocol syslog
class-map match-any SDMManage-Serial1/3
  match protocol dhcp
  match protocol dns
  match protocol imap
  match protocol kerberos
  match protocol ldap
  match protocol secure-imap
  match protocol secure-ldap
  match protocol snmp
  match protocol socks
  match protocol syslog
class-map match-any SDMIVideo-Serial1/3
  match protocol rtp video
class-map match-any SDMSVideo-Ethernet0/0
  match protocol cuseeme
  match protocol netshow
  match protocol rtspplayer
  match protocol streamwork
  match protocol vdolive
class-map match-any SDMIVideo-Ethernet0/0
  match protocol rtp video
class-map match-any SDMSVideo-Serial1/3
  match protocol cuseeme
  match protocol netshow
  match protocol rtspplayer
  match protocol streamwork
  match protocol vdolive
!
!
policy-map SDM-Pol-Serial1/3
  class SDMTrans-Serial1/3
   bandwidth remaining percent 33
   set dscp af21
  class SDMSignal-Serial1/3
   bandwidth remaining percent 40
   set dscp cs3
  class SDMVoice-Serial1/3
   priority percent 70
   set dscp ef
  class SDMRout-Serial1/3
   bandwidth remaining percent 3
   set dscp cs6
  class SDMManage-Serial1/3
   bandwidth remaining percent 3
   set dscp cs2
policy-map SDM-QoS-Policy-2
  class class-default
   fair-queue
   random-detect
policy-map SDM-QoS-Policy-1
  class class-default
   fair-queue
   random-detect
policy-map SDM-Pol-Ethernet0/0
  class SDMVoice-Ethernet0/0
   priority percent 70
   set dscp ef
  class SDMRout-Ethernet0/0
   bandwidth remaining percent 3
   set dscp cs6
  class SDMTrans-Ethernet0/0
   bandwidth remaining percent 33
   set dscp af21
  class SDMSignal-Ethernet0/0
   bandwidth remaining percent 40
   set dscp cs3
!
!
!
!
interface Ethernet0/0
description LAN interface
ip address 10.127.236.254 255.255.255.0
ip nbar protocol-discovery
half-duplex
service-policy output SDM-Pol-Ethernet0/0
!
interface Serial0/0
no ip address
shutdown
!
interface TokenRing0/0
no ip address
shutdown
ring-speed 16
!
interface Serial0/1
no ip address
shutdown
!
interface Serial1/3
description <<Pt.to Pt.: To Lexus>>
ip address 1.1.1.34 255.255.255.252
ip nbar protocol-discovery
encapsulation ppp
service-policy output SDM-Pol-Serial1/3
!
ip http server
ip http authentication local
ip classless
ip route 0.0.0.0 0.0.0.0 Serial1/3
ip route 10.127.234.0 255.255.255.0 10.127.234.242

!
!
gatekeeper
shutdown
!
!
line con 0
line aux 0
password 7 022B1149020303711B
line vty 0 4
password 7 02240B59091F5F77
login
!
!
end

WNrouter#

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jerry Ye Mon, 06/28/2010 - 09:56
User Badges:
  • Cisco Employee,

You are running IP/H323 Plus Basic on your 2600 with IOS 12.3, but in 12.4, that feature set doesn't exist. The minimum memory requirement for 12.4 H323 is 32MB flash and 128MB DRAM.


BTW, I don't think you can run 12.4 on the 2600, it only supports 2600XM.


Regards,

jerry

Actions

This Discussion

Related Content