MPLS TE Tunnels not coming up

Answered Question
Jun 28th, 2010

Hi All

I need help bringing up my TE tunnels please ee output below.

PE-1#show mpls traffic-eng tunnels summary
Signalling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Head: 4 interfaces, 0 active signalling attempts, 0 established
          0 activations, 0 deactivations
    Midpoints: 0, Tails: 0
    Periodic reoptimization:        every 3600 seconds, next in 703 seconds
    Periodic auto-bw collection:    disabled


PE-1#show mpls traffic-eng tunnels brief
Signalling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Periodic reoptimization:        every 3600 seconds, next in 747 seconds
    Periodic auto-bw collection:    disabled
TUNNEL NAME                      DESTINATION      UP IF     DOWN IF   STATE/PROT
PE-1_t0                          204.134.83.1     -         unknown   up/down
PE-1_t1                          204.134.83.1     -         unknown   up/down
PE-1_t2                          204.134.83.8     -         unknown   up/down
PE-1_t3                          204.134.83.8     -         unknown   up/down
Displayed 4 (of 4) heads, 0 (of 0) midpoints, 0 (of 0) tails

I have this problem too.
1 vote
Correct Answer by Chetan Kumar Ress about 6 years 5 months ago

Hi Carl

You'll find several cases that might cause the path to be invalid:

Case A - Multiple constraints are placed on the tunnel. Removing some of them brings the tunnel up.

Case B-  One or more constraints on the tunnel, and only when you remove all of them does the tunnel come up.

Case C - There are no paths to the destinations, constrained or unconstrained, and even when you remove all the constraints on the tunnel, it still stays down.

Here is the below config of P1 router that you shared :-

!
interface FastEthernet1/1
description *** CORE P-2 ***
no shut
ip address 204.134.83.17 255.255.255.252
mpls ip
ip rsvp bandwidth 1000
duplex auto
speed auto
!
interface FastEthernet2/0
description *** CORE P-3 ***
mpls ip
no shut
ip rsvp bandwidth 1000
  ip address 204.134.83.21 255.255.255.252
duplex auto
speed auto
!
interface fastethernet1/0
description *** CORE PE-1 ***
  mpls ip
no shut
ip rsvp bandwidth 1000
ip address 204.134.83.14 255.255.255.252
duplex half

Here you can see that you had not configured the command

mpls traffic-eng tunnels

You must configure the below config on every interface that participate the MPLS TE

mpls ip

ip rsvp bandwidth

mpls traffic-eng tunnels

You must config IGP to suport MPLS TE

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

Ensure the connectivity between the tunnel destination also using trace route or use show mpls traffic-eng topology path destination x.x.x.x

Regards

Chetan Kumar

Correct Answer by Chetan Kumar Ress about 6 years 5 months ago

Hi

Accourding to your config PE1 is Headed & PE2 is Tailed router.

But In PE3 i won't see the below config.

router ospf X

mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0

Your Config

router ospf 101
log-adjacency-changes
network 204.134.83.0 0.0.0.255 area 0
network 204.134.84.0 0.0.0.255 area 0

You must enable MPLS TE config under ospf process in all router to make you tunnel working.

Regards

Chetan Kumar

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Chetan Kumar Ress Mon, 06/28/2010 - 09:54

Hi

As per my understanding May be your output is due to insufficient amount of bandwidth on that link & may be having higher priority has preempted the tunnel . 

As you output is also showing  Periodic auto-bw collection:    disabled.

Please confirm the RSVP config in all router with proper path & If Possible please share the config of you tunnel.

Regards

Chetan kumar

Carl Williams Mon, 06/28/2010 - 10:15

Hi Mate

My tunnels are configured from PE1 headend.

Ideally i want two tunnels to each destination one for the primary path and one for the secondary.

Attachment: 
Carl Williams Mon, 06/28/2010 - 10:23

PE 3 config also

for Tunnel 0 = primary path PE1,P1,P3,PE2

for Tunnel 1 = Secondary PE1,P1,P2,P3,PE2

For Tunnel 2 = primary path PE1, P1, P3,PE3

for Tunnel 3 = Secondary path PE1, P1, P2,P3, PE3

ideally this is what i'm trying to create i'm not specifying an explicit path I'm relying on the IGP to take care of that.

Let me know if you can spot anything that might bring the tunnel up.

Attachment: 
Correct Answer
Chetan Kumar Ress Mon, 06/28/2010 - 11:39

Hi

Accourding to your config PE1 is Headed & PE2 is Tailed router.

But In PE3 i won't see the below config.

router ospf X

mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0

Your Config

router ospf 101
log-adjacency-changes
network 204.134.83.0 0.0.0.255 area 0
network 204.134.84.0 0.0.0.255 area 0

You must enable MPLS TE config under ospf process in all router to make you tunnel working.

Regards

Chetan Kumar

Carl Williams Mon, 06/28/2010 - 12:28

Hi Mate

I've made the correction and the below is what i see.

PE-1#show mpls traffic-eng tunnels

Name: PE-1_t0                             (Tunnel0) Destination: 204.134.83.1
  Status:
    Admin: up         Oper: down   Path: not valid   Signalling: Down
    path option 10, type dynamic
    path option 11, type explicit primary

  Config Parameters:
    Bandwidth: 0        kbps (Global)  Priority: 1  1   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 0        bw-based
    auto-bw: disabled

  History:
    Tunnel:
      Time since created: 2 hours, 23 minutes
    Path Option 11:
      Last Error: PCALC:: No addresses to connect 204.134.83.3 to 0.0.0.0

Name: PE-1_t1                             (Tunnel1) Destination: 204.134.83.1
  Status:
    Admin: up         Oper: down   Path: not valid   Signalling: Down
    path option 12, type dynamic

  Config Parameters:
    Bandwidth: 0        kbps (Global)  Priority: 3  3   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 0        bw-based
    auto-bw: disabled

  History:
    Tunnel:
      Time since created: 47 minutes, 36 seconds
    Path Option 12:
      Last Error: PCALC:: No path to destination, 204.134.83.1

Name: PE-1_t2                             (Tunnel2) Destination: 204.134.83.8
  Status:
    Admin: up         Oper: down   Path: not valid   Signalling: Down
    path option 20, type dynamic

  Config Parameters:
    Bandwidth: 0        kbps (Global)  Priority: 1  1   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 0        bw-based
    auto-bw: disabled

  History:
    Tunnel:
      Time since created: 47 minutes, 39 seconds
    Path Option 20:
      Last Error: PCALC:: No path to destination, 204.134.83.8

Name: PE-1_t3                             (Tunnel3) Destination: 204.134.83.8
  Status:
    Admin: up         Oper: down   Path: not valid   Signalling: Down
    path option 21, type dynamic

  Config Parameters:
    Bandwidth: 0        kbps (Global)  Priority: 3  3   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  enabled   LockDown: disabled  Loadshare: 0        bw-based
    auto-bw: disabled

  History:
    Tunnel:
      Time since created: 47 minutes, 38 seconds
    Path Option 21:
      Last Error: PCALC:: No path to destination, 204.134.83.8

Correct Answer
Chetan Kumar Ress Mon, 06/28/2010 - 13:06

Hi Carl

You'll find several cases that might cause the path to be invalid:

Case A - Multiple constraints are placed on the tunnel. Removing some of them brings the tunnel up.

Case B-  One or more constraints on the tunnel, and only when you remove all of them does the tunnel come up.

Case C - There are no paths to the destinations, constrained or unconstrained, and even when you remove all the constraints on the tunnel, it still stays down.

Here is the below config of P1 router that you shared :-

!
interface FastEthernet1/1
description *** CORE P-2 ***
no shut
ip address 204.134.83.17 255.255.255.252
mpls ip
ip rsvp bandwidth 1000
duplex auto
speed auto
!
interface FastEthernet2/0
description *** CORE P-3 ***
mpls ip
no shut
ip rsvp bandwidth 1000
  ip address 204.134.83.21 255.255.255.252
duplex auto
speed auto
!
interface fastethernet1/0
description *** CORE PE-1 ***
  mpls ip
no shut
ip rsvp bandwidth 1000
ip address 204.134.83.14 255.255.255.252
duplex half

Here you can see that you had not configured the command

mpls traffic-eng tunnels

You must configure the below config on every interface that participate the MPLS TE

mpls ip

ip rsvp bandwidth

mpls traffic-eng tunnels

You must config IGP to suport MPLS TE

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

Ensure the connectivity between the tunnel destination also using trace route or use show mpls traffic-eng topology path destination x.x.x.x

Regards

Chetan Kumar

Carl Williams Mon, 06/28/2010 - 13:55

performance between sites does'nt seem to great any ideas.

CE-1#ping 192.168.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
..!..
Success rate is 20 percent (1/5), round-trip min/avg/max = 1964/1964/1964 ms
CE-1#trace
CE-1#traceroute 192.168.2.1

Type escape sequence to abort.
Tracing the route to 192.168.2.1

  1 192.168.3.9 268 msec 116 msec 276 msec
  2 204.134.83.14 [MPLS: Labels 26/32 Exp 0] 1596 msec 2516 msec 2780 msec
  3 204.134.83.18 [MPLS: Labels 29/32 Exp 0] 2640 msec 2020 msec *
  4 204.134.83.26 [MPLS: Labels 26/32 Exp 0] 2792 msec 2300 msec 2592 msec
  5 192.168.3.6 [AS 65000] [MPLS: Label 32 Exp 0] 2288 msec 2300 msec 2636 msec
  6 192.168.3.5 [AS 65000] 2944 msec 2232 msec 2236 msec

Chetan Kumar Ress Mon, 06/28/2010 - 14:15

Hi Carl

Can you check in PE1 & Verify Next-Hop Mapping to Tunnel Interface with the command sh ip router x.x.x.x (Loopback IP)

& use Extended Ping Verification for MPLS TE Tunnel Path.

Regards

Chetan Kumar

Mohamed Sobair Wed, 06/30/2010 - 13:45

Hi,

The latency is very high and there is a packet drops with Normal ping,

you will need to make sure that MPLS MTU is increased on the Core Network. change MPLS MTU value to 1532 on all MPLS enabled interfaces and perform ping again.

Make sure you have sufficent bandwidth reserved by the TE tunnel for this link and see.

HTH

Mohamed

Actions

This Discussion