IP Communicator

Unanswered Question
Jun 28th, 2010
User Badges:

Hi


We have recently aquired  the IP communicator using 7.0.4.0


I have setup on my laptop no problem but tried to setup on my managers laptop. Have done exactly the same as for myself  but his version does not seem to recognise the ext number. I have deleted and reinstalled a couple of times with no luck.


I currently have a Cisco 7912 phone while he has a cisco 7940 ( not sure if that has any effect)

I have alos setup OK on another Cisco 7912


The communicator starts ok but the screen is blank with no ext number showing and no softkey options. We are both running windows XP


Any help greatly appreciated




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aaron Harrison Tue, 06/29/2010 - 00:25
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi Jenny


Basically whatever 'other' physical phones you have isn't really important.


What is important is that:


1) You configure each instance of CIPC in CallManager as you would a physical phone - so add an 'IP Communicator' and assign it the extension it should have.


2) When you install the software on a PC, it automatically grabs the MAC address of the laptop to use as a Device Name. This can be a problem, as the MAC address might change, or might not be the one you expect it to get. The best way to do this (in my opinion at least) is to use a different ID for the CIPC - so you might pick:


- Hostname of the PC it is installed on

- Username of the PC's owner


In CallManager, you would then put 'SEPhostname' or 'SEPusername' in the Device Name field when you configure the CIPC device.


In the CIPC application, go in to Preferences, then the 'Network' tab, and select 'Use this device name' - type in the SEPhostname or SEPusername you configured in CallManager. The CIPC will then register using those details when you hit OK.


Regards


Aaron


Please rate helpful posts...

jonmo2578 Fri, 07/02/2010 - 07:27
User Badges:

Hi, we are having the same issues on our laptops too since upgrading to Windows 7..


If we stick with the default ID ( ie. the MAC address of the laptop ), the softphone will cycle for a while and then come back with Registration Rejected on Call Manager and the softphone.


I have also tried removing the existing database entry for the device ID from call manager altogether to force the softphone to auto register again.. The Device ID correctly reappears on Call Manager, however the registration is again rejected..


Yesterday, I tried out your suggestion below before regarding manually creating a new device ID and then pointing the softphone to the custom ID within perferences..


This works sucessfully on a laptop running Win XP.. proving that the profile and tftp settings are correct

However, on the Win 7 computer, the softphone cycles for ages and does not pick up the profile or get as far as rejecting the registration..


I have seen serveral suggestions on the web regarding turning Windows firewall off, which we have done... but this has not fixed it..


Does anyone have any more suggestion please....


Thanks.


Jon.

Actions

This Discussion