how to disable autonegotiation on catalyst 2960

Unanswered Question
Jun 29th, 2010

Hello, everyone

I'm trying to set fixed speed and fixed duplex mode for one port on catalysy2960 switch. According to the manual I should be able to do it with:

speed 100

duplex full

However there doesn't seem to be such commands. I still have some 2950 switches. And these commands are present there. Has anything changed? Are this commands IOS-specific?

Thanks and best regards.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 1 (1 ratings)
Loading.
Ganesh Hariharan Tue, 06/29/2010 - 02:23

Hello, everyone

I'm trying to set fixed speed and fixed duplex mode for one port on catalysy2960 switch. According to the manual I should be able to do it with:

speed 100

duplex full

However there doesn't seem to be such commands. I still have some 2950 switches. And these commands are present there. Has anything changed? Are this commands IOS-specific?

Thanks and best regards.

I dont think it is problem with ios, It should work under interface configuration mode if you want set to manual setting and if you want to disable auto negotiation configure a command no negotiation auto.

Hope to Help !!

Ganesh.H

oscar123 Tue, 06/29/2010 - 02:37

"no negotiation auto" doesn't seem to be available either. I've attached an image with my console session, just in case someone could spot what am I doing wrong.

Attachment: 
Leo Laohoo Tue, 06/29/2010 - 15:37

Are you using the SFP modules?  If so, you can't change the speed and duplex.  Duplex is always set to full and speed depends on your SFP module.  You are not trying to set to 100 your 1Gb SFP modules are you?  If you are then you are using the wrong modules.

Cisco 100BASE-FX SFP Fast Ethernet Interface Converter on Gigabit SFP Ports

http://www.cisco.com/en/US/prod/collateral/modules/ps5455/ps6578/product_data_sheet0900aecd801ba88e_ps5000_Products_Data_Sheet.html

Don't forget to rate useful posts.  Thanks.

Actions

This Discussion

Related Content