Clients connected to AP541N cannot get DHCP address

Unanswered Question
Jun 29th, 2010

New install with 3 AP541N's in a cluster. Two AP's are connected by an ESW-520-8P PoE switch and one on its own power adapter and a 3COM switch.  I have set up a single SSID with WPA-AES encryption. I am connecting with HP 2740P tablets with Intel wireless cards. Clients can see and connect to the AP's but only some can get IP addesses from our Small Business Server 2003 DHCP server.

It's intermittent, some will get an IP and work for a while, while other can't. Then the ones that are working will drop and then none of the devices can get an IP. Then suddenly a few will start to work again. I have solid connectivity everywhere in the building but can't get an IP. Also, strangely, even when assigning a static IP I can not pass traffic, although it says I am connected with "5 bars" of signal strength.

Clients show up under Cluster>Sessions, but sometimes with really high counts of "Signal" and "Error Rate". However, even the clients with a "good" connection cannot get an IP.

Here is what I have tried:

  • Upgrade firmware on all 3 AP's to 1.9.1 (latest)
  • Wiped and reloaded the devices several times
  • Tried no encryption, WEP, WPA, doesn't make a difference
  • Tried everything described in this thread: https://supportforums.cisco.com/message/3078962#3078962 including the registry entry on the DHCP server
  • I have a spare AP that I put into production with the same load, but it didn't seem to make a difference.
  • Broadcast/Multicast limiting set to off
  • Upgraded to latest drivers on tablets; Boosted power on adapter to highest strength; Turned off power saving

I have exhausted all efforts in searching and trying based on my own experience, so any help the community can provide would be appreciated.

Thanks,

Derek

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cindy toy Fri, 07/16/2010 - 23:08

Hi Derek,


Have you considered using our Online Chat Support?


Cisco Online Chat Support provides live, real-time technical support for  Cisco Small Business products through a web chat session with a Small  Business Support Center engineer during local  business hours


Note: Warranty Coverage is one year from the date of purchase.


Regards,

Cindy Toy

Cisco Small Business

Community Manager

Derek Thom Mon, 07/26/2010 - 08:46

Forgot to follow up on this once I had gotten the problem resolved.

Turns out the 8 port ESW switch I was using for PoE to the access points had smart ports enabled by default, and port security was on as well. With the smart ports default configuration set to PC/IP Phone, it would only allow one computer to pull an IP at a time. Setting it to the Wireless Access Point role resolved the issue.

I guess I am used to having all security off by default, so I didn't think to look there.

streaves Wed, 07/28/2010 - 14:59

Thanks, Derek, for sharing your solution. I'm sure it's valuable to others in the Community.

Stephanie Reaves

Small Business Technology Group

I  am good to go with laptops in the domain, but for guest computer I have to set it to static ip to be able to connect to the AP. I just wonder a $50 wireless router can do the job why this $300 equipment can not. Is there anything I am missing. I double check the admin manual, but can not find anywhere says DHCP for clients. It only mentions DHCP in lan setting for itself. Currently I have only one vlan setup with static IP in the network.

can someone help out? Thanks

Actions

This Discussion