Redundancy between two ISP using HSRP - Need Help.

Unanswered Question
Jun 29th, 2010

Dear All Experts,

Please find the topology shown in attached jpg. It also include the configuration.

Now I need to implement redundancy between tweo ISP i.e TATA and Airtel.

Both Link is terminated on two different ISP.

My Questions are:

1. How to configure HSRP or VRRP to select one ISP? - Primary is TATA and Secondary is AIrtel.

2. How to configure so that Both Link is active but Load sharing using HSRP or VRRP.

3. If TATA all 3 link is goes down than Traffic is diverted to Airtel link. But Airltel link is only 4 MBPS . SO I need to pass only selected traffic. How This is possible?

4. ANy Suggation in this config.

Please do the needful. Its very helpful for me.

Congiuration:

TATA link ROuter :

interface GigabitEthernet0/1

description *** Tata MPLS Link ***

bandwidth 30720

ip address 1.1.55.46 255.255.255.252

interface FastEthernet0/1/0

description ***Tata MPLS Link ***

bandwidth 16384

ip address 1.1.5.19 255.255.255.252

interface FastEthernet0/3/0

description ***Tata MPLS Link ***

bandwidth 16384

ip address 1.1.4.18 255.255.255.248interface GigabitEthernet0/0

description ***Local LAN***

ip address 10.0.150.250 255.255.255.0

router bgp 65000

bgp log-neighbor-changes

neighbor 1.1.5.17 remote-as 4000

neighbor 1.1.4.17 remote-as 4000

neighbor 1.1.55.45 remote-as 4000

maximum-paths 3

!

network 10.0.150.0 mask 255.255.255.0

network 10.0.134.0 mask 255.255.255.0

network 10.0.136.0 mask 255.255.255.0

network 10.0.139.0 mask 255.255.255.0

network 10.0.140.0 mask 255.255.255.0

network 10.0.141.0 mask 255.255.255.0

network 10.0.142.0 mask 255.255.255.0

ip route 10.0.134.0 255.255.255.0 10.0.150.100

ip route 10.0.136.0 255.255.255.0 10.0.150.100

ip route 10.0.139.0 255.255.255.0 10.0.150.100

ip route 10.0.140.0 255.255.255.0 10.0.150.100

ip route 10.0.141.0 255.255.255.0 10.0.150.100

ip route 10.0.142.0 255.255.255.0 10.0.150.100

Airtel Link Router:

interface FastEthernet0/0

description ***Local LAN ***

ip address 10.0.150.241 255.255.255.0

interface FastEthernet0/1

description *****Airtel MPLS Link ****

bandwidth 4096

ip address 10.10.10.90 255.255.255.252

router bgp 64000

bgp log-neighbor-changes

neighbor 10.10.10.89 remote-as 9700

network 10.0.150.0 mask 255.255.255.0

network 10.0.134.0 mask 255.255.255.0

network 10.0.136.0 mask 255.255.255.0

network 10.0.139.0 mask 255.255.255.0

network 10.0.140.0 mask 255.255.255.0

network 10.0.141.0 mask 255.255.255.0

network 10.0.142.0 mask 255.255.255.0

ip route 10.0.134.0 255.255.255.0 10.0.150.100

ip route 10.0.136.0 255.255.255.0 10.0.150.100

ip route 10.0.139.0 255.255.255.0 10.0.150.100

ip route 10.0.140.0 255.255.255.0 10.0.150.100

ip route 10.0.141.0 255.255.255.0 10.0.150.100

ip route 10.0.142.0 255.255.255.0 10.0.150.100

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
John Blakley Tue, 06/29/2010 - 12:09

1. How to configure HSRP or VRRP to select one ISP? - Primary is TATA  and Secondary is AIrtel.

With HSRP, you'll use 3 addresses: 2 physical and 1 virtual. Virtual is the gateway that users/devices will use.

On TATA Router inside interface:

standby 100 ip

standby 100 priority 105 <-- this will make this link primary

standby 100 preempt

standby 100 track

On Alrtel router:

standby 100 ip

standby 100 ip preempt

2. How to configure so that Both Link is  active but Load sharing using HSRP or VRRP.

Only with GLBP for load balancing. Otherwise, you'll need to set your half your clients to use the physical address of TATA link and the other half to use physical address of Alrtel link for "load balancing." HSRP and VRRP is only a standby protocol. GLBP will load balance in round-robin method.

3. If TATA all 3 link  is goes down than Traffic is diverted to Airtel link. But Airltel link  is only 4 MBPS . SO I need to pass only selected traffic. How This is  possible?

You'll need to use QoS and prioritize/block traffic that you don't want to go over that link. Something like:

class-map NOWEB match-all

match ip protocol http

policy-map OUTBOUND

class NOWEB

drop

int

service-policy output OUTBOUND

The above is VERY rough and from memory, but it would drop all traffic that matches http (web traffic).

**** Please rate all helpful posts ****

HTH,

John

Dipesh Patel Tue, 06/29/2010 - 17:51

Dear John,

Thanks for the reply.

Yes that is good. But I am confusing as on TATA Link Router as shown in Topology there are 62 MB link terminated using 3 diffferent Physical Ports.

In this case how should I proceed. I can not go for multilink option here.

Pls suggest how I will configure HSRP/VRRP/GLBP?

Regards,

joshiaroon Tue, 06/29/2010 - 12:12

HSRP or VRRP are primarily for redundancy not for load balancing. If you want both redundancy and load balancing try configuring GLBP (gateway load balancing protocol)

thanks

Actions

This Discussion

Related Content