Simple question on EIGRP

Unanswered Question
Jun 30th, 2010
User Badges:

Hi,

While try to small change on EIGRP routing side, observed that all the neibours going down. here is config

If I eanble eigrp log-neighbor will that impact to router CPM/MEM utilization?


Present config at location
-----------------------------------

interface GigabitEthernet0/8
no switchport
ip address 10.255.10.53 255.255.255.0
speed 100
duplex full
no cdp enable

router eigrp 100
network 10.53.0.0 0.0.255.255
network 10.0.0.0
passive-interface default
no passive-interface GigabitEthernet1/0/48


After removing 10.0.0.0/8 network in routing protocal, neighbors went


router eigrp 100
network 10.53.0.0 0.0.255.255
no network 10.0.0.0
passive-interface default
no passive-interface GigabitEthernet1/0/48


Neighbor location config
-------------------------------


interface GigabitEthernet3/0/14
no switchport
ip address 10.255.10.70 255.255.255.0
ip summary-address eigrp 100 10.70.0.0 255.255.0.0 5
speed 100
no mdix auto


router eigrp 100
passive-interface default
no passive-interface GigabitEthernet3/0/14
network 10.0.0.0
no auto-summary
no eigrp log-neighbor-changes


I assume that there is a problem with summarization...I am looking for some explanation.

Regards

Kumar

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
shivlu jain Wed, 06/30/2010 - 03:27
User Badges:
  • Silver, 250 points or more

Hi You are having below configs



interface GigabitEthernet0/8
no switchport
ip address 10.255.10.53 255.255.255.0
speed 100
duplex full
no cdp enable

router eigrp 100
network 10.53.0.0 0.0.255.255
network 10.0.0.0
passive-interface default
no passive-interface GigabitEthernet1/0/48



when u remove net 10.0.0.0 you connectivity will down because 10p:.255.10.53 255.255.255.0 belongs to 10.0.0.0 network.



regards

shivlu jain

http://www.mplsvpn.info    

sateeshk10 Wed, 06/30/2010 - 03:35
User Badges:

Shiva,


you are right, if you look at other location config in that i am summerz the routes(10.70.0.0/16) on interface sending to other site ryt.. In that my interface IP(10.255.10.70) is not comes under that range.. how come EIGRP got established to other location..


Neighbor location config
-------------------------------


interface GigabitEthernet3/0/14
no switchport
ip address 10.255.10.70 255.255.255.0
ip summary-address eigrp 100 10.70.0.0 255.255.0.0 5
speed 100
no mdix auto


router eigrp 100
passive-interface default
no passive-interface GigabitEthernet3/0/14
network 10.0.0.0
no auto-summary
no eigrp log-neighbor-changes


One more when I check the routes at other end(Neighbor location) for the location which has enabled for autosummary by default...showing classless routes..its suppose to show classfull right as i have enanbled auto on EIGRP(default behaviour)..


Neibhor location#  sh  ip  route |  i 10.53
D       10.53.30.0/24
           [90/28416] via 10.255.10.53, 06:57:07, GigabitEthernet3/0/14
D       10.53.20.0/24
           [90/28416] via 10.255.10.53, 06:57:07, GigabitEthernet3/0/14
D       10.53.10.0/24
           [90/28416] via 10.255.10.53, 06:57:07, GigabitEthernet3/0/14
D       10.53.4.0/24
           [90/28416] via 10.255.10.53, 06:57:07, GigabitEthernet3/0/14
D       10.53.99.0/24
           [90/28416] via 10.255.10.53, 06:57:07, GigabitEthernet3/0/14
D       10.53.200.0/22
           [90/28416] via 10.255.10.53, 06:57:07, GigabitEthernet3/0/14


Regards

kumar

sateeshk10 Wed, 06/30/2010 - 06:32
User Badges:

Hi,


Can somebody try to respond  my queries?


Regards

Kuma.rk

vladimirsaltao Wed, 06/30/2010 - 08:04
User Badges:


You should configure the "no auto-summary" command on the  10.255.10.53 router

Richard Burts Wed, 06/30/2010 - 11:49
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Kumar


The problem is not with the summarization. The problem is with how you changed the selection of interfaces participating in EIGRP.


First let us review a fundamental aspect of how EIGRP works. The main function of the network statement in EIGRP is to identify the interfaces on which EIGRP will process. The router (or layer 3 switch) running EIGRP looks at all of the configured network statements and looks at all of the interfaces and finds interfaces that match one or more of the network statements. EIGRP will process on these (and only these) interfaces.


So when your configuration included the statement network 10.0.0.0 then any interface in network 10 (including 10.255.10.53) were active EIGRP interfaces and formed neighbor relationships. When you removed the network 10.0.0.0 statement then the only network statement was network 10.53.0.0 0.0.255.255 and only interfaces that match 10.53 were active EIGRP interfaces. Since 10.255.10.53 no longer matched a network statement it stopped being an active EIGRP interface and the neighbor relationship went away.


You asked about the impact of adding log neighbor and the answer is that it would have very minimal impact on router performance.


HTH


Rick

Actions

This Discussion