ACS EXpress upgrade issue

Unanswered Question
Jun 30th, 2010

Hi all,

I get the following errors when I try to upgrade an ACS Express from 5.0.0.18 to 5.0.1.1:

"manifest.xml file missing from bundle CSCOacsxp-5.0.1.1-appbundle.tar.gz"

"Error while Installing - Application bundle: CSCOacsxp-5.0.1.1-appbundle.tar.gz Repository: barry ErrorCode: -999"

There is an ACS System solution for a similar problem, ie, installing 5-0-0-21-9.tar.gpg and ACS_5.0.0.21_ADE_OS_1.2_upgrade.tar.gpg. Is there a similar ACS Express solution as well.

Thanks for any help

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Waris Hussain Wed, 06/30/2010 - 14:03

are you using TFTP server for upgrading , if yes can you try FTP server instead.

Thanks

Waris Hussain.

barryfowles Thu, 07/01/2010 - 00:11

Thanks for the response but I think I've answered my own question by burning the iso to disk and manually visiting the boxes.

Dennis Ariel Le... Mon, 08/09/2010 - 14:36

I'm having the same issue:

1. I downloaded the file named: CSCOacsxp-5.0.1.1-appbundle.tar.gz.

2. I copied that file to a FTP server.

3. I run the application upgrade command via SSH to the appliance and I got the following:

ACS-01/admin# un all

ACS-01/admin# application upgrade CSCOacsxp-5.0.1.1-appbundle.tar.gz ftp://172.24.1.228/CSCOacsxp-5.0.1.1-appbundle.tar.gz
Do you want to save the current configuration ? (yes/no) [yes] ?
Generating configuration...
Saved the running configuration to startup successfully

% Application upgrade failed, Error - -999. Please check ADE logs for details, or re-run with - debug application install - enabled.

I went to the logs and I found this:

Aug  9 14:14:03 HE-ZFM-ACS-01 debugd[2182]: [12558]: application:install cars_install.c[73]: Install initiated with bundle - CSCOacsxp-5.0.1.1-appbundle.tar.gz, repo - CSCOacsxp-5.0.1.1-appbundle.ta
Aug  9 14:14:03 HE-ZFM-ACS-01 debugd[2182]: [12558]: application:install cars_install.c[80]: Stage area - /storeddata/Installing/.1281363243
Aug  9 14:14:03 HE-ZFM-ACS-01 debugd[2182]: [12558]: application:install cars_install.c[84]: Getting bundle to local machine
Aug  9 14:14:03 HE-ZFM-ACS-01 debugd[2182]: [12558]: config:repository: rm_repos_cfg.c[207]: repository CSCOacsxp-5.0.1.1-appbundle.ta could not be loaded (normal and expected when adding a new repository)
Aug  9 14:14:03 HE-ZFM-ACS-01 debugd[2182]: [12558]: transfer: cars_xfer.c[40]: couldn't get repository CSCOacsxp-5.0.1.1-appbundle.ta
Aug  9 14:14:03 HE-ZFM-ACS-01 debugd[2182]: [12558]: application:install cars_install.c[90]: Could not get remote bundle CSCOacsxp-5.0.1.1-appbundle.tar.gz from repo CSCOacsxp-5.0.1.1-appbundle.ta
Aug  9 14:14:03 HE-ZFM-ACS-01 debugd[2182]: [12558]: application:install install_cli.c[175]: Error while Installing - Application bundle: CSCOacsxp-5.0.1.1-appbundle.tar.gz  Repository: CSCOacsxp-5.0.1.1-appbundle.ta  ErrorCode: -999

There is no firewall rule in between blocking FTP and I even tried using a FTP server on my machine with no luck...

Documentation at cisco.com for this issues is almost inexistent...

Any toughts?

Regards,

DL.

Waris Hussain Mon, 08/09/2010 - 15:00

Hi,

In the logs I see :

Aug  9 14:14:03 HE-ZFM-ACS-01 debugd[2182]: [12558]: application:install cars_install.c[90]: Could not get remote bundle CSCOacsxp-5.0.1.1-appbundle.tar.gz from repo CSCOacsxp-5.0.1.1-appbundle.ta


Aug  9 14:14:03 HE-ZFM-ACS-01 debugd[2182]: [12558]: application:install install_cli.c[175]: Error while Installing - Application bundle: CSCOacsxp-5.0.1.1-appbundle.tar.gz  Repository: CSCOacsxp-5.0.1.1-appbundle.ta  ErrorCode: -999

Is CSCOacsxp-5.0.1.1-appbundle.ta  you repository name ?

The correct syntax is :

application upgrade

as per link :

http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_server_express/5.0.1/release/notes/xpnote.html#wp60443

Make sure you  have CSCOacsxp-5.0.1.1-appbundle.tar.gz with exact same extension name showing under FTP server.

I have previous cases where the browser is changing the extnesion of the file while downloading or saving it on the ftp server and getting same error message as  you are getting.

Thanks

Waris Hussain

Dennis Ariel Le... Mon, 08/09/2010 - 15:17

Waris,

Thanks for the answer,

Please correct me if I'm wrong with something because I might be missunderstanding something on the procedure:

I just did this:

- I downloaded the file and without modifying the name I uploaded it to the FTP server.

- I did a test by downloading the file via FTP from my PC and it downloaded just fine without modifying the name (the ACS and my PC are on the same subnet).

- I connected to the ACS via SSH and ran the following command:

ACS-01/admin#application upgrade CSCOacsxp-5.0.1.1-appbundle.tar.gz ftp://172.24.1.228/

I got this error with debug application enabled:

Do you want to save the current configuration ? (yes/no) [yes] ?
Generating configuration...
Saved the running configuration to startup successfully
6 [13475]: application:install cars_install.c[73]: Install initiated with bundle - CSCOacsxp-5.0.1.1-appbundle.tar.gz, repo - ftp://172.24.1.228/
6 [13475]: application:install cars_install.c[80]: Stage area - /storeddata/Installing/.1281366110
6 [13475]: application:install cars_install.c[84]: Getting bundle to local machine
3 [13475]: application:install cars_install.c[90]: Could not get remote bundle CSCOacsxp-5.0.1.1-appbundle.tar.gz from repo ftp://172.24.1.228/

% Application upgrade failed, Error - -999. Please check ADE logs for details, or re-run with - debug application install - enabled.
3 [13475]: application:install install_cli.c[175]: Error while Installing - Application bundle: CSCOacsxp-5.0.1.1-appbundle.tar.gz  Repository: ftp://172.24.1.228/  ErrorCode: -999

I'm attaching a screenshot of the FTP server screen I get when I connect using my PC...the only difference is that I have to enter a username/password to login with my PC. I'm not sure if this does affects the ACS upgrade. And as for the syntax is my understanding that 'repository name' should be replaced with:  ftp://172.24.1.228/

Do u have a real sample of this procedure?

Thanks again,

PD. this is also the ADE log from my last attempt:

Aug 9 15:01:50 HE-ZFM-ACS-01 debugd[2182]: Opened tty (34) /dev/pts/0
Aug 9  15:01:50 HE-ZFM-ACS-01 debugd[2182]: [13475]: application:install  cars_install.c[73]: Install initiated with bundle -  CSCOacsxp-5.0.1.1-appbundle.tar.gz, repo - ftp://172.24.1.228/
Aug 9  15:01:50 HE-ZFM-ACS-01 debugd[2182]: [13475]: application:install  cars_install.c[80]: Stage area - /storeddata/Installing/.1281366110
Aug 9  15:01:50 HE-ZFM-ACS-01 debugd[2182]: [13475]: application:install  cars_install.c[84]: Getting bundle to local machine
Aug 9 15:01:50  HE-ZFM-ACS-01 debugd[2182]: [13475]: config:repository: rm_repos_cfg.c[207]:  repository ftp://172.24.1.228/ could not be loaded (normal and expected when  adding a new repository)
Aug 9 15:01:50 HE-ZFM-ACS-01 debugd[2182]: [13475]:  transfer: cars_xfer.c[40]: couldn't get repository ftp://172.24.1.228/
Aug 9  15:01:50 HE-ZFM-ACS-01 debugd[2182]: [13475]: application:install  cars_install.c[90]: Could not get remote bundle  CSCOacsxp-5.0.1.1-appbundle.tar.gz from repo ftp://172.24.1.228/
Aug 9  15:01:50 HE-ZFM-ACS-01 debugd[2182]: [13475]: application:install  install_cli.c[175]: Error while Installing - Application bundle:  CSCOacsxp-5.0.1.1-appbundle.tar.gz Repository: ftp://172.24.1.228/ ErrorCode:  -999

DL.

Attachment: 
Waris Hussain Mon, 08/09/2010 - 15:41

Hi ,

here are the steps :

Create a local repository pointing towards  your ftp server.

acsexpress1/admin(config)# repository myrepository

acsexpress1/admin(config-Repository)# url ftp://172.24.1.228
acsexpress1/admin(config-Repository)# user Luke password plain skywalker ( luke is the usernamre and skywalker password )
acsexpress1/admin(config-Repository)# exit
so assunimg that  CSCOacsxp-5.0.1.1-appbundle.tar.gz is located in ftp server mentioned above 
run the command 
application upgrade  
which is in your case will look like :
ACS-01/admin#application upgrade CSCOacsxp-5.0.1.1-appbundle.tar.gz  myrepository
Here is the link for CLI for ACS exp:
http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_server_express/5.0/command/reference/guide/CLIappA.html#wp1013913
Thanks
Waris Hussain.
Dennis Ariel Le... Mon, 08/09/2010 - 16:19

Waris,

The repository part was missing in the documentation at cisco.com; I just followed the steps you sent me and it worked out just fine...

Thank you very much for the assistance..

Best Regards,

DL.

subflava Wed, 01/12/2011 - 07:00

Waris,

Are you saying using TFTP to do the upgrade does not work, but using FTP will work? I also ran into this exact issue and ended up doing the upgrade via cd-rom.

Actions

This Discussion