Unable to ping router port on Cisco 3550

Unanswered Question
Jun 30th, 2010
User Badges:

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman","serif";}

I can't ping 10.10.10.1 from my laptop, am I doing something wrong?


Used: Cisco 3550

Ports used:         Fa0/46 è access port with VLAN 4000

                                Fa0/47 è router port with IP 10.10.10.1/24

                                Fa0/48 è access port with VLAN 4000


Procedure:

1-      Built Fa0/46 and L3 interface.  Configured laptop with IP 10.10.10.2/24

a.       Able to ping L3

2-      Removed L3 interface

3-      Built Fa0/47 as router port.

a.       Able to ping router port

4-      Built Fa0/48

a.       Connected laptop to port 0/48

5-      Unable to ping 10.10.10.1 from port 0/48, able to ping myself

6-      All interfaces were up/up

a.       Used cross cable between port 0/46 and 0/47

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
vladimirsaltao Wed, 06/30/2010 - 09:25
User Badges:

double check config of port 48, do "sh vlan id 4000" to see if all ports appear ,

do a "sh mac-address-table vlan 4000 | inc Fa" to see if there is a mac entry in all ports.

fibernet570 Wed, 06/30/2010 - 09:28
User Badges:

I have to retest and gather the info this evening, but I did:

Switch#show spanning-tree vlan 4000


VLAN4000
  Spanning tree enabled protocol ieee
  Root ID    Priority    36768
             Address     000f.349c.9d00
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec


  Bridge ID  Priority    36768  (priority 32768 sys-id-ext 4000)
             Address     000f.349c.9d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec


Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/46              Desg FWD 19        128.46   P2p
Fa0/48              Desg FWD 19        128.48   P2p

vladimirsaltao Wed, 06/30/2010 - 09:33
User Badges:

You should have a STP entry  for the router port also, check the status and config of it

glen.grant Wed, 06/30/2010 - 09:44
User Badges:
  • Purple, 4500 points or more

  What do you have for an ip address for vlan 4000 ?  If you have 10.10.10.0/24 on 47 as a routed port I don't believe it will let you have that same  address range on a SVI for vlan 4000 .

fibernet570 Wed, 06/30/2010 - 09:51
User Badges:

I had an SVI on the switch but I removed, this is the config:

(Note: all interfaces were up/up but I didnt verify it MAC learning from every port)


interface FastEthernet0/46
switchport access vlan 4000
switchport mode access
speed 100
duplex full
spanning-tree bpdufilter enable
end


Switch#
Switch#show run int fast 0/47
Building configuration...


Current configuration : 110 bytes
!
interface FastEthernet0/47
no switchport
ip address 10.10.10.1 255.255.255.0
speed 100
duplex full
end


Switch#
Switch#show run int fast 0/48
Building configuration...


Current configuration : 144 bytes
!
interface FastEthernet0/48
switchport access vlan 4000
switchport mode access
speed 100
duplex full
spanning-tree bpdufilter enable
end

glen.grant Wed, 06/30/2010 - 09:56
User Badges:
  • Purple, 4500 points or more

   You would need a L3 SVI address in  vlan 4000 different from the  range than port 47  and then put your clients (ports)into the address range for vlan 4000 and then try pinging .



Interface vlan 4000

ip address 10.10.9.1 255.255.255.0   --- as an example, could be whatever you want



interface FastEthernet0/46
switchport access vlan 4000
switchport mode access
speed 100
duplex full
spanning-tree  bpdufilter enable
end


Switch#
Switch#show run int fast 0/47
Building  configuration...


Current configuration : 110 bytes
!
interface  FastEthernet0/47
no switchport
ip address 10.10.10.1  255.255.255.0
speed 100
duplex full
end


Switch#
Switch#show  run int fast 0/48
Building configuration...


Current configuration : 144  bytes

!

interface FastEthernet0/48

switchport access vlan 4000

switchport mode access

speed 100

duplex full

spanning-tree  bpdufilter enable

fibernet570 Wed, 06/30/2010 - 10:07
User Badges:

So,

1- Keep laptop IP as 10.10.10.2/24

2- Keep laptop plugged into port Fa0/48

3- Keep cross cable between Fa0/46 and Fa0/47

4- Create SVI on VLAN 4000 with IP 10.10.9.1/24 (or whatever)


Is this correct?  If so, I will retry this evening once I get home.


-Manny

fibernet570 Wed, 06/30/2010 - 12:14
User Badges:

Forgot something, revised test bed:


I can't ping 10.10.10.1 from my laptop, am I doing  something wrong?


Used: Cisco 3550

Ports used:             Fa0/46  ==> access port with VLAN 4000

                                 Fa0/47 ==> router port with  IP 10.10.10.1/24

                                 Fa0/48 ==> access port with  VLAN 4000


Procedure:

1-      1- Built Fa0/46 and L3 interface.   Configured laptop with IP 10.10.10.2/24

a.       Able to ping L3

2-      2- Removed L3 interface

3-      3- Built Fa0/47 as router port.

a.       Able to ping router port

4-      4- Built Fa0/48

a.       Connected laptop to port 0/48

5-      5- Used a cross-over and connected Fa0/46 to Fa0/47

         6- Unable to ping 10.10.10.1 from port  0/48, able to ping myself

6-      7- All  interfaces were up/up

a.       Used cross cable between port 0/46  and 0/47



This test should be similar to:

laptop ==> Fa0/46 ==> Cisco 3550 ==> Fa0/48 ==> laptop


-Manny

Actions

This Discussion