Slow transfer rate - need expert opinion?

Unanswered Question
Jun 30th, 2010
User Badges:

Hi Guys,


We have 2 Virtual servers in – one is a Citrix server and the other is an Application server. The  communication between these 2 servers is critical, as the application writes to  the APP server. Now, we have been facing a latency on the servers for some time.  The vendor was asked to check on the application and they have stated that the  issue is with the Network and not the application.


Both CTX Server & APP Server are on the same subnet –  10.X.X.X and going through the same router. The NIC is 1 GBps, but the  connection is shared between all the virtual servers in the same subnet and also  the hosting ESX server. There was a testing done to transfer a 600 MB file from  CTX server to the APP server and it took 45 seconds to complete the transfer  (app 13.3 MB/s).


We need your expert opinion on this issue and also the ways  to improve the performance if you feel that this is a slow transfer  rate.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Leo Laohoo Wed, 06/30/2010 - 22:24
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless


The vendor was asked to check on the application and they have stated that the  issue is with the Network and not the application.

Vendors will always say it's a network issue.


Do you have a network diagram?  What's the switch the servers are connected to?

thinakraj Wed, 06/30/2010 - 22:37
User Badges:

sorry i don't have the permission to view the doc.

checked port charactestic in both server end and switch end. it is in full duplex only. any other ????

robert-olsson Thu, 07/01/2010 - 05:06
User Badges:

Hi,


600MB in 45 seconds is very close to 100Mbps transfer.


When reading your description of the setup it seems like the 2 virtual servers are on the same physical server?

If so, when these 2 servers are communicating all is done in the virtual VM-switch and do not leave the physical server to the Switch.


I would start to check both virtual servers nic to see that the driver is updated and that they both use 1Gbps. And also that the virtual switch supports this.


Reg

//Robert

Actions

This Discussion