How to configure cisco router(1unit) connect to two switch 3560? please help!!

Unanswered Question
Jun 30th, 2010

Dear All,

i have some problem on configuration on cisco router 2821 and switch 3560. my boss he wants cisco switch 3560 Active/Active, i mean that Cisco 3560 is working the same time. let me show u on diagram that: Cisco 2821 i have card hwic-1Enet this card connect to internet and int g0/0 connect to switch 3560 (01) and int g0/1 connect to switch 3560 (02) and both switch connect to access switch.

but i don't know how to configure on switch 3560 (2unit) Active/Active and Cisco router 2821. Could you let me know how to configure ?

Best Regards,

Rechard_david

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Richard Burts Thu, 07/01/2010 - 11:25

There is another alternative to consider which should be able to satisfy this requirement. Configure the router with Integrated Routing and Bridging. With IRB you configure both Gig interfaces for bridging (no ip address on the interface and a bridge group on the interface), you then configure a virtual interface (a Bridged Virtual Interface) and the BVI is where you configure the ip address. There are a couple of commands that enable carrying routed IP traffic over the bridged interfaces. Here is a post from the forum which has examples of the commands:

https://supportforums.cisco.com/message/26680#26680

HTH

Rick

Richard Burts Thu, 07/01/2010 - 23:11

Ram

HSRP is designed to work when there are router interfaces on 2 routers connected to switches in the same VLAN and same subnet. HSRP is not designed to work on 2 interfaces of the same router. If you attempt to configure HSRP with 2 interfaces on the same router you will get an error when you attempt to configure the IP address of the second interface. The error will inform you that the address you are attempting to configure overlaps witn an existing address and the IOS will not accept the address assignment.

HTH

Rick

Ramprasad Pr Thu, 07/01/2010 - 23:27

Rick,
This configuration for Distribution switch, that is on ( 3560 - 01 & 02 ) not on router.
Regards
Ram

rechard_david Fri, 07/02/2010 - 02:02

Dear All,

Thanks you for you help!!!

I'm not clear when we use protocol GLBP on Router, how about Cisco switch 3560 ( 2 unite) that Cisco router 2821 connected to both swith, so which protocol that we can do both switch Active/Active?


Could you let me know ?

Best Regards,

Rechard

Ramprasad Pr Fri, 07/02/2010 - 02:19

Richard,

You can go for HSRP but you need to run two instance at a time for Active/Active mode.

Regards

Ram

rechard_david Fri, 07/02/2010 - 02:32

Dear Ram,

i'm not sure about HSRP.

For HSRP it use Active/Standy.

how can we do HSRP to Active/Active?

Best regards,

Rechard

rechard_david Fri, 07/02/2010 - 03:08

Dear Ram,

After i read document that u show me i saw it Acitve/Standy, Please see infor as below:

HSRP is often used to improve resiliency in  networks, but this can cause a decrease in network efficiency. The  example in this document has two paths from the host network to the  server network. For redundancy, HSRP runs between R1 and R2, either of  which can become the active router and take "ownership" of the HSRP  virtual IP address. The second router becomes the standby router, and  only becomes the active router if the current active router goes down

last time i did configure Active/standby

Primary(Active)

interface Vlan100
ip address 192.168.39.3 255.255.255.0
ip access-group aclall out
standby 16 ip 192.168.39.2
standby 16 priority 200
standby 16 timers 1 3
standby 16 preempt

Secondary (Backup)

interface Vlan100
ip address 192.168.39.4 255.255.255.0
ip access-group aclall out
standby 16 ip 192.168.39.2
standby 16 timers 1 3
standby 16 preempt

command as above is Active/Standy, so on HSRP do you have other command for Active/Active

Best regards,

Rechard

CSCO10320953 Fri, 07/02/2010 - 03:16

HI ,

This is will be useful for your Gateway Load Balancing Protocol (GLBP)

  • Created by Cisco, for Cisco in 2005
  • Identical features to HSRP, but allows an active-active connection that adds load-balancing features

GLBP

Switch 1#

int f0/0
ip address 192.168.1.11 255.255.255.0
glbp 1 ip 192.168.1.1
glbp 1 priority 200
glbp 1 preempt
no shut

Switch 2#

int f0/0
ip address 192.168.1.12 255.255.255.0
glbp 1 ip 192.168.1.1
no shut

Pl rate on this.

Ramprasad Pr Fri, 07/02/2010 - 03:38


Dear Richard,

Router1 is the active router for group 1 (priority 110, default 100), so all the traffic will
flow through Router1's path. I will apply the configuration to migrate this default
HSRP  to Multigroup HSRP (MHSRP) which is load balance client traffic :

    Router1
    interface FastEthernet0/0
    ip address 192.168.12.1 255.255.255.0
    standby 1 preempt
    standby 1 ip 192.168.12.3
    standby 1 priority 110
    standby 2 preempt
    standby 2 ip 192.168.12.4

    Router2
    interface FastEthernet0/0
    ip address 192.168.12.2 255.255.255.0
    standby 1 preempt
    standby 1 ip 192.168.12.3
    standby 2 preempt
    standby 2 ip 192.168.12.4
    standby 2 priority 110

We have group 1 with Router1 active (192.168.12.3) and group 2 with Router2 active
(192.168.12.4). Of course you will have to find a way to push to the clients
the 2 gateways (192.168.12.3 and 192.168.12.4) or to configure them manually on
your users machines, to really achieve the load balance feature with HSRP.

Regards

Ram

Richard Burts Sat, 07/03/2010 - 11:57

Ram

I absolutely agree with you that this is an excellent solution when there is router 1 and router 2. But unless I seriously misread the original post the original question was 1 router with 2 switches.

The original post was pretty clear that he wants one 3560 connected to router interface gig0/0 and the other switch connected to same router on interface gig0/1. In this case HSRP does not work.

The only solution that I see for this that will work is Integrated Routing and Bridging. While IRB would work here I am not presenting it as a desirable choice.

HTH

Rick

Ramprasad Pr Sat, 07/03/2010 - 21:06

Richard,

Yes , we need to use IRB in this case as per this question.

Regards

Ram

Actions

Login or Register to take actions

This Discussion

Posted June 30, 2010 at 6:43 PM
Stats:
Replies:14 Avg. Rating:
Views:2252 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard