EIGRP not working on 3560

Answered Question
Jul 1st, 2010
User Badges:

I am using 3560-ts-s and updated with IP services image. i want to route two networks 10.0.1.1 and 10.0.2.1 through the 3560 using eigrp. I also need to configure HSRP on the same switch. the part of configuration is below


IP routing
!
interface FastEthernet0/1
description **** Connected to FTE community-1 ****
no switchport
ip address 10.0.1.200 255.255.255.0
  no ip proxy-arp
ip pim dense-mode
ip igmp version 3
duplex auto
speed auto
standby 1 ip 10.0.1.254
standby 1 timers msec 250 msec 750
standby 1 priority 105
standby 1 preempt delay minimum 180
standby 1 track FastEthernet0/1
standby 1 track FastEthernet0/2
!
interface FastEthernet0/2
description **** Connected to FTE community-2 ****
no switchport
ip address 10.0.2.200 255.255.255.0
  no ip proxy-arp
ip pim dense-mode
ip igmp version 3
duplex auto
speed auto
standby 1 ip 10.0.2.254
standby 1 timers msec 250 msec 750
standby 1 priority 105
standby 1 preempt delay minimum 180
standby 1 track FastEthernet0/1
standby 1 track FastEthernet0/2
!
router eigrp 150
network 10.0.1.128 0.0.0.127
network 10.0.2.128 0.0.0.127
no auto-summary
!
ip classless
!



Issue is i not able to see any routing using EIGRP and not able to ping to node. the archtecture is attached

Correct Answer by Richard Burts about 6 years 11 months ago

Victor


Thank you for adding support to the points that I made.


To the original poster


I have several observations and suggestions for you:

- you seem to be very concerned about EIGRP. But what is shown in your diagrams are only 2 routing devices (both 3560) and they have only connected routes. So there is no real need for EIGRP, and there would be no EIGRP routes in the routing table, unless one of the 3560 is connected to some other network that the other 3560 is not connected to.

- for the 3560 with connected routes, as long as ip routing is enabled the connected subnets should talk to each other. Your posts show that ip routing is enabled. So routing should be happening between the connected subnets.

- in reading the thread more carefully I notice that both servers are in VLAN 110 (the same VLAN but differing subnets). That is a bit odd. Some people might think that it was a problem. But since the 2960s are connecting to the 3560 on a routed port (not a switching port) the VLAN really makes little difference.

- since the server default gateway is the virtual address it may make some difference which 3560 is the active router for the subnet.
- it might be helpful if you would post the output of show standby from the 3560.

- it might also be helpful if you would post the output of show arp from the 3560.


HTH


Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Ganesh Hariharan Thu, 07/01/2010 - 03:34
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Member's Choice, February 2016

Hi,


What is the output of show ip protocols in switch ?


Ganesh.H

girishwalvekar Thu, 07/01/2010 - 03:49
User Badges:

by show ip protocol i able to see EIGRP protocol but not any network routed on that.i

Please note that i updated cisco switch 3560 TS-S to IP services so is there any relation with this.

I able to ping all network from Router console, i mean inside the router.

thinakraj Thu, 07/01/2010 - 04:14
User Badges:

hi check your config..... how  the priority 105 is same for two interface ?


default is 100. again you are making two interface as in the same priority, which one is going to active ?


kindly check this and provide the # sh stanby and #sh ip route

and tracert out put also... ?


standby 1 priority 105....?

girishwalvekar Thu, 07/01/2010 - 04:21
User Badges:

Hi,

You mean beacuse of HSRP configuration EIRGP routing is not happning.

and about Priority configuration Fa0/1 is connected to one 2960 switch having 10.0.1.0/24 network and Fa0/2 is connected to another 2960 switch having 10.0.2.0/24 network. Presently i am far away from switch so not able to provide you more detail.


But not that i able to ping all the node from 3560 console.

Don Saling Thu, 07/01/2010 - 06:48
User Badges:

I don't think your network statements are correct.  They don't match the prefix length of the interfaces.  You have /24 on the FE interfaces, but /25 in your network statements.


try:


router eigrp 150

no network 10.0.1.128 0.0.0.127
no network 10.0.2.128 0.0.0.127

network 10.0.1.0 0.0.0.255
network 10.0.2.0 0.0.0.255

tj.mitchell Thu, 07/01/2010 - 10:40
User Badges:
  • Bronze, 100 points or more

Agreed, subnets aren't correct in the routing protocol. Fix that should fix the problem.

Richard Burts Thu, 07/01/2010 - 11:40
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Actually there is no requirement that the mask (inverse mask) used in the EIGRP network statement needs to match the mask used in the subnet. The mask in the network statement will successfully match the .200 interface address and the interface will be included in EIGRP. This can be proven from the output of the command show ip eigrp interface, which should show both fa0/1 and fa0/2 as EIGRP interfaces.


HTH


Rick

Richard Burts Thu, 07/01/2010 - 11:50
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

I am not clear how you are looking to see routing by EIGRP. Perhaps you could post the output of show ip eigrp interface and of show ip eigrp neighbor. These might help to demonstrate whether there is EIGRP routing.


In looking at your diagram I wonder how the 2960s are configured. Are they configured with any VLANs? VLANs on the 2960s could interfere with routing on the 3560s.


Can you tell us the specifics of how server-1 and server-2 are set up? What are their address, their mask, and their default gateway?


Can a 3560 ping server-1 or server-2? Can server-1 (or server-2) ping the 3560?


If we knew these things we might be closer to understanding what the problem is.


HTH


Rick

girishwalvekar Sun, 07/04/2010 - 22:14
User Badges:

both 2960 are configured for Vlan101.

I able to ping both the servers (1 & 2) form 3560 console but not able to ping from any server.

following is ip configuration for server -1


IP - 10.0.1.129 255.255.255.0

Default gateway 10.0.1.254 ( is standby ip at fa0/1)


IP configuration for Server-2

IP 10.0.2.129 255.255.255.0

Default gateway 10.0.2.254 ( is standby ip at fa0/2)


by show ip route


only able to see directly connected network , no eigrp network


I also tried

router eigrp 150

network 10.0.1.0 0.0.0.255

network 10.0.2.0 0.0.0.255


But no success, i still not able to see eigrp route and also not able to ping any node to node.

Please not that i able to ping gateway and router IP from both the servers and also able to ping server-1 and server-2 from 3560.

girishwalvekar Sun, 07/04/2010 - 23:31
User Badges:

Is this becoz of IOS upgrade. Because i upgraded 3560-TS-S (IP base

) to IP services. I downloaded IOs from cisco site and having license also.

amar_5664 Mon, 07/05/2010 - 00:02
User Badges:

mate,


according to your diagram you dont have any interconnect between the switches or the routers.


Few things to check


-     can you ping from one router to another router say f0/1 of SW-A to SW-B ( watever the name is) and f0/2 ?

-     diagram says routers are sitting on two different switches and the switches are not interconnected or not running any trunk to pass the Vlans etc.

-     if unable to ping router to router get your connections right.



get the ping results


give us configuration details on your routers and switches.

girishwalvekar Mon, 07/05/2010 - 00:11
User Badges:

I able to ping SW- A to ROuter and also from SW-B to router

but there is no ping from SW-A to SW-B. Please note that both the switches are having Vlan101

configured.

Is there trunking required in 3560? as i am using same Vlan at all switches?


router config is



IP routing
!
interface FastEthernet0/1
description **** Connected to FTE community-1 ****
no switchport
ip address 10.0.1.200 255.255.255.0
  no ip proxy-arp
ip pim dense-mode
ip igmp version 3
duplex auto
speed auto
standby 1 ip 10.0.1.254
standby 1 timers msec 250 msec 750
standby 1 preempt delay minimum 180
standby 1 track FastEthernet0/1
standby 1 track FastEthernet0/2
!
interface FastEthernet0/2
description **** Connected to FTE community-2 ****
no switchport
ip address 10.0.2.200 255.255.255.0
  no ip proxy-arp
ip pim dense-mode
ip igmp version 3
duplex auto
speed auto
standby 1 ip 10.0.2.254
standby 1 timers msec 250 msec 750
standby 1 preempt delay minimum 180
standby 1 track FastEthernet0/1
standby 1 track FastEthernet0/2
!
router eigrp 150
network 10.0.1.128 0.0.0.127
network 10.0.2.128 0.0.0.127
no auto-summary
!
ip classless

amar_5664 Mon, 07/05/2010 - 01:42
User Badges:

do u mean to say u can ping from your 2960 switch to 3560 router..

i want to know can you ping from 3560 router to another 3560 router ?

u do not need trunk on 3560 but i dont see any interconnects between your routers or switch, how are your routers going to talk to each other?


log on to one 3560 router and ping other routers interface and paste that result here...

girishwalvekar Mon, 07/05/2010 - 01:58
User Badges:

i can ping 3560 router from 2960 switches. Please note that i am using redundancy network. the routers are redundant and switches also redundant.

So there is no connection from one router to another. Through HSRP they are linked. See attached modified topology


The router( 3560) i am using only to allow access between two network. And also connected some printers and GPS time server on the same router.

Attachment: 
amar_5664 Mon, 07/05/2010 - 17:22
User Badges:

i understand that you can ping from switch to 3560... your new diagram includes a link between two switches so which diagram is correct the initial one or the lastes that you posted


can you provide show standby brief for both routers?

lamav Mon, 07/05/2010 - 18:07
User Badges:
  • Blue, 1500 points or more

Girish, you're going in circles, my friend. Stop sending frivolous PINGs and do what Rick asked you to do.


Execute a 'sh ip eigrp nei' to see if the routers have established neighborships with each other. No neighbors - no routing.


As for the inverse masks on the network statements and the masks on the interface, they do not have to match, as Rick pointed out. The purpose of the network statement under EIGRP is not to advertise networks, per se, as it is in BGP. The purpose is to simply tell the EIGRP protocol on which interfaces to run the protocol. If the IP address of the interface is included in the network range covered by the inverse mask in the network statement, the protocol will run on the interface and the subnet mask on the interface is what will be advertised.


For example, if the network address on the FastEthernet interface is 10.0.1.200, then several network statements will work.


network 10.0.1.200 0.0.0.0


network 10.0.1.0 0.0.0.255


network 10.0.1.128 0.0.0.127


All these network statements include the interface address in the range it covers, so all of them will be successful in running EIGRP on the interface, thereby allowing the router to establish neighborships and exchange routing information.



HTH


Victor

Correct Answer
Richard Burts Thu, 07/08/2010 - 19:49
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Victor


Thank you for adding support to the points that I made.


To the original poster


I have several observations and suggestions for you:

- you seem to be very concerned about EIGRP. But what is shown in your diagrams are only 2 routing devices (both 3560) and they have only connected routes. So there is no real need for EIGRP, and there would be no EIGRP routes in the routing table, unless one of the 3560 is connected to some other network that the other 3560 is not connected to.

- for the 3560 with connected routes, as long as ip routing is enabled the connected subnets should talk to each other. Your posts show that ip routing is enabled. So routing should be happening between the connected subnets.

- in reading the thread more carefully I notice that both servers are in VLAN 110 (the same VLAN but differing subnets). That is a bit odd. Some people might think that it was a problem. But since the 2960s are connecting to the 3560 on a routed port (not a switching port) the VLAN really makes little difference.

- since the server default gateway is the virtual address it may make some difference which 3560 is the active router for the subnet.
- it might be helpful if you would post the output of show standby from the 3560.

- it might also be helpful if you would post the output of show arp from the 3560.


HTH


Rick

girishwalvekar Fri, 07/09/2010 - 22:52
User Badges:

Rick,

Thanks for your support. You are correct.

I removed eigrp configuration from the router as it is not required and also enabled arp.

Now router is functioning properly.


Regards,

Girish


Richard Burts Sat, 07/10/2010 - 06:21
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Girish


I am glad that you got the problem solved and that my suggestions were helpful. Thank you for posting back to the forum indicating that it was solved and how you solved it (and thanks for the rating). It makes the forum more useful when people can read about a problem and can know from the marking that the problem was solved and they will find out about the solution.


HTH


Rick

Actions

This Discussion

Related Content