Configuration Suggestions

Unanswered Question
Jul 1st, 2010
User Badges:

We have implemented a simple small office with about 15 users using a ESW-520-48 switch and WRVS4400N router.  Type II T1 connected to the router WAN and port 1 connected to uplink on Switch.


There are 13 VoIP devices connected directly to the switch and about 10 WiFi users through the N-router.


We are experiencing some call quality issues even after setting QoS on the router (rate - to prioritize the VoIP).  Typical desktop usage is fine.


It is possible that the configuration of the router and switch are not correct (looking for suggestions).


I have limited experience with Cisco products on this scale.


Thank you in advance for any input.


Phil Barron

[email protected]

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Mohamed Sobair Thu, 07/01/2010 - 09:25
User Badges:
  • Gold, 750 points or more

Hi,


There could be multiple factors on this:


1- VoIP setup (Communication Manager, VoIP GW router , FXO)

2- Congestion on the Network.

3- Not a proper Network setup.

4- Not a proper QoS setup.


you cant be positive unless some one analyzes and evaluates your setup.



HTH

Mohamed

dwalter411 Thu, 07/01/2010 - 09:53
User Badges:

Thank you Mohamed for the quick reply.


I've ruled out FXO.  VoIP gear is remotely hosted using Polycoms.


I'm pretty sure the Router and Switch are not currently configured correctly (physically as well - although I'd imagine it wouldn't be working at all it it wasn't).


Perhaps a better question to ask is what would be the correct physical configuration of a T1 > Router > Switch > devices.  I am wondering if the router simply be placed on a standard port (ie. smartport) rather than an uplink.


Again, thank you for your reply and comments.


Phil.

Mohamed Sobair Thu, 07/01/2010 - 10:24
User Badges:
  • Gold, 750 points or more

Hi Phil,


The configuration of the T1 should be as follows:


interface serial0/0

ip address x.x.x.x y.y.y.y

encapsulation ppp

service-module t1 timeslots 1-24 (If you have full T1)
service-module t1 framing esf (According to the service provider CSU information)
service-module  t1 linecode b8zs (According to the service provider CSU information)

service-module t1 clock source line

no shut


The Lan port of the router should be the Gateway for the users-ie and the Gateway for the Voice:


Interface F0/0

no ip address

no shutdown


interface f0/0.1

encapsulation dot1q 2

ip address z.z.z.z f.f.f.f.f


interface f0/0.2

encapsulation dot1q 3

ip address a.a.a.a b.b.b.b


---------------------------------------------------------------------


You should have at least 2 Vlans , one for Data and one for Voice (depends on your initial design) , the uplink port of the switch should be trunked to the router.


Access ports should be configured for both Voip vlan and data Vlan. ie:


interface f0/0 (Access port)

switch port mode access

switch port acc vlan 2  (Data Vlan)

switch port voice vlan 3 (voice vlan)

no shutdown


You would then need to check whether the user and the phones gets IP from a DHCP server or from the router.



This is a basic setup, you will need to make sure the Phone are setup properly to recieve IP from the DHCP server and you should also make sure they are communicating with the communication manager and your QoS if you have QoS setup. The QoS depends whether you have congestion on the Network or not.



HTH

Mohamed

Actions

This Discussion