AP1400 bridge Dot1q trunk assistance

Unanswered Question
Jul 1st, 2010

I am trying to set up a point to (multi)point bride using Cisco AP1400 wireless bridges.

Catalyst 4500 - 1400 Root - 1400 NotRoot - Cat3650

I am trying to run 3 vlans across this link.  Voice, Data and Management

I can get everything connected and talking on the native VLAN, but no luck with the other 2.  Looking at the vlans on the bridge, they appear to be passing traffic... but I can't seem to get anywhere when connected to them.  I have no routing set up other than a default gateway on the far switch.

Any ideas what I'm doing wrong?

Local C4500 port config:

interface FastEthernet4/14

switchport trunk encapsulation dot1q

switchport trunk native vlan 999

switchport trunk allowed vlan 20,102,999

switchport mode trunk

Wireless config
dot11 ssid WanTest
   vlan 999
   authentication open
   guest-mode
   infrastructure-ssid
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid WanTest
!
station-role install root
rts threshold 4000
concatenation
infrastructure-client
!
interface Dot11Radio0.1
encapsulation dot1Q 999 native
no ip route-cache
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.2
encapsulation dot1Q 102
no ip route-cache
bridge-group 2
bridge-group 2 subscriber-loop-control
bridge-group 2 spanning-disabled
!
interface Dot11Radio0.3
encapsulation dot1Q 20
no ip route-cache
bridge-group 3
bridge-group 3 subscriber-loop-control
bridge-group 3 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
!
interface FastEthernet0.1
encapsulation dot1Q 999 native
no ip route-cache
bridge-group 1
!
interface FastEthernet0.2
encapsulation dot1Q 102
no ip route-cache
bridge-group 2
!
interface FastEthernet0.3
encapsulation dot1Q 20
no ip route-cache
bridge-group 3
!
interface BVI1
ip address 10.99.X.X 255.255.0.0
no ip route-cache
!
ip default-gateway 10.99.1.1
ip http server
no ip http secure-server
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
login local
!
end
--Other wireless AP is the same, except for the Station-role
Far-side 3650 switchport configuration:
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport trunk allowed vlan 20,102,999
switchport mode trunk
interface Vlan1
no ip address
shutdown
!
interface Vlan999
ip address 10.99.X.X 255.255.0.0
!
ip default-gateway 10.99.1.1
Sho Vlan on Far Side

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Gi0/1, Gi0/2
20   VLAN0020                         active
102  VLAN0102                         active    Fa0/23
999  VLAN0999                         active    Fa0/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mages_mark Thu, 07/01/2010 - 12:36

--Nevermind - I had the bridge groups misconfigured on AP2.

Thanks for the help!

Mohamed Sobair Thu, 07/01/2010 - 10:40

Hi,

Mark: Glad it works, just a quick note: you dont need a Bridge-group on the BVI interface since its actually a layer-3 interface. I have corrected it. but for your APs to work, you need the BVI interface or simply they wouldnt be able to access internet or routed on the router.

Let me know if you understand Integrated routing bridging.

You need the following commands to be added:

bridge 2 protocol ieee

bridge 2 route ip

bridge 3 protocol ieee

bridge 3 route ip


and you have to setup a gateway for the bridges interfaces:

int bvi 2     (Gateway for Wireless users on vlan 102)

ip address x.x.x.x y.y.y.y.

int bvi 3     (Gateway for Wireless users on vlan 20)

ip address z.z.z.z f.f.f.f

It should work after that,

HTH

Mohamed

Actions

This Discussion