Establishing a VPN with iPad and RVS4000

Unanswered Question
Jul 1st, 2010
User Badges:

Hi,


I am hoping someone can help!  I am trying to configure a VPN from my iPad to the Cisco/Linksys RVS4000 router.  I have tried using the built-in Cisco client over IPSEC, L2TP, and PPTP.  For the life of me I cannot get it to work.  I would appreciate any insight on how to do this (if anyone has!).


Thanks in advance,


Phil

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.

I have not used a RVS4000, but I googled it and notice people mentioning using "QuickVPN" which as far as I can tell is not compatible with the Cisco VPN Client that is on the Apple devices(they connect to ASA's and PIXs). Although I have never used L2TP or PPTP versions of the cisco client. I would have thought they would be less proprietary.

jack.garabedian Wed, 07/07/2010 - 07:22
User Badges:

We have the same issue...Can't get the iPad to connect to the RVS4000....Tried everything...


If you configure a VPN user on the RVS4000, it just requires username and password but the iPad Cisco VPN client requires a shared key.


As Kenneth suggested, It looks like the RVS4000 client VPN only supports QuickVPN...


So, we configured a tunnel on the RVS4000 and tried to connect using PPTP and L2TP but no luck...


Anybody get this to work?

kenrandrews Wed, 07/07/2010 - 07:44
User Badges:

Have you done any debugging with commands like debug ppp error and debug vpdn error? If so what was the output?

jack.garabedian Wed, 07/07/2010 - 15:26
User Badges:

Here is the VPN log from the RVS4000...


#62: policy does not allow Extended Authentication (XAUTH) of initiator (we are responder). Attribute OAKLEY_AUTHENTICATION_METHOD

#64: OAKLEY_DES_CBC is not supported. Attribute OAKLEY_ENCRYPTION_ALGORITHM

#64: no acceptable Oakley Transform


I'm not sure how to pull the debug info from the iPad client...

llcckk1509 Wed, 07/07/2010 - 20:02
User Badges:

After much research, I came to the conclusion that the RVS4000 cannot connect to the built-in iPad VPN client.  The Cisco IPSec client does not work on the Cisco/Linksys small business line (it appears only QuickVPN works).   Also, since the RVS4000 does not have a native L2TP or PPTP server built-in, these protocols cannot be used either.


In short, I gave up on it and set up an iVPN server instead.  I have successfully connected my iPad to it via L2TP.


Cheers,


Phil

VinceWard Tue, 01/11/2011 - 16:37
User Badges:

With the new IPad Version 4.2.1 it appears to support L2TP  and PPTP. Has anyone tried to connect the IPad to a RVS4000 VPN with the new version software?

Actions

This Discussion