UCCE SQL 2000 to 2005 Upgrade

Unanswered Question
Jul 1st, 2010
User Badges:

Has anyone upgraded their SQL from 2000 to 2005 after in their UCCE environement?

I have been working on my lab and everytime I select the Workstation components the installation fails with some ambiguous error with and access denied.

Anyone encounter this?

Best regards,


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)

I've actually been doing this quite a few times in the last couple of weeks and know quite a few tricks.

I select SQL Server Database Services and Workstation components, then go into Workstation and deselect Books etc. to save a bit of space.

Normally Google resolves ambiguous errors.   What are you seeing?

If you have trouble with the upgrade, the alternative is to make a SQL Backup of your (say) logger database, put it somewhere safe, remove SQL 2000 completely and clean up the directory, then reboot and do a nice fresh install of 2005, apply SP2.

Then use RESTORE DATABASE out of Query Analyzer (I prefer the SQL statements to restore databases for a couple of reasons).  As it restores the database it upgrades it - and then you are good to go.

This takes the same time as an upgrade.

I had trouble trying to upgrade SQL 2000 Enterprise with SQL 2005 Enterprise - it complained that the "editions" were mismatched. But they were not. So that's how I determined the alternative to upgrading.



tkrisher193 Fri, 07/02/2010 - 07:26
User Badges:

Thanks Geoff.

I am by no means a SQL guy, so I did some more searching off the log files and found this.. http://support.microsoft.com/kb/916760

Core-Log output


Error: Action "InstallToolsAction.11" threw an exception during execution.  Error information reported during run:
Target collection includes the local machine.
Fatal Exception caught while installing package: "11"
        Error Code: 0x80070002 (2)
Windows Error Text: The system cannot find the file specified.

  Source File Name: sqlchaining\sqlprereqpackagemutator.cpp
Compiler Timestamp: Tue Aug  9 01:14:20 2005
     Function Name: sqls::SqlPreReqPackageMutator::modifyRequest
Source Line Number: 196

---- Context -----------------------------------------------

WinException caught while installing package. : 1603
        Error Code: 0x80070643 (1603)
Windows Error Text: Fatal error during installation.

  Source File Name: packageengine\installpackageaction.cpp
Compiler Timestamp: Fri Jul  1 01:28:25 2005
     Function Name: sqls::InstallPackageAction::perform
Source Line Number: 167

---- Context -----------------------------------------------


Followed the instructions and still no luck.

Go Mircosoft!

Followed the instructions and still no luck.

Go Mircosoft!

So by that you mean you followed the instructions I wrote above about making a backup of the DB, deleting SQL 2000 and doing a fresh install? That's certainly odd - never seen it, but that means little.

Can you find another server to try a SQL 2005 install?



tkrisher193 Fri, 07/02/2010 - 10:21
User Badges:

First I tried the instructions provided by Microsoft and then I tried your suggestion. Both failed because the issue was related to the install needing the second sql disk to install files regarding the collation for Latin1.

Originally I was extracting the ISO to the harddrive and installing from there and it couldn't find the files from disk 2.

Resolution is to mount (not extract) the ISO and install.

Thanks for the help.



This Discussion