QoS advice - LLQ with other classes still not giving me predictable behavior

Unanswered Question

I have a 3Mbit link from A to B. My policy-map looks like this:

Policy Map To_B

  Class VoiceRTP

      priority 512

  Class Control

      bandwidth 256

  Class VideoRTP

      bandwidth 1024

  Class Interactive

      bandwidth 1024

  Class class-default


Control is all the VoIP signaling protocols, icmp, eigrp, ospf, and snmp

Interactive is Citrix, ssh, and telnet

I did some testing and it seems that when there are amounts of class-default traffic, it is degrading the performance of everything else like VideoRTP and my ping latency jumps to 3000ms!

Does anyone have any advice?  I read somewhere that I should set the "bandwidth" setting on my interface to 90% of my actual bandwidth.  What do you think?

Vince

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Thanks for your reply, shh, here it is.

Packets are being marked with this policy on the inbound interface:

class-map match-any RTP-Video
   match protocol rtp video
   match access-group name CUVAVideo
class-map match-any Priority
   match protocol rtp audio
class-map match-any Control
   match protocol mgcp
   match protocol skinny
   match protocol h323
   match protocol sip
   match protocol icmp
   match protocol eigrp
   match protocol ospf
   match protocol snmp
class-map match-any Interactive
   match protocol citrix
   match protocol telnet
   match protocol ssh
   match access-group name ToCitrixServers

policy-map To_WAN

    class Priority

        set dscp ef
    class Control
        set dscp af41
    class RTP-Video
        set dscp af31
    class Interactive
        set dscp af21
    class class-default
        set dscp default

Here's the inbound interface:

interface GigabitEthernet0/0
    description to London_Core_Switch3560
    ip address 10.41.120.2 255.255.255.0
    ip nbar protocol-discovery
    ip pim sparse-dense-mode
    ip igmp join-group 239.1.1.2
    duplex auto
    speed auto
    h323-gateway voip interface
    h323-gateway voip bind srcaddr 10.41.120.2
    service-policy input To_WAN

Shaping and bandwidth policies are on the outbound interface.  Here is the config for the outbound policy:

class-map match-any EF
     match  dscp ef

class-map match-any AF41
    match  dscp af41

class-map match-any AF31
     match  dscp af31 
class-map match-any AF21
    match  dscp af21

policy-map To_Irvine
    class EF
        priority 512
    class AF41
        bandwidth 256
    class AF31
        bandwidth 768
    class AF21
        bandwidth 1024
    class class-default


policy-map To_Irvine_Shaper
    class class-default
        shape average percent 95
        service-policy To_Irvine

Here's the outbound interface:

interface FastEthernet0/0/0
    description SAVVIS To Irvine
    bandwidth 3088
    ip address 192.168.104.1 255.255.255.0
    duplex full
    speed 100
    service-policy output To_Irvine_Shaper

Actions

This Discussion

Related Content