802.11n with TKIP | WDS problem

Unanswered Question
Jul 2nd, 2010

Hi,

I am facing a weird problem when running traffic between two Access Points using WDS configured in 802.11n (WPA-PSK & TKIP encryption). The problem occurs when I send packets of size in the range (105 bytes - 112 bytes). The packets in this range are not getting transfered between the Access Points connected using WDS. Only the total size of the transmitted packet matters; packets not in the range are getting transfered fine.

I ran wireshark on the interfaces in the access points and I could see the packets on the transmitting WDS interface but not on the receiving WDS interface. The same does not happen in a Client - AP setup with WPA-PSK/TKIP. Both the boxes have broadcom chipset.

I have read that 802.11n is not compatible with TKIP but I don't face this problem in the Client-AP setup & in any case I was expecting just a speed degradation. I would appreciate any pointers in solving this problem.

Thanks for your time.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Stephen Rodriguez Tue, 07/06/2010 - 11:08

So to make sure I am reading this properly.

You sniff one AP, and you see the packets on the switch side.  You sniff the other AP, and do not see the packets there.  If that is the case, you would need to sniff the path between the AP to see where the packet is getting dropped.

voxnernet Tue, 07/06/2010 - 21:59

Thanks for your reply. That's what I was trying to do. But the 11n cards I had were not able to sniff the packets when I place them in Monitor mode.; with b/g they work fine.

I found that myproblem disappears when I disable MPDU Aggregation (A-MPDU) in one of the  APs. I was worried that the "incompatability" thing with respect to TKIP & 11n could have been a problem.

Actions

This Discussion

Related Content

 

 

Trending Topics - Security & Network