cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
727
Views
0
Helpful
1
Replies

dynamic NAT inside -> outside and static NAT outside -> inside on the same device

bartemye
Level 1
Level 1

I have a single router that I'd like to perform source and destination NAT at the same time.

Possible?

I.e.

interface FastEthernet0

ip nat outside

ip add 10.1.1.1.255.255.255.0

!

interface FastEthernet1

ip nat inside

ip add 192.168.1.1 255.255.255.0

!

ip nat inside source route-map dynamic_nat_map interface FastEthernet0 overload

ip nat outside source static 10.100.1.24 192.168.2.24

ip route 172.16.0.0 255.240.0.0 192.168.1.2

ip access-list extended dynamic_nat_acl

permit ip 172.16.0.0 255.240.0.0 192.168.2.0 0.0.0.255

!

route-map dynamic_nat_map permit 10

match ip address dynamic_nat_acl

!

I'd like users on 172.16.0.0/12 connect to 10.100.1.24, but they must appear as 192.168.1.1 and 10.100.1.24 needs to appear to them as 192.168.2.24

1 Reply 1

andrew.prince
Level 10
Level 10

Boris,

Where is the 172.16/12 ?

Where is the 10.100.1.x ?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco