Deskphone disabled on CUPC release 8.x

Answered Question
Jul 2nd, 2010
User Badges:

Deskphone disabled on CUPC release 8.x

Hello All,

We have a CUPS release 8 that runs fine on CUPC release 7.x. Yesterday we upgraded the CUPC client to 8.x and now the deskphone feature is greyed out. Chat and all other features are working except the deskphone.

When we test this with CUPC 7 it works at the same time with the same user accounts. Please assist on this.

When I check the Server health the notification is " failed to connect to ccmcip authentication server"

Is this related to the Deskphone ?

Is there any additional configuration that needs to be done on CUPS for CUPC 8.x other than what was done for CUPC 7.x

Correct Answer by htluo about 6 years 11 months ago

Per the log, your certificate on CUCM was expired.  You should regenerate the Tomcat cert.


1) Log into CUCM OS Administration page

2) Security > Certificate Management.  Click "Find" to list all certs.

3) Click on "tomcat.pem"

4) Click on "Regenerate"

5) On command line, type "utils service restart Cisco Tomcat"


Michael

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (4 ratings)
Loading.
htluo Fri, 07/02/2010 - 07:29
User Badges:
  • Red, 2250 points or more

CUPC 8 uses CCMCIP service on CUCM to retrieve the "controlled device".


Please make sure you configured CCMCIP address correctly from CUPS > Application > Cisco Unified Personal Communicator.


I recommend you take a look at http://www.lulu.com/content/5552336.  It covers CUPS 8 and CUPC 8 configuration.


Thanks!

Michael

http://htluo.blogspot.com

abraham23482 Fri, 07/02/2010 - 08:09
User Badges:

Hello


I configured the CCMCIP Settings, however still the Deskphone is greyed out.. Please check my screenshot

Attachment: 
abraham23482 Fri, 07/02/2010 - 23:50
User Badges:

Dear Mike,


I am sorry to say I did terminate this process but the same result. Only the Deskphone is still greyed out.. Do you see any other reasons why this is happening. The funniest part is CUPC 7 works so well with the same user ids..

htluo Sat, 07/03/2010 - 07:42
User Badges:
  • Red, 2250 points or more

If CUPC7 works fine but CUPC8 doesn't, it has to be CCMCIP issue.  What error message you got on CUPC8?


Michael

abraham23482 Sat, 07/03/2010 - 08:11
User Badges:

The error message is


" Device initialization error has occured. Failed to connect to ccmcip authentication server [1201]"


I know there is something wrong with the CCMCIP settings but cant identify what and I am not sure if the CCMCIP settings that I gave was correct. Screenshot of CCMCIP settings was attached in the previous post.


Another point I noted is, In CUPC 7 also if I check the server health status the phone configuration is down. But still deskphone feature works in 7.x may be because it is failing over to a backup config residing locally.

htluo Sat, 07/03/2010 - 08:17
User Badges:
  • Red, 2250 points or more

Create or Modify the following registry key


  • HKEY_CURRENT_USER\Software\Cisco Systems, Inc.\Client Services  Framework\AdminData\CcmcipServerValidation
  • Type  : String / REG_SZ
  • Value : 0


After that, kill cucsf.exe from Task Manager.


Details: http://www.cisco.com/en/US/docs/voice_ip_comm/cucimoc/7_1/english/integrat/guide/config_clients.html#wp1054938


Michael

http://htluo.blogspot.com

abraham23482 Sat, 07/03/2010 - 08:49
User Badges:

HI


I made the changes above and no luck.. I am attaching the problem report here. Could you please verify this and let me know If you find any issues.

htluo Sat, 07/03/2010 - 08:53
User Badges:
  • Red, 2250 points or more

How did you get the report?  It should be a single big zip file on your desktop other than three small files.


Michael

htluo Sat, 07/03/2010 - 09:09
User Badges:
  • Red, 2250 points or more

Per the log, it's still the CCMCIP certificate issue.


Could you export your registry hive HKEY_CURRENT_USER/Software/Cisco Systems, Inc./AdminData/ and upload here?


Thanks!

Michael

htluo Sat, 07/03/2010 - 09:21
User Badges:
  • Red, 2250 points or more

Per the registry, you didn't follow my previous suggestion to set "CcmcipServerValidation" to "0".


In your registry, it's still "1":


Michael

abraham23482 Sat, 07/03/2010 - 09:29
User Badges:

Oops sorry about that. I had reverted the change last time when it was not working now again made it to 0 with no luck.


:(

htluo Sat, 07/03/2010 - 09:32
User Badges:
  • Red, 2250 points or more

Don't complicate the problem by keep changing settings. 


Now with the value set to "0", do the following:


1) Kill cucsf.exe from Task Manager.

2) Recreate the problem.

3) Generate problem report

4) Upload Problem report and registry export again.


Michael

htluo Sat, 07/03/2010 - 10:10
User Badges:
  • Red, 2250 points or more

There's no more CCMCIP cert error in the latest logs.


So what's the problem right now?


Michael

abraham23482 Sun, 07/04/2010 - 02:46
User Badges:

Hi,


Attached is the screenshot with the status of the client. Somehow I am unable to get this thing working. However 7x client is working perfectly.

htluo Sun, 07/04/2010 - 06:53
User Badges:
  • Red, 2250 points or more

It depends on WHEN you got that error.


Per the log, the last time of the CCMCIP error was:

Jul03_21:58:15 : Cannot validate CCMCIP HTTPS certificate (line 4564)


Did you get the error before or after Jul03_21:58:15?


Did you restart cucsf.exe after you change the registry?


The last CUPC session started at 2010-07-03 22:03:51.  But the log only contains the information up to 2010-07-03 22:04:00 (9 seconds since CUPC last restarted).  We won't be able to see too much info in 9 seconds.


You may do this:


1) Exit CUPC 8 and kill cucsf.exe.

2) Delete old logs in %userprofile%\Local Settings\Application Data\Cisco\Unified Communications\Client Services Framework\Logs

3) Make sure registry was set to 0

4) Lauch CUPC 8

5) Wait for at least 1 minute after logged in.

6) See if you can get the desk phone control

7) If not, generate problem report again.


Michael

abraham23482 Sun, 07/04/2010 - 09:37
User Badges:

Hi


I think I got the problem...


We edited the Registry value and made it 0 so that it ignores the certificate validation process. Now by doing this, we got the CUCIMOC to work. But the CUPC is still going for the certificate validation process.


Here's what I found from the logs of problem report.


---------------------------------------------------------------------------------


2010-07-04 21:18:42,889 DEBUG [ws-pool-thread-2] [CCMCIPProvider] [CCMCIPProviderImpl.fetchDeviceList(90)] - Attempting to connect to primary CCMCIP host: 172.22.16.10
2010-07-04 21:18:42,889 WARN  [ws-pool-thread-2] [CCMCIPProvider] [CCMCIPClient.fetchDevices(241)] - Unknown certification level, setting it to SELF_SIGNED_CERTS.  Unknown level value:
2010-07-04 21:18:42,889 INFO  [ws-pool-thread-2] [CCMCIPProvider] [CCMCIPClient.fetchDevices(244)] - Setting certification level to '1' (SELF_SIGNED_CERTS)
2010-07-04 21:18:42,905 ERROR [ws-pool-thread-2] [CCMCIPProvider] [CCMCIPClient.fetchDevices(277)] - IOException: java.security.cert.CertificateExpiredException: NotAfter: Thu Jul 01 13:20:51 IST 2010
2010-07-04 21:18:42,905 INFO  [ws-pool-thread-2] [CCMCIPProvider] [CCMCIPProviderImpl.fetchDeviceList(117)] - Trying backup CCMCIP host: 172.22.16.10
2010-07-04 21:18:42,905 WARN  [ws-pool-thread-2] [CCMCIPProvider] [CCMCIPClient.fetchDevices(241)] - Unknown certification level, setting it to SELF_SIGNED_CERTS.  Unknown level value:
2010-07-04 21:18:42,905 INFO  [ws-pool-thread-2] [CCMCIPProvider] [CCMCIPClient.fetchDevices(244)] - Setting certification level to '1' (SELF_SIGNED_CERTS)
2010-07-04 21:18:42,905 ERROR [ws-pool-thread-2] [CCMCIPProvider] [CCMCIPClient.fetchDevices(277)] - IOException: java.security.cert.CertificateExpiredException: NotAfter: Thu Jul 01 13:20:51 IST 2010
2010-07-04 21:18:42,905 ERROR [ws-pool-thread-2] [CCMCIPProvider] [CCMCIPProviderImpl.fetchDeviceList(122)] - Couldn't connect to any CCMCIP host
2010-07-04 21:18:42,905 WARN  [ws-pool-thread-2] [DeviceService] [DeviceServiceCoreImpl.populateCCMCIP(1533)] - Couldn't connect to any CCMCIP host. Sending async error.
2010-07-04 21:18:42,920 DEBUG [ws-pool-thread-2] [EventAdapter] [EventAdapterImpl.publish(140)] - publish method = onError class = com.cisco.uc.core.broker.phone.device.DeviceServiceCallback
2010-07-04 21:18:42,920 DEBUG [ws-pool-thread-2] [EventAdapter] [BaseClientProxy.publish(109)] - Adding callback to queue : onError priority message true
2010-07-04 21:18:42,920 WARN  [ws-pool-thread-2] [DeviceService] [DeviceServiceCoreImpl.populateCCMCIP(1551)] - CCMCIP host is unreachable.  Trying to use the last used softphone device.
2010-07-04 21:18:42,920 ERROR [ws-pool-thread-2] [DeviceService] [DeviceServiceCoreImpl.isSRSTConfigured(1642)] - Couldn't connect to any CCMCIP host and no softphone device is available.
2010-07-04 21:18:42,920 DEBUG [SOAPCallback - CcClient-1] [EventAdapter] [PendingCallbackQueue.poll(151)] - Taking callback from queue : onError primary queue size 0 secondary queue size 0
2010-07-04 21:18:42,920 ERROR [ws-pool-thread-2] [DeviceService] [DeviceServiceCoreImpl.populateCCMCIP(1569)] - Couldn't connect to any CCMCIP host and no softphone device is available.
2010-07-04 21:18:42,920 DEBUG [SOAPCallback - CcClient-1] [EventAdapter] [SoapCallbackClientProxyImpl.processCallback(98)] - Notifying clientID CcClient-1 of onError on callback URL http://127.0.0.1:44442/v2/
2010-07-04 21:18:42,920 ERROR [ws-pool-thread-2] [DeviceAdapter] [DeviceServiceImpl.initialize(435)] - Problem initializing on the Device service. Could not connect to CCMCIP
com.cisco.uc.core.common.exceptions.device.CCMCIPFailureCoreException: Could not connect to CCMCIP

____________________________________________________________________________________________________


I am attaching the Admin Data Registry settings. Please refer this.


Abraham

Attachment: 
htluo Sun, 07/04/2010 - 10:50
User Badges:
  • Red, 2250 points or more

Did you install CUCIMOC and CUPC 8 on the same computer?  That is not supported.  Sorry I was confusing you with the word CUCIMOC while I acutally meant CUPC.


Could you upload CUPC problem report with registry set to 0?


Michael

abraham23482 Mon, 07/05/2010 - 00:22
User Badges:

Hi


I uninstalled everything that is related to CUCIMOC

Reinstalled the CUPC client 8.x

Restarted the Client PC

I have associated a softphone to the client and this works well with the same user id on a CUPC 7.x


Still the same problem that is the deskphone is disabled and I cannot make calls throught the client 8.x.


Attached is the problem report along with the registry settings. Please verify this.



Thanks in Advance

Abraham

Attachment: 
abraham23482 Mon, 07/05/2010 - 01:52
User Badges:

Hi


I filtered the core log from the Problem report that I generated now. Please see this. In BOLD


2010-07-05 12:03:11,140 ERROR [ws-pool-thread-2] [CCMCIPProvider] [CCMCIPClient.fetchDevices(277)] - IOException: java.security.cert.CertificateExpiredException: NotAfter: Thu Jul 01 13:20:51 IST 2010
2010-07-05 12:03:11,140 INFO  [ws-pool-thread-2] [CCMCIPProvider] [CCMCIPProviderImpl.fetchDeviceList(117)] - Trying backup CCMCIP host: 172.22.16.10
2010-07-05 12:03:11,140 WARN  [ws-pool-thread-2] [CCMCIPProvider] [CCMCIPClient.fetchDevices(241)] - Unknown certification level, setting it to SELF_SIGNED_CERTS.  Unknown level value:
2010-07-05 12:03:11,140 INFO  [ws-pool-thread-2] [CCMCIPProvider] [CCMCIPClient.fetchDevices(244)] - Setting certification level to '1' (SELF_SIGNED_CERTS)
2010-07-05 12:03:11,140 ERROR [ws-pool-thread-2] [CCMCIPProvider] [CCMCIPClient.fetchDevices(277)] - IOException: java.security.cert.CertificateExpiredException: NotAfter: Thu Jul 01 13:20:51 IST 2010
2010-07-05 12:03:11,140 ERROR [ws-pool-thread-2] [CCMCIPProvider] [CCMCIPProviderImpl.fetchDeviceList(122)] - Couldn't connect to any CCMCIP host
2010-07-05 12:03:11,140 WARN  [ws-pool-thread-2] [DeviceService] [DeviceServiceCoreImpl.populateCCMCIP(1533)] - Couldn't connect to any CCMCIP host. Sending async error.
2010-07-05 12:03:11,156 DEBUG [ws-pool-thread-2] [EventAdapter] [EventAdapterImpl.publish(140)] - publish method = onError class = com.cisco.uc.core.broker.phone.device.DeviceServiceCallback
2010-07-05 12:03:11,156 DEBUG [ws-pool-thread-2] [EventAdapter] [BaseClientProxy.publish(109)] - Adding callback to queue : onError priority message true
2010-07-05 12:03:11,156 DEBUG [SOAPCallback - CcClient-1] [EventAdapter] [PendingCallbackQueue.poll(151)] - Taking callback from queue : onError primary queue size 0 secondary queue size 0
2010-07-05 12:03:11,156 WARN  [ws-pool-thread-2] [DeviceService] [DeviceServiceCoreImpl.populateCCMCIP(1551)] - CCMCIP host is unreachable.  Trying to use the last used softphone device.
2010-07-05 12:03:11,156 DEBUG [SOAPCallback - CcClient-1] [EventAdapter] [SoapCallbackClientProxyImpl.processCallback(98)] - Notifying clientID CcClient-1 of onError on callback URL http://127.0.0.1:44442/v2/
2010-07-05 12:03:11,156 ERROR [ws-pool-thread-2] [DeviceService] [DeviceServiceCoreImpl.isSRSTConfigured(1642)] - Couldn't connect to any CCMCIP host and no softphone device is available.
2010-07-05 12:03:11,156 ERROR [ws-pool-thread-2] [DeviceService] [DeviceServiceCoreImpl.populateCCMCIP(1569)] - Couldn't connect to any CCMCIP host and no softphone device is available.
2010-07-05 12:03:11,171 WARN  [SOAPCallback - CcClient-1] [DeviceService] [DeviceCallback.onError(242)] - OnError sent to the client.

Correct Answer
htluo Mon, 07/05/2010 - 07:25
User Badges:
  • Red, 2250 points or more

Per the log, your certificate on CUCM was expired.  You should regenerate the Tomcat cert.


1) Log into CUCM OS Administration page

2) Security > Certificate Management.  Click "Find" to list all certs.

3) Click on "tomcat.pem"

4) Click on "Regenerate"

5) On command line, type "utils service restart Cisco Tomcat"


Michael

abraham23482 Mon, 07/05/2010 - 11:41
User Badges:

Hi Mike,


Thank you so much. I did the changes you pointed out and it is working now.. All features are up and running fine and feels great to see the new client work in full swing.


thanks again.



Abraham

tenaro.gusatu.novici Tue, 07/06/2010 - 09:45
User Badges:

Hi there,


any chance you can share with us if softphone mode is working for you? I'm able to initiate calls from CUPC (which is then going to use my deskphone) but I'm not sure what to do so I can make calls directly from CUPC8, while I'm out-of-office.


Best regards,

Tenaro

abraham23482 Tue, 07/06/2010 - 10:58
User Badges:

Hi,


I have a CUPC 8 client running fine with softphone now. Everything works perfect.


Are you sure you have mapped the softphone device to the user and associated the user to the softphone ?

pruttman Tue, 07/27/2010 - 09:28
User Badges:

How do you flip between softphone mode and deskphone modein CUPC 8?  I don't see the option like I do in CUPC 7.


Pete

benjaminwatt Tue, 07/27/2010 - 11:23
User Badges:
  • Bronze, 100 points or more

There's a tickbox at the bottom of CUPC 8 that will either say 'Use my desk phone for audio' or something like 'Use my Cisco 7971 for audio' depending on the model of Cisco phone you're using. When it's ticked you're in desk phone mode, when it's not you're in soft phone mode.

htluo Tue, 07/27/2010 - 11:26
User Badges:
  • Red, 2250 points or more

ya, the funny thing is - if there's no checkbox, you don't know if you're in soft phone or desk phone. 


Michael

http://htluo.blogspot.com

pruttman Tue, 07/27/2010 - 12:36
User Badges:

I see no checkbox, but it does say "User my Cisco 7960 for audio".  If I click on "cisco 7960" I get the Select Desk Phone Device" option, but no where do I see the ability to change to soft phone.


My phone is operating successfully in deskphone mode.


Thanks,


Pete

benjaminwatt Tue, 07/27/2010 - 13:05
User Badges:
  • Bronze, 100 points or more

There's probably other causes of this too, but the most likely explanation for this is that you haven't created a CSF (Cisco Unified Client Services Framework) phone device, and added it to the 'Controlled Devices' of that user.


CUPC 8 doesn't use the UPC (Cisco Unified Personal Communicator) type anymore as I understand it, so to get softphone functionality you need to create a CSF device for each user instead.


Desk phone control will work regardless of whether you have a CSF device or not.

abraham23482 Tue, 07/27/2010 - 15:09
User Badges:

Another thing I've noticed is, If I give 2 lines to my deskphone or softphone and associate that to my cups user ID, both the lines will display in the client but you cannot switch from one to the other. Wonder why then it is displayed there...



Abraham

pruttman Tue, 07/27/2010 - 15:20
User Badges:

I created a CSF device and a CCMCIP Profile and the checkbox appeared so I can now toggle between softphone and deskphone.  Thanks!


Pete

m.ranger Thu, 09/02/2010 - 08:29
User Badges:

Hello all,

I have the same problem, but not with all phones.

My setup is working with 8961 and 9971 Phones. All my Users are working with extension mobility and all of them have CUPC8.

For Users with a 8961 Phone and a Device Profil for 8961 Phones everything is working fine (Softphone Mode and Deskphone Mode).


For Users with a 9971 Phone and a Device Profil for 9971 Phones I have the same behaviour and the same error messages as descrived by Abraham23482.

I did the registry changes and recreated the tomcat.pem, but no change in the behaviour.


Attached my problem report.


Any ideas?


Best regards

Manfred

shamkumar Tue, 09/21/2010 - 11:14
User Badges:

Hi delete the presence dns which u created using UPCXXX(Cisco Unified Personal Communicator) in CUCM and create with CSFXXXX( Cisco Unified Client Services FrameWork) restart the CUPC client 8.x every thing will work now....deskphone controle and multiple deskphone controles......

upchaurasia Fri, 10/29/2010 - 05:43
User Badges:

Hi,


I am facing some issues similar to this post and need expert help here. First let me explin my setup-


I have CUCM 8.x, CUPS 8.x and CUPC 8.0.171.

I have configured LDAP in CUCM and CUPS and created CUPC devices in CUCM and associated Cisco IP phone.

I am able to make call from my CUPC client but unable to initiate "Chat", when I click on "Chat" option I am getting "Invalid Parameter" error.


Otherthing I am able to search contact from my Microsoft AD. I have created LDAP profile in CUPS and able to import users from AD to CUCM and CUCM to CUPS. I am confused with the "Search Context" parameter in LDAP profile, what should I specify here.


I am attching logs.

Your suggestion will help me to move forward.


Thanks & Regards,

Umesh

Actions

This Discussion